webex-logowebex-logoHelp Center
  • Ctrl K
    • Get started
    • Help by product
    • Administration
    • What's new
    • Support

      Join a meeting
      Developer ToolsDeveloper Tools
      Webex AdoptionWebex Adoption
      Contact Support

      learn

      Video resources
      Webex AcademyWebex Academy
      Live Events and WebinarsLive Events and Webinars
      Webex BlogWebex Blog

      programs

      Webex CommunityWebex Community
      Webex InsiderWebex Insider
      App HubApp Hub
      Cisco AI Assistant

      Cisco AI Assistant

      The most advanced generative AI-powered platform for hybrid work and customer experience.

      Learn more →
      webexDownload Webex
      +1-888-469-3239Contact Sales →
    • Ctrl K
      • Dansk
      • Deutsch
      • English language tick
      • Español
      • Français
      • Italiano
      • Nederlands
      • Português
      • Pyccĸий
      • Svenska
      • Tϋrkçe
      • 한국어
      • 日本語
      • 简体中文
      • 繁體中文
      • Română
      • Magyar
      • Polski
      • Čeština
      • Български
      • Norsk
      • Hrvatski
      • Srpski
      • Українська
      • العربية
      • עברית
      • Suomi
      • Slovenščina
      • Slovenský
    • Home
    • /
    • Article
    Was this article helpful?
    close

    Thanks for your feedback.

    May 13, 2025 | 25807 view(s) | 34 people thought this was helpful
    I Can't Pair a Touch 10 to a Cisco Endpoint or Cisco Webex Room Device
    list-menuFeedback?

    I can't pair a Touch 10 to a Cisco endpoint or Cisco Webex room device.

    Touch 10 is not updating

    Touch 10 is not pairing to Cisco endpoint

    Possible Causes:

    • Cisco Touch 10 devices must be paired with endpoints or room devices before the endpoint is activated on Webex.
    • If connecting the Touch 10 over the network (LAN) the Touch 10 must be on the same subnet as the Webex room device.
    • The room device must have been restarted within the last 10 minutes. If the room device doesn’t appear in the list, try restarting it.


    If the Touch 10 is not paired when the endpoint is activated, it may not be able to pair successfully, will not receive system updates, and won't retain any changes to the settings.

    Note: Cisco TAC only supports a single Touch 10 per room device.

    Solution:

    If the Touch10 was not paired when the endpoint was activated, do the following:

    1. Unplug the Touch 10 from the endpoint.
    2. Factory Reset the Touch 10.
    For help, see:
    • Factory Reset a Cisco Touch 10
    1. After the Touch 10 is reset, reconnect it to the Power over Ethernet (PoE) injector in the endpoint's frame.

     

    For help, see:
    • Touch 10 Installation Guide for Web
    • Connect Touch 10 to a Room Device Over the Network (LAN)
    1. Once the Touch 10 is connected to power, the set-up procedure begins. Follow the instructions on the screen.
    2. After the Touch 10 is paired, activate the endpoint again.

    Was this article helpful?
    Was this article helpful?
    PricingWebex AppMeetingsCallingMessagingScreen Sharing
    Webex SuiteCallingMeetingsMessagingSlidoWebinarsEventsContact CenterCPaaSSecurityControl Hub
    HeadsetsCamerasDesk SeriesRoom SeriesBoard SeriesPhone SeriesAccessories
    EducationHealthcareGovernmentFinanceSports & EntertainmentFrontlineNonprofitsStartupsHybrid Work
    DownloadsJoin a Test MeetingOnline ClassesIntegrationsAccessibilityInclusivityLive & On-Demand WebinarsWebex CommunityWebex DevelopersNews & Innovations
    CiscoContact SupportContact SalesWebex BlogWebex Thought LeadershipWebex Merch StoreCareers
    • X
    • LinkedIn
    • Facebook
    • Youtube
    • Instagram
    Terms & ConditionsPrivacy StatementCookiesTrademarks
    ©2026 Cisco and/or its affiliates. All rights reserved.
    Terms & ConditionsPrivacy StatementCookiesTrademarks