- الرئيسية
- /
- المقال
يسمح تكوين SIP المناسب لهواتفك بالتسجيل في خادم SIP لإجراء المكالمات وتلقيها. الإعدادات خاصة بالهاتف بشكل عام وللإضافات. تتناول مقالة التعليمات هذه سلسلة هواتف Cisco المكتبية 9800 وهاتف فيديو Cisco 8875 المسجل في Cisco BroadWorks.
تكوين إعدادات SIP للهاتف
| 1 |
قم بالوصول إلى صفحة الويب الخاصة بإدارة الهاتف. |
| 2 |
حدد . |
| 3 |
قم بتكوين المعلمات كما هو موضح في المعلمات الخاصة بإعدادات SIP للهاتف |
| 4 |
انقر فوق إرسال جميع التغييرات. |
المعلمات الخاصة بإعدادات SIP للهاتف
تتوفر المعلمات التالية في علامة التبويب على صفحة الويب الخاصة بإدارة الهاتف. راجع الجداول التالية لمعرفة المعلمات ذات الصلة:
المعلمات العامة
يصف الجدول التالي معاملات SIP المتوفرة في قسم معلمات SIP.
|
المعلمة |
وصف |
|---|---|
|
ماكس فوروارد |
يحدد قيمة SIP القصوى لإعادة التوجيه. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: من 1 إلى 255 الافتراضي: 70 |
|
الحد الأقصى لإعادة التوجيه |
يحدد عدد المرات التي يمكن فيها إعادة توجيه الدعوة لتجنب التكرار اللانهائي. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 5 |
|
ماكس أوث |
يحدد الحد الأقصى لعدد المرات (من 0 إلى 255) التي يمكن فيها الطعن في الطلب. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: من 0 إلى 255 الإعداد الافتراضي: 2 |
|
اسم وكيل مستخدم SIP |
تستخدم في الطلبات الصادرة. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: $VERSION إذا كان العنوان فارغًا، فلن يتم تضمين العنوان. التوسع الكلي من $ A إلى $D المقابل لـ المسموح به GPP_A GPP_D |
|
اسم خادم SIP |
رأس الخادم المستخدم في الردود على الردود الواردة. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: $VERSION |
|
اسم وكيل مستخدم SIP Reg |
اسم وكيل المستخدم الذي سيتم استخدامه في طلب التسجيل. إذا لم يتم تحديد ذلك، فسيتم استخدام اسم وكيل مستخدم SIP أيضًا لطلب REGISTER. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
|
لغة قبول SIP |
قبول اللغة التي استخدمها العنوان. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
لا يوجد إعداد افتراضي. إذا كان العنوان فارغًا، فلن يتم تضمين العنوان. |
|
نوع MIME لترحيل DTMF |
نوع MIME المستخدم في رسالة SIP INFO للإشارة إلى حدث DTMF. يجب أن يتطابق هذا الحقل مع حقل مزود الخدمة. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: التطبيق/dtmf-relay |
|
نوع هوك فلاش MIME |
يُستخدم نوع MIME في رسالة SIPINFO للإشارة إلى حدث فلاش خطافي. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: التطبيق/hook-flash |
|
إزالة السجل الأخير |
يتيح لك إزالة التسجيل الأخير قبل تسجيل تسجيل جديد إذا كانت القيمة مختلفة. اضبط على نعم لإزالة التسجيل الأخير. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
استخدم رأس مضغوط |
في حالة الضبط على «نعم»، يستخدم الهاتف رؤوس SIP المدمجة في رسائل SIP الصادرة. إذا كانت طلبات SIP الواردة تحتوي على رؤوس عادية، فإن الهاتف يستبدل الرؤوس الواردة برؤوس مضغوطة. في حالة الضبط على «لا»، تستخدم الهواتف رؤوس SIP العادية. إذا كانت طلبات SIP الواردة تحتوي على رؤوس مضغوطة، فإن الهواتف تعيد استخدام نفس الرؤوس المضغوطة عند إنشاء الاستجابة، بغض النظر عن هذا الإعداد. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
اسم عرض الهروب |
تمكنك من الحفاظ على خصوصية اسم العرض. اضبط على نعم إذا كنت تريد أن يقوم هاتف IP بإرفاق السلسلة (التي تم تكوينها في اسم العرض) في زوج من علامات الاقتباس المزدوجة لرسائل SIP الصادرة. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
حزمة التحدث |
يتيح دعم حزمة BroadSoft Talk التي تتيح للمستخدمين الرد على مكالمة أو استئنافها بالنقر فوق زر في تطبيق خارجي. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
حزمة الانتظار |
يتيح دعم حزمة BroadSoft Hold Package، التي تتيح للمستخدمين وضع مكالمة قيد الانتظار بالنقر فوق زر في تطبيق خارجي. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
حزمة المؤتمر |
يتيح دعم حزمة BroadSoft Conference Package التي تمكن المستخدمين من بدء مكالمة جماعية بالنقر فوق زر في تطبيق خارجي. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
تعليق المكالمات وفقًا للمعيار RFC 2543 |
في حالة التعيين إلى نعم، تتضمن الوحدة صيغة c=0.0.0.0 في SDP عند إرسال دعوة SIP Re-invite إلى النظير لإجراء المكالمة. في حالة التعيين إلى لا، لن تتضمن الوحدة صيغة c=0.0.0.0 في SDP. ستتضمن الوحدة دائمًا صيغة a=sendonly في SDP في كلتا الحالتين. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: نعم |
|
REG CID عشوائي عند إعادة التشغيل |
في حالة الضبط على «نعم»، يستخدم الهاتف معرف مكالمة عشوائي مختلفًا للتسجيل بعد إعادة تشغيل البرنامج التالي. في حالة الضبط على «لا»، يحاول هاتف Cisco IP استخدام نفس معرف الاتصال للتسجيل بعد إعادة تشغيل البرنامج التالي. يستخدم هاتف Cisco IP دائمًا معرف مكالمة عشوائي جديد للتسجيل بعد دورة الطاقة، بغض النظر عن هذا الإعداد. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
الحد الأدنى لمنفذ SIP TCP |
يحدد أقل رقم منفذ TCP يمكن استخدامه لجلسات SIP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 5060 |
|
منفذ SIP TCP كحد أقصى |
يحدد أعلى رقم منفذ TCP يمكن استخدامه لجلسات SIP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 5080 |
|
عنوان معرف المتصل |
يوفر خيار أخذ معرف المتصل من عنوان PAID-RPID-FROM أو PAID-FROM أو RPID-PAID-FROM أو RPID-FROM أو FROM. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: مدفوع من | مساعدة من | سريع مدفوع من | سريع - من | من الإعداد الافتراضي: الدفع السريع |
|
امسك الهدف قبل الإحالة |
يتحكم في ما إذا كان سيتم الاحتفاظ بساق المكالمة مع هدف التحويل قبل إرسال REFER إلى المنقول إليه عند بدء تحويل مكالمة تحت إشراف كامل (حيث أجاب هدف النقل). لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
تمكين مربع حوار SDP |
عند التمكين ويكون نص رسالة Notify كبيرًا جدًا مما يتسبب في التجزئة، يتم تبسيط مربع حوار xml الخاص برسالة Notify؛ لا يتم تضمين بروتوكول وصف الجلسة (SDP) في محتوى xml الخاص بحوار الحوار. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
احتفظ بالحكم عند فشل الإحالة |
في حالة الضبط على «نعم»، يقوم بتكوين الهاتف للتعامل مع رسائل NOTIFY sipfrag على الفور. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
معلومات تحويل العرض |
اعرض معلومات التحويل المضمنة في رسالة SIP على شاشة LCD أم لا. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
عرض مجهول من العنوان |
اعرض معرف المتصل من عنوان رسالة SIP INVITE «من» عند التعيين إلى نعم، حتى إذا كانت المكالمة مكالمة مجهولة. عند ضبط المعلمة على «لا»، يعرض الهاتف «Anonymous Caller» كمعرف المتصل. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
قبول ترميز Sip |
يدعم ميزة gzip لترميز المحتوى. إذا تم تحديد gzip، فإن رأس رسالة SIP يحتوي على السلسلة «Accept-Encoding: gzip»، ويكون الهاتف قادرًا على معالجة نص رسالة SIP، والذي يتم ترميزه بتنسيق gzip. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: لا شيء و gzip الإعداد الافتراضي: لا شيء |
|
تفضيلات بروتوكول الإنترنت الخاصة بـ SIP |
يضبط ما إذا كان الهاتف يستخدم IPv4 أو IPv6. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: IPv4 | IPv6 الإعداد الافتراضي: IPv4 |
|
تعطيل الاسم المحلي لرأس الصفحة |
يتحكم في اسم العرض في «الدليل» و «سجل المكالمات» وفي رأس «إلى» أثناء مكالمة صادرة. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
مؤقت OffHook المفضل من قبل المستخدم |
الوقت (بالثواني) الذي ينتظره الهاتف بعد إيقاف الاتصال قبل بدء الاتصال.
وعند تكوين هذا الإعداد، يكون له الأسبقية على لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 0-30 الإعداد الافتراضي: فارغ |
| نوع حزمة حدث شارك لاين |
يقوم بتمكين الخط المشترك المستند إلى مربع الحوار، بحيث يمكن للهواتف الموجودة في السطر المشترك الاشتراك في حزمة حدث الحوار. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: معلومات الاتصال | مربع الحوار الإعداد الافتراضي: معلومات الاتصال |
| تم تمديد مصادقة SIP Notify |
يتيح المصادقة المحسّنة لطلبات SIP NOTIFY خارج مربع الحوار المستلمة عبر UDP عند تعطيل Block Nonproxy SIP.
لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
قيم مؤقت SIP
يصف الجدول التالي معاملات SIP المتوفرة في قسم قيم SIP Timer.
|
المعلمة |
وصف |
|---|---|
|
SIP T1 |
قيمة RFC 3261 T1 (تقدير RTT) التي يمكن أن تتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 0.5 ثانية |
|
SIP T2 |
قيمة RFC 3261 T2 (الحد الأقصى للفاصل الزمني لإعادة الإرسال للطلبات غير الداعية واستجابات INVITE) التي يمكن أن تتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 4 ثوانٍ |
|
SIP T4 |
قيمة RFC 3261 T4 (الحد الأقصى لمدة بقاء الرسالة في الشبكة)، والتي يمكن أن تتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 5 ثوانٍ. |
|
مؤقت SIP B |
قيمة مهلة INVITE، والتي يمكن أن تتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 16 ثانية. |
|
جهاز ضبط الوقت F |
قيمة مهلة عدم الدعوة، والتي يمكن أن تتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 16 ثانية. |
|
جهاز ضبط الوقت السريع |
قم بدعوة الاستجابة النهائية، قيمة المهلة، والتي يمكن أن تتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 16 ثانية. |
|
جهاز ضبط الوقت D |
وقت تعليق ACK، والذي يمكن أن يتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 16 ثانية. |
|
جهاز ضبط الوقت J |
وقت التوقف عن الاستجابة بدون دعوة، والذي يمكن أن يتراوح من 0 إلى 64 ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 16 ثانية. |
|
تنتهي صلاحية الدعوة |
تنتهي قيمة العنوان لطلب الدعوة. إذا قمت بإدخال 0، فلن يتم تضمين عنوان انتهاء الصلاحية في الطلب. تتراوح من 0 إلى 2000000. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 240 ثانية |
|
تنتهي صلاحية إعادة الدعوة |
طلب إعادة الدعوة تنتهي قيمة العنوان. إذا قمت بإدخال 0، فلن يتم تضمين عنوان انتهاء الصلاحية في الطلب. تتراوح من 0 إلى 2000000. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 30 |
|
تنتهي صلاحية ريج مين |
الحد الأدنى لوقت انتهاء التسجيل المسموح به من الوكيل في رأس انتهاء الصلاحية أو كمعامل رأس جهة الاتصال. إذا قام الوكيل بإرجاع قيمة أقل من هذا الإعداد، يتم استخدام الحد الأدنى للقيمة. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 1 |
|
تنتهي صلاحية ريج ماكس |
الحد الأقصى لوقت انتهاء التسجيل المسموح به من الوكيل في عنوان Min-Expires . إذا كانت القيمة أكبر من هذا الإعداد، يتم استخدام القيمة القصوى. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 7200 |
|
ريج ريتري إنتي في |
فاصل زمني للانتظار قبل أن يقوم هاتف Cisco IP Phone بإعادة محاولة التسجيل بعد الفشل أثناء التسجيل الأخير. يتراوح النطاق من 1 إلى 2147483647 لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 30 انظر الملاحظة أدناه للحصول على تفاصيل إضافية. |
|
ريج ريتري لفترة طويلة |
عند فشل التسجيل مع رمز استجابة SIP غير <Retry Reg RSC>المطابق، ينتظر هاتف Cisco IP المدة الزمنية المحددة قبل إعادة المحاولة. إذا كانت هذه الفترة الزمنية هي 0، فسيتوقف الهاتف عن المحاولة. يجب أن تكون هذه القيمة أكبر بكثير من قيمة Reg Retry Intvl، والتي يجب ألا تكون 0. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 1200 انظر الملاحظة أدناه للحصول على تفاصيل إضافية. |
|
تأخير عشوائي لإعادة المحاولة |
نطاق تأخير عشوائي (بالثواني) لإضافته إلى <Register Retry Intvl> عند إعادة محاولة التسجيل بعد الفشل. يجب إضافة الحد الأدنى والحد الأقصى للتأخير العشوائي إلى المؤقت القصير. يتراوح النطاق من 0 إلى 2147483647. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 0 |
|
Reg: إعادة المحاولة (تأخير عشوائي طويل) |
نطاق تأخير عشوائي (بالثواني) لإضافته إلى معلمة Register Retry Long Intvl عند إعادة محاولة التسجيل بعد الفشل. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 0 |
|
قبعة ريج ريتري الدولية |
القيمة القصوى للتأخير الأسي. الحد الأقصى للقيمة للحد من تأخير إعادة محاولة التراجع الأسي (والذي يبدأ عند Register Retry Intvl ويضاعف كل إعادة محاولة). الإعدادات الافتراضية هي 0، مما يؤدي إلى تعطيل التراجع الأسي (أي أن الفاصل الزمني لإعادة محاولة الخطأ يكون دائمًا في Register Retry Intvl). عند تمكين هذه الميزة، تتم إضافة Reg Retry Random Delay إلى قيمة تأخير التراجع الأسي. يتراوح النطاق من 0 إلى 2147483647. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 0 |
|
تنتهي صلاحية الحد الأدنى الفرعي |
يقوم بتعيين الحد الأدنى لقيمة انتهاء صلاحية REGISTER التي تم إرجاعها من خادم الوكيل. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 10 |
|
تنتهي صلاحية Sub Max |
يقوم بتعيين الحد الأعلى لقيمة register minexpires التي يتم إرجاعها من خادم الوكيل في عنوان Min-Expires. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 7200 |
|
Intvl إعادة المحاولة الفرعية |
تحدد هذه القيمة (بالثواني) الفاصل الزمني لإعادة المحاولة عندما يفشل طلب الاشتراك الأخير. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 10 |
يمكن للهاتف استخدام قيمة RETRY-AFTER عند استلامها من خادم وكيل SIP مشغول جدًا لمعالجة الطلب (رسالة 503 Service Unavailable). إذا كانت رسالة الاستجابة تتضمن عنوان RETRY-AFTER، فسينتظر الهاتف المدة الزمنية المحددة قبل التسجيل مرة أخرى. في حالة عدم وجود عنوان RETRY-AFTER، ينتظر الهاتف القيمة المحددة في الفاصل الزمني لإعادة المحاولة أو الفاصل الزمني الطويل لإعادة المحاولة.
معالجة رمز حالة الاستجابة
يصف الجدول التالي معاملات SIP المتوفرة في قسم معالجة رمز حالة الاستجابة.
|
المعلمة |
وصف |
|---|---|
|
جرب النسخ الاحتياطي لـ RSC |
يحدد رموز حالة استجابة SIP التي تؤدي إلى فشل الهاتف ومحاولة التسجيل باستخدام خادم النسخ الاحتياطي. على سبيل المثال، يمكنك إدخال قيم رقمية 500 أو مجموعة من القيم الرقمية
بالإضافة إلى البطاقات البديلة إذا كانت القيم المتعددة ممكنة. بالنسبة إلى الأحدث، يمكنك استخدامها
لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
|
إعادة المحاولة ريج RSC |
يحدد رموز حالة استجابة SIP التي تقوم بتشغيل الهاتف لإعادة محاولة محاولات التسجيل. على سبيل المثال، يمكنك إدخال قيم رقمية 500 أو مجموعة من القيم الرقمية
بالإضافة إلى البطاقات البديلة إذا كانت القيم المتعددة ممكنة. بالنسبة إلى الأحدث، يمكنك استخدامها
لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
معايير RTP
يصف الجدول التالي معاملات SIP المتوفرة في قسم معلمات RTP.
|
المعلمة |
وصف |
|---|---|
|
الحد الأدنى لمنفذ RTP |
الحد الأدنى لرقم المنفذ لإرسال واستقبال RTP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: من 2048 إلى 49151 إذا كان نطاق القيمة (RTP Port Max - RTP Port Min) أقل من 16 أو إذا قمت بتكوين المعلمة بشكل غير صحيح، فسيتم استخدام نطاق منفذ RTP (16382 إلى 32766) بدلاً من ذلك. الإعداد الافتراضي: 16384 |
|
آر تي بي بورت ماكس |
الحد الأقصى لرقم المنفذ لإرسال واستقبال RTP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: من 2048 إلى 49151 إذا كان نطاق القيمة (RTP Port Max - RTP Port Min) أقل من 16 أو إذا قمت بتكوين المعلمة بشكل غير صحيح، فسيتم استخدام نطاق منفذ RTP (16382 إلى 32766) بدلاً من ذلك. الإعداد الافتراضي: 16482 |
|
حجم حزمة RTP |
يحدد الفاصل الزمني لحزم الصوت (بالثواني) لتدفقات صوت RTP لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: تتراوح من 0.01 إلى 0.13. يجب أن تكون القيم الصالحة من مضاعفات 0.01 ثانية. الإعداد الافتراضي: 0.02 |
|
الحد الأقصى لخطأ RTP ICMP |
عدد أخطاء ICMP المتتالية المسموح بها عند إرسال حزم RTP إلى النظير قبل أن ينهي الهاتف المكالمة. في حالة تعيين القيمة إلى 0، يتجاهل الهاتف الحد الأقصى لأخطاء ICMP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 0-10 الإعداد الافتراضي: 0 |
|
الفاصل الضريبي لـ RTCP |
الفاصل الزمني لإرسال تقارير مرسلي RTCP عن اتصال نشط. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: من 0 إلى 255 ثانية الإعداد الافتراضي: 0 |
|
إحصائيات المكالمات |
يحدد ما إذا كان الهاتف يرسل إحصائيات نهاية المكالمة داخل رسائل SIP عند إنهاء المكالمة أو وضعها قيد الانتظار. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
تفضيلات بروتوكول الإنترنت الخاصة بـ SDP |
حدد عنوان IP المفضل الذي يستخدمه الهاتف كعنوان RTP. إذا كان الهاتف في الوضع المزدوج ولديه عناوين ipv4 و ipv6، فسيتضمن دائمًا كلا العنوانين في SDP حسب السمات «a=altc... إذا تم تحديد عنوان IPv4، فإن عنوان ipv4 له أولوية أعلى من عنوان ipv6 في SDP ويشير إلى أن الهاتف يفضل استخدام عنوان ipv4 RTP. إذا كان الهاتف يحتوي فقط على عنوان ipv4 أو عنوان ipv6، فإن SDP لا يحتوي على سمات ALTC ويتم تحديد عنوان RTP في سطر «c =». للحصول على معلومات حول السلوك في الوضع المزدوج، راجع سلوكيات SIP وRTP في الوضع المزدوج. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: IPv4 | IPv6 الإعداد الافتراضي: IPv4 |
|
RTP قبل ACK |
يسمح لك بتحديد ما إذا كانت جلسة RTP تبدأ قبل أو بعد استلام ACK من الطرف المتصل.
لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
إعادة تعيين SSRC على Rx RE-INVITE |
يتحكم في إعادة تعيين مصدر المزامنة (SSRC) لجلسات RTP و SRTP الصادرة عند RE-INVITE الواردة.
لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
إعادة تعيين SSRC عند إعادة دعوة الضرائب |
يتحكم في إعادة تعيين مصدر المزامنة (SSRC) لجلسات RTP و SRTP الصادرة على RE-INVITE الصادرة.
لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
أنواع حمولة SDP
يدعم هاتف Cisco IP الخاص بك RFC4733. يمكنك الاختيار من بين ثلاثة خيارات لنقل الصوت والفيديو (AVT) لإرسال نبضات DTMF إلى الخادم.
يتم استخدام الحمولات الديناميكية التي تم تكوينها للمكالمات الصادرة فقط عندما يقدم هاتف Cisco IP عرض بروتوكول وصف الجلسة (SDP). بالنسبة للمكالمات الواردة مع عرض SDP، يتبع الهاتف نوع الحمولة الديناميكية المعين للمتصل.
يستخدم هاتف Cisco IP أسماء برامج الترميز التي تم تكوينها في SDP الصادر. بالنسبة إلى SDP الوارد بأنواع الحمولة القياسية من 0 إلى 95، يتجاهل الهاتف أسماء برامج الترميز. بالنسبة لأنواع الحمولة الديناميكية، يقوم الهاتف بتعريف برنامج الترميز من خلال أسماء برامج الترميز التي تم تكوينها. المقارنة حساسة لحالة الأحرف، لذلك تحتاج إلى تعيين الاسم بشكل صحيح.
يصف الجدول التالي معاملات SIP المتوفرة في قسم أنواع حمولة SDP.
|
المعلمة |
وصف |
|---|---|
|
اسم برنامج الترميز G711u |
اسم برنامج الترميز G711u المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: PCMU |
|
اسم برنامج الترميز G711a |
اسم برنامج الترميز G711a المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: PCMA |
|
اسم برنامج الترميز G729a |
اسم برنامج الترميز G729a المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: G729a |
|
اسم برنامج الترميز G722 |
اسم برنامج الترميز G722 المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: G722 |
|
اسم برنامج الترميز G722.2 |
اسم برنامج الترميز G722.2 المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: AMR-WB |
|
اسم برنامج ترميز iLBC |
اسم برنامج ترميز iLBC المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: iLBC |
|
اسم برنامج ترميز iSAC |
اسم برنامج ترميز iSAC المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: iSAC |
|
اسم برنامج الترميز OPUS |
اسم برنامج ترميز OPUS المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: OPUS |
|
اسم برنامج ترميز AVT |
اسم برنامج ترميز AVT المستخدم في SDP. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: حدث عبر الهاتف |
|
الحمولة الديناميكية G722.2 |
نوع الحمولة الديناميكية G722. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الافتراضي: 96 |
|
الحمولة الديناميكية G722.2 OA |
G722.2 OA نوع الحمولة الديناميكية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 103 |
|
الحمولة الديناميكية لـ iLBC 20 مللي ثانية |
نوع الحمولة الديناميكية iLBC 20 مللي ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 97 |
|
الحمولة الديناميكية لـ iLBC 30 مللي ثانية |
نوع الحمولة الديناميكية iLBC 20 مللي ثانية. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 105 |
|
الحمولة الديناميكية لـ iSAC |
نوع الحمولة الديناميكية لـ iSAC. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الافتراضي: 98 |
|
حمولة OPUS الديناميكية |
نوع الحمولة الديناميكية OPUS. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الافتراضي: 99 |
|
حمولة RSFEC الديناميكية |
نوع الحمولة الديناميكية RSFEC. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 113 |
|
حمولة AVT الديناميكية |
نوع الحمولة الديناميكية AVT. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 101 |
|
حمولة ديناميكية AVT 16 كيلو هرتز |
نوع الحمولة الديناميكية AVT لمعدل الساعة 16 كيلو هرتز. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 101 |
|
حمولة ديناميكية AVT 48 كيلو هرتز |
نوع الحمولة الديناميكية AVT لمعدل الساعة البالغ 48 كيلو هرتز. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 101 |
|
الحمولة الديناميكية لـ INFOREQ |
نوع الحمولة الديناميكية من INFOREQ. لتكوين الإعداد، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: 96-127 الإعداد الافتراضي: 101 |
معايير دعم NAT
بالنسبة للمعلمات المتعلقة بدعم NAT، راجع اجتياز NAT مع الهواتف.
تكوين إعدادات SIP للملحق
باستخدام إعدادات SIP لكل سطر، يمكنك تحديد كيفية تعامل الهاتف مع إشارات SIP والتسجيل والوسائط الخاصة بامتداد فردي.
| 1 |
قم بالوصول إلى صفحة الويب الخاصة بإدارة الهاتف. |
| 2 |
حدد . |
| 3 |
في قسم إعدادات SIP، قم بتكوين المعلمات كما هو موضح في المعلمات لإعدادات SIP للملحق |
| 4 |
انقر فوق إرسال جميع التغييرات. |
المعلمات لإعدادات SIP للملحق
يحدد الجدول التالي وظيفة واستخدام المعلمات في قسم إعدادات SIP ضمن علامة التبويب في واجهة الويب الخاصة بالهاتف. كما تحدد أيضًا صيغة السلسلة التي تمت إضافتها في ملف تكوين الهاتف باستخدام رمز XML (cfg.xml) لتكوين المعلمة.
|
المعلمة |
وصف |
|---|---|
|
نقل بروتوكول SIP |
يحدد بروتوكول النقل لرسائل SIP. عند الضبط على AUTO، يقوم الهاتف بتحديد البروتوكول المناسب تلقائيًا، استنادًا إلى سجلات NAPTR على خادم DNS. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: UDP | TCP | TLS | تلقائي الإعداد الافتراضي: UDP |
|
منفذ SIP |
رقم منفذ الهاتف للاستماع إلى رسائل SIP وإرسالها. حدد رقم المنفذ هنا فقط عندما تستخدم UDP كبروتوكول نقل SIP. إذا كنت تستخدم TCP، فإن النظام يستخدم منفذًا عشوائيًا ضمن النطاق المحدد في SIP TCP Port Min وSIP TCP Port Max على علامة تبويب . إذا كنت بحاجة إلى تحديد منفذ خادم وكيل SIP، فيمكنك تحديده باستخدام حقل الوكيل أو حقل XSI Host Server . قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 5060 |
|
تمكين بروتوكول SIP 100REL |
يعمل بشكل فردي على تمكين ميزة SIP 100REL. عند التمكين، يدعم الهاتف ملحق 100REL SIP للإرسال الموثوق للاستجابات المؤقتة (18x) ويستخدم طلبات PRACK. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
منفذ إكست إس آي بي |
رقم منفذ SIP الخارجي. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: الإعداد الافتراضي: 5060 |
|
إعادة تشغيل المصادقة وإعادة التشغيل |
يقوم هاتف Cisco IP بمصادقة المرسل عندما يتلقى رسالة NOTIFY بالطلبات التالية:
قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: نعم |
|
وكيل SIP - مطلوب |
يمكن أن يدعم وكيل SIP امتدادًا أو سلوكًا معينًا عندما يتلقى عنوان Proxy-Require من وكيل المستخدم. إذا تم تكوين هذا الحقل ولم يدعمه الوكيل، فإنه يستجيب بالرسالة، غير مدعوم. قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
|
معرف SIP الخاص بالطرف البعيد |
عنوان معرف الطرف البعيد الذي سيتم استخدامه بدلاً من رأس From. حدد نعم للتمكين. الإعداد الافتراضي: نعم |
|
تأخير وقت الإحالة |
يتحكم عندما يرسل الهاتف BYE لإنهاء أرجل المكالمات القديمة عند الانتهاء من عمليات تحويل المكالمات. تم تكوين إعدادات التأخير المتعددة (المرجع وهدف الإحالة والمرجع والإشارة إلى الهدف) على هذه الشاشة. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: عدد صحيح من 0 إلى 65535 الإعداد الافتراضي: 4 |
|
الرجوع إلى جهة الاتصال المستهدفة |
يشير إلى هدف الإحالة. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
تأخير وداع الحكم |
يحدد وقت تأخير الوداع للحكم بالثواني. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: عدد صحيح من 0 إلى 65535 الإعداد الافتراضي: 0 |
|
يرجى الرجوع إلى الهدف قبل التأخير |
يحدد وقت تأخير الوداع لهدف الإحالة بالثواني. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: عدد صحيح من 0 إلى 65535 الإعداد الافتراضي: 0 |
|
ستيكي 183 |
يتحكم في أول استجابة 183 SIP لدعوة صادرة. لتمكين هذه الميزة، قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
دعوة المصادقة |
يتحكم في ما إذا كان التفويض مطلوبًا لطلبات INVITE الواردة الأولية من وكيل SIP. لتمكين هذه الميزة. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
راجع Ntfy على 1x-to-inv |
في حالة الضبط على نعم، كمنقول إليه، سيرسل الهاتف تنبيهًا مع الحدث: ارجع إلى المحول للحصول على أي استجابة 1xx يتم إرجاعها من قبل هدف النقل، في قسم مكالمة النقل. في حالة الضبط على «لا»، سيرسل الهاتف إشعارًا فقط للردود النهائية (200 فأكثر). قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: نعم |
|
انظر مرفق G729 (ب) |
قم بتكوين إعدادات الملحق B لـ G.729. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: لا شيء | لا | نعم | اتبع إعداد supp الصامت الإعداد الافتراضي: نعم |
|
استخدم OPUS ذات النطاق الترددي المنخفض |
لتحسين النطاق الترددي في شبكتك، يمكنك إعداد الهواتف لاستخدام برنامج ترميز OPUS ضيق النطاق. لن يتعارض برنامج الترميز ضيق النطاق مع برنامج ترميز النطاق العريض. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: لا |نعم الإعداد الافتراضي: لا |
|
عنوان تقرير جودة الصوت |
يحدد الوجهة التي يرسل فيها الهاتف تقارير تشخيصية حول جودة المكالمة. يمكنك إدخال اسم نطاق أو عنوان IP. يمكنك أيضًا إضافة رقم منفذ إلى جانب اسم المجال أو عنوان IP لهذه المعلمة. إذا لم تقم بإدخال رقم منفذ، فسيتم استخدام قيمة منفذ SIP UDP (5060) افتراضيًا. إذا كانت معلمة URL لخادم التجميع فارغة، فلن يتم إرسال رسالة SIP PUBLISH. قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
|
الفاصل الزمني لتقرير جودة الصوت |
يحدد عدد المرات التي يقوم فيها الهاتف بإنشاء تقارير جودة الصوت وإرسالها إلى عنوان التقرير الذي تم تكوينه. يتم قياس الفاصل الزمني بالدقائق. توفر الفواصل الزمنية الأقصر تحديثات أكثر تكرارًا للمراقبة ولكنها قد تزيد من حركة مرور التقارير، بينما تقلل الفواصل الزمنية الأطول من الحمل ولكنها توفر قدرًا أقل من التفاصيل. الفاصل الزمني الافتراضي هو 0، مما يعني أنه لن يتم إرسال أي تقارير دورية. قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 0 |
| مجموعة تقارير جودة الصوت |
يحدد معرف المجموعة المستخدم عند إرسال تقارير جودة الصوت من الهاتف. تسمح هذه المعلمة بتنظيم هواتف متعددة ضمن نفس مجموعة التقارير، بحيث يمكن للمسؤولين فرز بيانات جودة المكالمات وتصفيتها وتحليلها بسهولة. قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
|
هاتف متساوي للمستخدم |
عندما يتم تحويل عنوان URL الخاص بالهاتف إلى عنوان URL لـ SIP ويتم تمثيل رقم الهاتف بجزء المستخدم من عنوان URL، فإن عنوان URL الخاص بـ SIP يتضمن المعلمة الاختيارية: user=phone (RFC3261). على سبيل المثال: إلى: أرسل: + 12325551234@example.com؛ المستخدم = الهاتف قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
عنوان الخصوصية |
يضبط خصوصية المستخدم في رسالة SIP في الشبكة الموثوقة. خيارات عنوان الخصوصية هي:
قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: معطل | لا شيء | رأس | جلسة | مستخدم | معرف الإعداد الافتراضي: معطل |
|
دعم P-Early Media |
يتحكم في ما إذا كان عنوان P-Early-Media مضمنًا في رسالة SIP لمكالمة صادرة. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
دعم معرف جلسة SIP |
يتيح استخدام رأس معرف جلسة SIP (المحدد في RFC 7989) لتحديد جلسة اتصال من طرف إلى طرف بشكل فريد. يظل معرف الجلسة هو نفسه عبر أرجل المكالمات، حتى إذا تم تحويل المكالمة أو إعادة توجيهها أو المرور عبر وسطاء SIP متعددين. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: نعم |
|
طلب ميدياسيك |
يحدد ما إذا كان الهاتف يطلب استخدام Media Security (MediaSec) أثناء إعداد مكالمة SIP. عند التمكين، يتضمن الهاتف قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
ميدياسيك عبر TLS فقط |
يتحكم فيما إذا كان الهاتف يستخدم أمان الوسائط (MediaSec، RFC 3329) فقط عندما تكون إشارات SIP محمية باستخدام TLS. عند التمكين، يتضمن الهاتف MediaSec ( قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
دعم الشروط المسبقة |
يحدد ما إذا كان الهاتف يتضمن علامة الشرط المسبق (المحددة في RFC 3312) في حقل العنوان المدعوم.
قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: معطل | ممكّن الإعداد الافتراضي: معطل |
|
دعم المصادقة RFC8760 |
يتيح دعم نظام المصادقة المحدد في RFC 8760 - المصادقة الموجزة لـ SIP (SHA-256/512). تعمل هذه المواصفة القياسية على توسيع مصادقة SIP لاستخدام وظائف تجزئة أقوى وأكثر أمانًا مقارنة بالملخص الأقدم المستند إلى MD5 (RFC 2617). عند التمكين، يدعم الهاتف المصادقة الموجزة SHA-256/SHA-512 عند الاعتراض عليه من قبل خادم SIP. عند التعطيل، لا يدعم الهاتف سوى مصادقة MD5 digest القديمة (RFC 2617). قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
اجتياز NAT مع الهواتف
تسمح ترجمة عنوان الشبكة (NAT) لأجهزة متعددة بمشاركة عنوان IP واحد وعام وقابل للتوجيه لإنشاء اتصالات عبر الإنترنت. تتواجد NAT في العديد من أجهزة الوصول ذات النطاق العريض لترجمة عناوين IP العامة والخاصة. لكي يتعايش VoIP مع NAT، يلزم اجتياز NAT.
لا يوفر جميع مزودي الخدمة اجتياز NAT. إذا كان مزود الخدمة الخاص بك لا يوفر اجتياز NAT، فلديك عدة خيارات:
-
رسم خرائط NAT باستخدام وحدة تحكم حدود الجلسة: نوصي باختيار موفر خدمة يدعم تعيين NAT من خلال وحدة تحكم حدود الجلسة. مع تخطيط NAT الذي يوفره موفر الخدمة، لديك المزيد من الخيارات في اختيار جهاز التوجيه.
-
رسم خرائط NAT باستخدام جهاز توجيه SIP-ALG: يمكن رسم خرائط NAT باستخدام جهاز توجيه يحتوي على بوابة طبقة تطبيق SIP (ALG). باستخدام جهاز توجيه SIP-ALG، لديك المزيد من الخيارات في اختيار مزود الخدمة.
-
تعيين NAT باستخدام عنوان IP ثابت: يمكن إجراء تعيين NAT باستخدام عنوان IP ثابت خارجي (عام) لضمان قابلية التشغيل البيني مع مزود الخدمة. يجب أن تكون آلية NAT المستخدمة في جهاز التوجيه متماثلة. لمزيد من المعلومات، راجع تحديد NAT المتماثل أو غير المتماثل.
استخدم تعيين NAT فقط إذا كانت شبكة موفر الخدمة لا توفر وظيفة وحدة تحكم حدود الجلسة. لمزيد من المعلومات حول كيفية تكوين تعيين NAT باستخدام IP ثابت، راجع تكوين تعيين NAT باستخدام عنوان IP الثابت.
-
رسم خرائط NAT باستخدام STUN: إذا كانت شبكة موفر الخدمة لا توفر وظيفة وحدة تحكم حدود الجلسة وإذا تم استيفاء المتطلبات الأخرى، فمن الممكن استخدام أدوات اجتياز الجلسة لـ NAT (STUN) لاكتشاف تعيين NAT. للحصول على معلومات حول كيفية تكوين تعيين NAT باستخدام STUN، راجع تكوين تعيين NAT باستخدام STUN.
تكوين تعيين NAT باستخدام عنوان IP الثابت
قم بتكوين رسم خرائط NAT على هاتفك لضمان قابلية التشغيل البيني مع مزود الخدمة.
قبل أن تبدأ
-
يجب أن يكون لديك عنوان IP خارجي (عام) ثابت.
-
يجب أن تكون آلية NAT المستخدمة في جهاز التوجيه متماثلة.
| 1 |
قم بالوصول إلى صفحة الويب الخاصة بإدارة الهاتف. |
| 2 |
حدد . |
| 3 |
في قسم معلمات دعم NAT، قم بتكوين المعلمات كما هو موضح في المعلمات لتعيين NAT لعنوان IP الثابت. |
| 4 |
انتقل إلى ، حيث nيوجد فهرس الإضافات. |
| 5 |
في قسم إعدادات NAT، قم بتكوين المعلمات كما هو موضح في المعلمات لرسم خرائط NAT على الامتدادات. |
| 6 |
انقر فوق إرسال جميع التغييرات. |
ما يجب القيام به بعد ذلك
قم بتكوين إعدادات جدار الحماية على جهاز التوجيه الخاص بك للسماح بحركة مرور SIP.
تكوين تعيين NAT باستخدام STUN
إذا كانت شبكة موفر الخدمة لا توفر وحدة تحكم حدود الجلسة (SBC) وتم استيفاء المتطلبات الأخرى، فيمكن استخدام أدوات اجتياز الجلسة لـ NAT (STUN) لاكتشاف تخطيط NAT.
يمكّن STUN التطبيقات التي تعمل خلف NAT من:
- اكتشف وجود NAT في مسار الاتصال.
- احصل على عنوان IP العام (المعين) ورقم المنفذ الذي تقوم NAT بتعيينه لاتصالات UDP بالمضيفين البعيدين.
يتطلب البروتوكول خادم STUN تابعًا لجهة خارجية يقع على الجانب العام من NAT، وعادةً ما يكون الإنترنت. من خلال تبادل الرسائل مع هذا الخادم، يتعرف العميل على كيفية ترجمة NAT لعنوان IP الخاص والمنافذ.
تعتبر STUN آلية احتياطية ويجب استخدامها فقط عندما تكون طرق اجتياز NAT الأخرى غير متوفرة.
قبل أن تبدأ
-
يجب أن يستخدم جهاز التوجيه NAT غير المتماثل. راجع تحديد NAT المتماثل أو غير المتماثل.
-
يجب أن يتوفر كمبيوتر يعمل ببرنامج خادم STUN. يمكنك إما استخدام خادم STUN عام أو إعداد خادم STUN الخاص بك.
| 1 |
قم بالوصول إلى صفحة الويب الخاصة بإدارة الهاتف. |
| 2 |
حدد . |
| 3 |
في قسم معلمات دعم NAT، قم بتعيين المعلمات كما هو موضح في جدول المعلمات لرسم خرائط NAT باستخدام عنوان IP ثابت. |
| 4 |
قم بتعيين المعلمات كما هو موضح في جدول المعلمات لرسم خرائط NAT باستخدام STUN. |
| 5 |
انقر فوق علامة التبويب Ext (n). |
| 6 |
في قسم إعدادات NAT، قم بتعيين المعلمات للملحق المحدد كما هو موضح في جدول المعلمات لتعيين NAT على الامتدادات. |
| 7 |
انقر فوق إرسال جميع التغييرات. |
ما يجب القيام به بعد ذلك
قم بتكوين إعدادات جدار الحماية على جهاز التوجيه الخاص بك للسماح بحركة مرور SIP.
تحديد NAT المتماثل أو غير المتماثل
لا يعمل STUN على أجهزة التوجيه ذات NAT المتماثل. باستخدام NAT المتماثل، يتم تعيين عناوين IP من عنوان IP داخلي ومنفذ إلى عنوان IP للوجهة الخارجية القابلة للتوجيه والمنفذ. وفي حالة إرسال حزمة أخرى من نفس عنوان IP المصدر والمنفذ إلى وجهة مختلفة، يتم استخدام تركيبة مختلفة من عنوان IP ورقم المنفذ. تعتبر هذه الطريقة تقييدية لأن المضيف الخارجي يمكنه إرسال حزمة إلى منفذ معين على المضيف الداخلي فقط إذا قام المضيف الداخلي أولاً بإرسال حزمة من هذا المنفذ إلى المضيف الخارجي.
يفترض هذا الإجراء أن خادم syslog قد تم تكوينه وأنه جاهز لاستقبال رسائل syslog.
قبل أن تبدأ
تحقق من أن جدار الحماية لا يعمل على جهاز الكمبيوتر الخاص بك. (يمكنه حظر منفذ syslog.) افتراضيًا، يكون منفذ syslog هو 514.
| 1 |
قم بالوصول إلى صفحة الويب الخاصة بإدارة الهاتف. |
| 2 |
حدد وانتقل إلى قسم تكوين الشبكة الاختياري. |
| 3 |
أدخل عنوان IP لخادم Syslog، إذا كان رقم المنفذ هو أي شيء آخر غير الافتراضي، 514. إذا تم استخدام المنفذ الافتراضي، فليس من الضروري تضمين رقم المنفذ. يجب الوصول إلى العنوان ورقم المنفذ من هاتف Cisco IP. يظهر رقم المنفذ في اسم ملف سجل الإخراج. إذا لم يتم تحديد رقم المنفذ، فإن اسم
ملف الإخراج الافتراضي هو |
| 4 |
قم بتعيين مستوى التصحيح إلى خطأ أو إشعار أو تصحيح. |
| 5 |
لالتقاط رسائل إشارات SIP، انقر فوق علامة التبويب Ext (n) وانتقل إلى إعدادات SIP. قم بتعيين خيار SIP Debug إلى الكامل. |
| 6 |
لجمع معلومات حول نوع NAT الذي يستخدمه جهاز التوجيه الخاص بك، انقر فوق علامة تبويب وانتقل إلى معلمات دعم NAT. |
| 7 |
قم بتعيين تمكين اختبار STUN إلى نعم. |
| 8 |
حدد نوع NAT من خلال عرض رسائل التصحيح في ملف السجل. إذا كانت الرسائل تشير إلى أن الجهاز يستخدم NAT المتماثل، فلا يمكنك استخدام STUN. |
| 9 |
انقر فوق إرسال جميع التغييرات. |
المعلمات لرسم خرائط NAT
المعلمات لرسم خرائط NAT باستخدام عنوان IP ثابت
يحدد الجدول التالي وظيفة واستخدام تعيين NAT مع معلمات IP الثابتة في قسم معلمات دعم NAT ضمن علامة تبويب في واجهة الويب للهاتف. كما تحدد أيضًا صيغة السلسلة التي تمت إضافتها في ملف تكوين الهاتف باستخدام رمز XML (cfg.xml) لتكوين المعلمة.
| المعلمة | وصف |
|---|---|
|
التعامل مع بطاقة VIA المستلمة |
يقوم بتمكين الهاتف أو تعطيله لمعالجة المعلمة المستلمة في رأس VIA. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
التعامل مع تقرير VIA |
يمكّن الهاتف أو يعطله لمعالجة قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
أدخل بطاقة VIA المستلمة |
يقوم بتمكين الهاتف أو تعطيله
لإدراج قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
إدراج تقرير VIA |
يقوم بتمكين الهاتف أو تعطيله لإضافة قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
استبدل عنوان VIA |
يمكّن المستخدم من استخدام قيم IP:port المعينة بواسطة NAT في رأس VIA. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
إرسال الرد إلى منفذ Src |
يتيح إرسال الردود إلى منفذ مصدر الطلب بدلاً من منفذ VIA المرسل . قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
EXT IP |
عنوان IP خارجي ليحل محل عنوان IP الفعلي للهاتف في جميع رسائل SIP الصادرة. إذا تم تحديد 0.0.0.0، فلن يتم إجراء استبدال لعنوان IP. في حالة تحديد هذه المعلمة، يفترض الهاتف عنوان IP هذا عند إنشاء رسائل SIP وSDP (إذا تم تمكين NAT Mapping لهذا الخط). قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
|
الحد الأدنى لمنفذ EXT RTP |
رقم منفذ البداية (الحد الأدنى) في مخطط NAT الخارجي الذي يجب أن يستخدمه الهاتف لحركة مرور RTP. قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: 0 |
|
حلف شمال الأطلسي - كيب ألايف إنتفل |
الفاصل الزمني بين رسم خرائط NAT يبقي الرسائل حية. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نطاقات رقمية من 0 إلى 65535 الإعداد الافتراضي: 15 |
|
إعادة توجيه ابق على قيد الحياة |
قم بتمكين الهاتف أو تعطيله لإرسال رسائل البقاء على قيد الحياة إلى الخادم الذي تمت إعادة توجيهه للحفاظ على الاتصال عند حدوث مشكلة. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
المعلمات لرسم خرائط NAT على الامتدادات
يحدد الجدول التالي وظيفة واستخدام تعيين NAT مع معلمات IP الثابتة في قسم معلمات دعم NAT ضمن علامة تبويب Voice>Ext في واجهة الويب للهاتف. كما تحدد أيضًا صيغة السلسلة التي تمت إضافتها في ملف تكوين الهاتف باستخدام رمز XML (cfg.xml) لتكوين المعلمة.
| المعلمة | وصف |
|---|---|
|
تمكين رسم خرائط NAT |
يتحكم في استخدام عناوين IP المعينة خارجيًا ومنافذ SIP/RTP في رسائل SIP. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
|
تمكين البقاء على قيد الحياة من NAT (اختياري) |
يقوم بتمكين الهاتف أو تعطيله لإرسال رسالة NAT keep alive بشكل دوري للحفاظ على اتصال SIP الخاص بالهاتف حيًا من خلال NAT. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم | لا الإعداد الافتراضي: لا |
المعلمات لرسم خرائط NAT باستخدام STUN
يحدد الجدول التالي وظيفة واستخدام تعيين NAT مع معلمات STUN في قسم معلمات دعم NAT ضمن علامة التبويب في واجهة الويب للهاتف. كما تحدد أيضًا صيغة السلسلة التي تمت إضافتها في ملف تكوين الهاتف باستخدام رمز XML (cfg.xml) لتكوين المعلمة.
|
المعلمة |
وصف |
|---|---|
|
تمكين الصوت |
يتيح استخدام STUN لاكتشاف رسم خرائط NAT. قم بتنفيذ أحد الإجراءات التالية:
القيم المسموح بها: نعم ولا. الإعداد الافتراضي: لا |
|
خادم ستاون |
عنوان IP أو اسم المجال المؤهل بالكامل لخادم STUN للاتصال به لاكتشاف خرائط NAT. يمكنك استخدام خادم STUN عام أو إعداد خادم STUN الخاص بك. قم بتنفيذ أحد الإجراءات التالية:
الإعداد الافتراضي: فارغ |
سلوكيات SIP و RTP في الوضع المزدوج
يمكنك التحكم في معاملات SIP و RTP باستخدام حقول تفضيلات SIP IP و SDP IP Preference عندما يكون الهاتف في الوضع المزدوج.
تحدد معلمة SIP IP Preference عنوان IP الذي يحاول الهاتف استخدامه أولاً عندما يكون في الوضع المزدوج.
|
وضع بروتوكول الإنترنت |
تفضيلات بروتوكول الإنترنت الخاصة بـ SIP |
قائمة العناوين من DNS، الأولوية، النتيجة P1 - عنوان الأولوية الأولى P2 - عنوان الأولوية الثانية |
تسلسل تجاوز الفشل |
|---|---|---|---|
|
الوضع المزدوج |
IPv4 |
P1- 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 النتيجة: سيرسل الهاتف رسائل SIP إلى 1.1.1.1 أولاً. |
1.1.1.1 ->2009:1:1:1:1 -> 2.2.2.2 -> 2009:2:2:2:2 |
|
الوضع المزدوج |
IPv6 |
P1- 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 النتيجة: سيرسل الهاتف رسائل SIP إلى 2009:1:1:1:1 أولاً. |
2009:1:1:1:1 -> 1.1.1.1 -> 2009:2:2:2:2 -> 2.2.2.2 |
|
الوضع المزدوج |
IPv4 |
P1- 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 النتيجة: سيرسل الهاتف رسائل SIP إلى 2009:1:1:1:1 أولاً. |
2009:1:1:1:1 -> 2.2.2.2 -> 2009:2:2:2:2 |
|
الوضع المزدوج |
IPv6 |
P1- 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 النتيجة: سيرسل الهاتف رسائل SIP إلى 1.1.1.1 أولاً. |
2009:1:1:1:1 -> 2009:2:2:2:2 ->2.2.2.2 |
|
IPv4 فقط |
IPv4 أو IPv6 |
P1 - 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 النتيجة: سيرسل الهاتف رسائل SIP إلى 1.1.1.1 أولاً. |
1.1.1.1 -> 2.2.2.2 |
|
IPv6 فقط |
IPv4 أو IPv6 |
P1 - 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 النتيجة: سيرسل الهاتف رسائل SIP إلى 2009:1:1:1:1 أولاً. |
2009:1:1:1:1 -> 2009:2:2:2::2 |
تكوين موثوقية الوسائط وإعدادات الجودة
معلومات الموارد المرتبطة بالوسائط (MARI) هي آلية إرسال الإشارات وإعداد التقارير - تُستخدم غالبًا في الشبكات المستندة إلى SIP و RTP - والتي تسمح للهواتف وخوادم التحكم في المكالمات بتبادل معلومات جودة الوسائط حول مكالمة في الوقت الفعلي أو بعد انتهاء المكالمة. قم بتمكين MARI إذا كنت تريد مراقبة مقياس جودة المكالمة أو تسجيله. عند التمكين، يرسل الهاتف إحصائيات حول تدفق الوسائط - مثل الارتعاش وفقدان الحزمة والتأخير و MOS (متوسط نقاط الرأي) وما إلى ذلك - مرة أخرى إلى نظام المراقبة
تصحيح الخطأ الأمامي (FEC) هو طريقة تستخدم لاستعادة حزم RTP المفقودة في الوقت الفعلي دون إعادة الإرسال. وهي تعمل عن طريق إضافة بيانات مكررة إلى دفق الوسائط، لذلك في حالة فقدان الحزمة، يمكن للمستقبل إعادة بنائها من المعلومات المكررة. تعمل FEC على تحسين جودة المكالمات على الشبكات المفقودة أو غير المستقرة. عند التمكين، يرسل الهاتف ويستقبل بيانات RTP الزائدة للحماية من فقدان الحزمة.
| 1 |
قم بالوصول إلى صفحة الويب الخاصة بإدارة الهاتف. |
| 2 |
حدد . |
| 3 |
في قسم تكوين MARI، قم بتعيين MARI ممكّن وFEC ممكّن إلى نعم لتمكين الميزات. افتراضيًا، يتم تعطيل هذه الميزات. يمكنك أيضًا تكوين الإعدادات باستخدام ملف تكوين الهاتف باستخدام XML (cfg.xml) عن طريق إدخال سلاسل بهذا التنسيق:
|
| 4 |
انقر فوق إرسال جميع التغييرات. |