- ホーム
- /
- 投稿記事
SIPを適切に設定すると、電話をSIPサーバーに登録して電話をかけたり受けたりできます。設定は電話全般と内線用です。このヘルプ記事は、シスコブロードワークスに登録されているシスコデスクフォン9800シリーズとシスコビデオフォン8875を対象としています。
電話のSIP設定を行います
| 1 |
電話管理ウェブページにアクセスしてください。 |
| 2 |
。 |
| 3 | |
| 4 |
「すべての変更を送信」をクリックします。 |
電話のSIP設定のパラメータ
次のパラメータは、電話管理ウェブページの「」タブにあります。 それぞれのパラメータについては、次の表を参照してください。
一般的なパラメーター
次の表では、 SIPパラメータセクションで使用可能なSIPパラメータについて説明しています。
|
パラメーター |
説明 |
|---|---|
|
マックス・フォワード |
SIP最大転送値を指定します。 設定を行うには、次の操作のいずれかを実行してください。
許可される値:1 から 255 デフォルト:70 |
|
最大リダイレクト |
無限ループを避けるために招待をリダイレクトできる回数を指定します。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:5 |
|
最大認証 |
リクエストに異議を申し立てることができる最大回数(0〜255)を指定します。 設定を行うには、次の操作のいずれかを実行してください。
許可される値:0から255まで デフォルト:2 |
|
SIPユーザーエージェント名 |
アウトバウンドリクエストで使用されます。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:$バージョン 空の場合、ヘッダーは含まれません。 許可されたものに対応する$Aから$Dへのマクロ展開 GPP_A GPP_D |
|
SIPサーバー名 |
受信応答への応答に使用されるサーバーヘッダー。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:$バージョン |
|
SIP Regユーザーエージェント名 |
REGISTERリクエストで使用されるユーザーエージェント名。 これが指定されていない場合は、 SIPユーザーエージェント名もREGISTERリクエストに使用されます。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:空白 |
|
SIP受け入れ言語 |
使用したヘッダーの受け入れ言語。 設定を行うには、次の操作のいずれかを実行してください。
デフォルトはありません。 空の場合、ヘッダーは含まれません。 |
|
DTMF リレー MIME タイプ |
DTMFイベントを通知するためにSIP INFOメッセージで使用されるMIMEタイプ。 このフィールドはサービスプロバイダーのフィールドと一致する必要があります。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:アプリケーション/DTMF-リレー |
|
フックフラッシュ MIME タイプ |
フックフラッシュイベントを通知するSIPINFOメッセージで使用されるMIMEタイプ。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:アプリケーション/フックフラッシュ |
|
最終登録を削除してください |
値が異なる場合は、新しい登録を登録する前に最後の登録を削除できます。 最後の登録を削除するには、「はい」に設定してください。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
コンパクトヘッダーを使う |
「はい」に設定すると、 電話はアウトバウンドSIPメッセージにコンパクトなSIPヘッダーを使用します。 インバウンドのSIPリクエストに通常のヘッダーが含まれている場合、 電話は着信ヘッダーをコンパクトヘッダーに置き換えます。 「いいえ」に設定すると、 電話機は通常のSIPヘッダーを使用します。 インバウンドのSIPリクエストにコンパクトヘッダーが含まれている場合、 この設定に関係なく、 電話機は応答を生成するときに同じコンパクトヘッダーを再利用します。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
エスケープ表示名 |
表示名を非公開にすることができます。 IP電話で、SIPメッセージの発信用に( 表示名で設定された)文字列を二重引用符で囲むようにするには、「はい」に設定します。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
トークパッケージ |
ユーザーが外部アプリケーションのボタンをクリックして電話に応答したり再開したりできるBroadSoft Talk Packageのサポートを有効にします。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
ホールドパッケージ |
BroadSoft Hold Packageのサポートを有効にします。これにより、 ユーザーは外部アプリケーションのボタンをクリックして通話を保留にすることができます。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
会議パッケージ |
ユーザーが外部アプリケーションのボタンをクリックして電話会議を開始できるBroadSoft Conference Packageのサポートを有効にします。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
RFC 2543コールホールド |
「はい」に設定すると、SIP re-INVITEをピアに送信して通話を保留するときに、ユニットはSDPにc=0.0.0.0構文を含めます。 「いいえ」に設定すると、 ユニットはSDPにc=0.0.0.0構文を含めません。 どちらの場合でも、ユニットのSDPには常に a=sendonly 構文が含まれます。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:はい |
|
再起動時にランダムな登録CIDです |
「はい」に設定すると、次回のソフトウェア再起動後に、 電話機は別のランダムなCall-IDを使用して登録します。 「いいえ」に設定すると、Cisco IP Phone は次回のソフトウェア再起動後に同じコール ID を使用して登録しようとします。 Cisco IP電話は、この設定に関係なく、電源を入れ直した後、 常に新しいランダムなコールIDを使用して登録します。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
SIP TCP ポートマイン |
SIPセッションに使用できる最小のTCPポート番号を指定します。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:5060 |
|
SIP TCP ポートマックス |
SIPセッションに使用できる最大のTCPポート番号を指定します。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:5080 |
|
発信者IDヘッダー |
PAID-RPID-FROM、 PAID-FROM、RPID-FROM、またはFROMヘッダーから発信者IDを取得するオプションを提供します。 設定を行うには、次の操作のいずれかを実行してください。
許容値:有料-RPID-FROM | AID-FROM | RIP-PID-FROM |; デフォルト:有料-RIPD-FROM |
|
紹介前にターゲットを保留してください |
全席通話転送(転送先が応答している場合)を開始するときに、 譲受人にREFERを送信する前に、転送先のコールレッグを保留するかどうかを制御します。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
SDP有効化ダイアログ |
有効になっていて、通知メッセージ本文が大きすぎて断片化してしまうと、 通知メッセージxmlダイアログが簡略化されます。セッション記述プロトコル(SDP) はダイアログのxmlコンテンツに含まれません。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
紹介が失敗したときも紹介者を残しておく |
はいに設定すると、NOTIFRAGメッセージをすぐに処理するように電話が設定されます 。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
転用情報を表示する |
SIPメッセージに含まれる転送情報をLCDに表示するかどうか。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
ヘッダーから匿名を表示 |
通話が匿名通話であっても、SIP INVITEメッセージの「From」ヘッダーから発信者IDを表示します。 パラメータが「いいえ」に設定されている場合、電話には発信者IDとして「匿名発信者」 と表示されます。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
Sipはエンコーディングを受け入れます |
コンテンツエンコーディングのgzip機能をサポートします。 gzipを選択すると、SIPメッセージヘッダーに「Accept-Encoding: gzip」という文字列が含まれ、 電話はgzip形式でエンコードされたSIPメッセージ本文を処理できます。 設定を行うには、次の操作のいずれかを実行してください。
許可される値:なしと gzip デフォルト:なし |
|
SIP IPプリファレンス |
電話がIPv4とIPv6のどちらを使用するかを設定します。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:IPv4 | IPv6 デフォルト:IPv4 |
|
ローカル名をヘッダーに無効にする |
発信時の「ディレクトリ」、「通話履歴」、および「宛先」ヘッダーの表示名を制御します。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
ユーザー優先オフフックタイマー |
オフフックになってからダイヤルを開始するまで電話が待機する時間(秒単位)。
設定すると、 設定を行うには、次の操作のいずれかを実行してください。
許可される値:0-30 デフォルト:空です |
| シェアラインイベントパッケージタイプ |
ダイアログベースの共有回線を有効にして、 共有回線の電話がダイアログイベントパッケージに登録できるようにします。 設定を行うには、次の操作のいずれかを実行してください。
許容値:通話情報 | ダイアログ デフォルト:通話情報 |
| SIP通知認証が延長されました |
非プロキシSIPブロックが無効になっているときに、 UDP経由で受信したダイアログ外のSIP NOTIFYリクエストの認証を強化できます。
設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
SIPタイマー値
次の表では、SIPタイマー値セクションで使用可能なSIPパラメータについて説明しています。
|
パラメーター |
説明 |
|---|---|
|
SIP T1 |
RFC 3261 T1の値(RTTの推定値)は、0秒から64秒までの範囲で指定できます。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:0.5秒 |
|
SIP T2 |
RFC 3261 T2値( 非INVITEリクエストとINVITEレスポンスの最大再送信間隔)は、0秒から64秒の範囲で指定できます。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:4秒 |
|
SIP T4 |
RFC 3261 T4値(メッセージがネットワークに残っている最大時間)。 範囲は0〜64秒です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:5秒。 |
|
SIPタイマー B |
INVITEのタイムアウト値。範囲は0〜64秒です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:16秒。 |
|
SIP タイマー F |
招待されないタイムアウト値。範囲は0〜64秒です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:16秒。 |
|
SIPタイマー H |
INVITEの最終応答、タイムアウト値。0〜64秒です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:16秒。 |
|
SIP タイマー D |
ACKのハングアラウンド時間。範囲は0〜64秒です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:16秒。 |
|
SIPタイマー J |
INVITE以外の応答のハングアラウンド時間。範囲は0〜64秒です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:16秒。 |
|
招待の有効期限が切れます |
招待リクエストはヘッダーの値を失効させます。 0を入力すると、 Expiresヘッダーはリクエストに含まれません。 0から200万までの範囲です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:240秒 |
|
再招待の有効期限が切れます |
ReInviteリクエストはヘッダーの値を失効させます。 0を入力すると、 Expiresヘッダーはリクエストに含まれません。 0から200万までの範囲です。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:30 |
|
Reg Minの有効期限が切れます |
ExpiresヘッダーまたはContactヘッダーパラメーターでプロキシから許可される最小登録有効期限。 プロキシがこの設定よりも小さい値を返す場合は、最小値が使用されます。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:1 |
|
Reg Maxの有効期限が切れます |
Min-Expiresヘッダーでプロキシから許可される最大登録有効期限。 値がこの設定よりも大きい場合は、最大値が使用されます。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:7200 |
|
登録再試行 Intv |
Cisco IP Phoneが前回の登録に失敗した後、 登録を再試行するまでの待機間隔。 範囲は1から2147483647までです 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:30 詳細については、以下のメモを参照してください。 |
|
登録、再試行、ロングインターナショナル |
SIP応答コードが一致しないために登録が失敗すると<Retry Reg RSC>、Cisco IP Phoneは指定された時間待ってから再試行します。 この間隔が0の場合、電話は試行を停止します。 この値は 、Reg Retry Intlの値よりもはるかに大きいはずです。0であってはなりません。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:1200 詳細については、以下のメモを参照してください。 |
|
reg リトライランダムディレイ |
障害発生後にREGISTERを再試行するときに、 <Register Retry Intvl>に追加するランダムな遅延範囲(秒単位)。 ショートタイマーに追加されるランダム遅延の最小値と最大値。 範囲は0から2147483647までです。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:0 |
|
登録再試行ロング・ランダム・ディレイ |
障害発生後にREGISTERを再試行するときに、 Register Retry Long Intlパラメータに追加するランダムな遅延範囲(秒単位)。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:0 |
|
登録リトライ国際帽子 |
指数関数的遅延の最大値。 指数関数的バックオフ再試行遅延の上限値 (Register Retry Intvlから始まり、再試行のたびに2倍になります)。 デフォルトは0で、 指数バックオフは無効です(つまり、エラーの再試行間隔は常にRegister Retry Intervlです)。 この機能を有効にすると、Reg Retry Random Delayが指数バックオフ遅延値に加算されます。 範囲は0から2147483647までです。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:0 |
|
サブミニオンが期限切れです |
プロキシサーバーから返されるREGISTERの有効期限値の下限を設定します。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:10 |
|
サブマックスの有効期限が切れます |
プロキシサーバーからMin-Expiresヘッダーに返されるREGISTERの最小有効期限値の上限を設定します。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:7200 |
|
サブリトライインターナショナル |
この値(秒単位)は、 最後のSubscribeリクエストが失敗したときの再試行間隔を決定します。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:10 |
要求を処理するには負荷が高すぎるSIPプロキシサーバーから電話を受信すると、RETRY-AFTER 値を使用できます(503 Service Unailable というメッセージ)。 応答メッセージにRETRY-AFTERヘッダーが含まれている場合、 電話は指定された時間待機してから再度登録します。 RETRY-AFTER ヘッダーがない場合、電話は Reg Retry Interval または Reg Long Interval で指定された値を待ちます。
応答ステータスコードの処理
次の表では、レスポンス・ステータス・コード・ハンドリング・セクションで使用可能なSIPパラメータについて説明しています。
|
パラメーター |
説明 |
|---|---|
|
バックアップRSCを試してみてください |
電話がフェールオーバーしてバックアップサーバーへの登録を試みるきっかけとなるSIP応答ステータスコードを指定します。 たとえば、500という数値を入力することも、
複数の値が可能な場合は数値とワイルドカードの組み合わせを入力することもできます。 後者については、
設定を行うには、次の操作のいずれかを実行してください。
デフォルト:空です |
|
Reg RSCを再試行してください |
電話機が登録を再試行するきっかけとなるSIP応答ステータスコードを指定します。 たとえば、500という数値を入力することも、
複数の値が可能な場合は数値とワイルドカードの組み合わせを入力することもできます。 後者については、
設定を行うには、次の操作のいずれかを実行してください。
デフォルト:空です |
RTPパラメーター
次の表では、RTPパラメータセクションで使用可能なSIPパラメータについて説明しています。
|
パラメーター |
説明 |
|---|---|
|
RTP ポートマイン |
RTP送受信用の最小ポート番号。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:2048から49151まで 値の範囲(RTPポートの最大値- RTPポート最小値)が16未満の場合、またはパラメータを誤って設定した場合は、 代わりにRTPポート範囲(16382~32766)が使用されます。 デフォルト:16384 |
|
RTP ポートマックス |
RTP送受信用の最大ポート番号。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:2048から49151まで 値の範囲(RTPポートの最大値- RTPポート最小値)が16未満の場合、またはパラメータを誤って設定した場合は、 代わりにRTPポート範囲(16382~32766)が使用されます。 デフォルト:16482 |
|
RTPパケットサイズ |
RTP音声ストリームの音声パケット化間隔(秒単位)を指定します 設定を行うには、次の操作のいずれかを実行してください。
許容値:0.01から0.13までの範囲です。 有効な値は0.01秒の倍数でなければなりません。 デフォルト:0.02 |
|
最大RTP ICMPエラー |
電話が通話を終了する前にRTPパケットをピアに送信するときに許容されるICMPエラーの連続数。 値が0に設定されている場合、電話はICMPエラーの制限を無視します 。 設定を行うには、次の操作のいずれかを実行してください。
許可される値:0-10 デフォルト:0 |
|
RTCPの送信間隔 |
アクティブな接続に関するRTCP送信者レポートを送信する間隔。 設定を行うには、次の操作のいずれかを実行してください。
許可される値:0 から 255 秒 デフォルト:0 |
|
通話統計 |
通話が終了または保留になったときに、 電話が通話終了統計をSIPメッセージで送信するかどうかを指定します。 設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
SDP IPプリファレンス |
電話がRTPアドレスとして使用する優先IPを選択してください。 電話がデュアルモードで、IPv4アドレスとIPv6アドレスの両方がある場合、SDPには常に両方のアドレスが属性「a=altc...」 で含まれます。 IPv4アドレスを選択した場合、 IPv4アドレスはSDPのIPv6アドレスよりも優先され、電話はipv4 RTPアドレスの使用を好むことがわかります。 電話にipv4アドレスまたはIPv6アドレスのみがある場合、 SDPにはALTC属性はなく、RTPアドレスは「c=」行で指定されます。 デュアルモードでの動作については、「デュアルモードでのSIPとRTPの動作」を参照してください。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:IPv4 | IPv6 デフォルト:IPv4 |
|
バック前のRTP |
RTPセッションを、 発信側からACKを受信する前か後に開始するかを指定できます。
設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
SSRCはRxへの再招待時にリセットされました |
着信RE-INVITEの発信RTPセッションとSRTPセッションの同期ソース(SSRC)をリセットするかどうかを制御します。
設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
送信時にSSRCがリセットされました |
発信RE-INVITEの発信RTPセッションとSRTPセッションの同期ソース(SSRC)をリセットするかどうかを制御します。
設定を行うには、次の操作のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
SDPペイロードタイプ
お使いのシスコのIP電話はRFC4733をサポートしています。 DTMFパルスをサーバーに送信するには、3つのオーディオビデオトランスポート(AVT) オプションから選択できます。
設定された動的ペイロードは、 Cisco IP Phoneがセッション記述プロトコル(SDP)オファーを提供する場合にのみ発信コールに使用されます。 SDPオファー付きの着信通話では、電話は発信者が割り当てた動的ペイロードタイプに従います。
Cisco IP電話は、アウトバウンドSDPに設定されたコーデック名を使用します。 標準ペイロードタイプが0〜95の着信SDPでは、電話はコーデック名を無視します。 ダイナミックペイロードタイプの場合、電話機は設定されたコーデック名でコーデックを識別します。 比較では大文字と小文字が区別されるので、名前を正しく設定する必要があります。
次の表では、SDPペイロードタイプセクションで使用可能なSIPパラメータについて説明しています。
|
パラメーター |
説明 |
|---|---|
|
G711uコーデック名 |
SDPで使用されているG711uコーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:PCMU |
|
G711aコーデック名 |
SDPで使用されるG711aコーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:PCMA |
|
g729aコーデック名 |
SDPで使用されるg729aコーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:G729a |
|
G722コーデック名 |
SDPで使用されるG722コーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:G722 |
|
G722.2 コーデック名 |
SDPで使用されるG722.2コーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:AMR-WB |
|
iLBCコーデック名 |
SDPで使用されるiLBCコーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:iLBC |
|
iSACコーデック名 |
SDPで使用されるiSACコーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:IsaC |
|
OPUS コーデック名 |
SDPで使用されているOPUSコーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:オーパス |
|
AVTコーデック名 |
SDPで使用されるAVTコーデック名。 設定を行うには、次の操作のいずれかを実行してください。
デフォルト:電話イベント |
|
G722.2 ダイナミックペイロード |
G722ダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:96 |
|
G722.2 OA ダイナミックペイロード |
G722.2 OA ダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:103 |
|
iLBC 20ミリ秒のダイナミックペイロード |
iLBC 20msダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:97 |
|
iLBC 30ミリ秒のダイナミックペイロード |
iLBC 20msダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:105 |
|
iSACダイナミックペイロード |
iSACダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:98 |
|
OPUS ダイナミックペイロード |
OPUS ダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:99 |
|
RSFECダイナミックペイロード |
RSFECダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:113 |
|
AVT ダイナミックペイロード |
AVTダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:101 |
|
AVT 16kHzダイナミックペイロード |
16 kHzクロックレート用のAVTダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:101 |
|
AVT 48kHzダイナミックペイロード |
48 kHzクロックレート用のAVTダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:101 |
|
INFOREQ ダイナミックペイロード |
INFOREQ ダイナミックペイロードタイプ。 設定を行うには、次の操作のいずれかを実行してください。
許可されている値:96-127 デフォルト:101 |
NATサポートパラメータ
NATサポートに関連するパラメータについては、電話でのNATトラバーサルを参照してください。
拡張機能のSIP設定を行います
回線ごとのSIP設定で、電話機が個々の内線のSIPシグナリング、 登録、およびメディアを処理する方法を定義できます。
| 1 |
電話管理ウェブページにアクセスしてください。 |
| 2 |
を選択します。 |
| 3 |
SIP設定セクションで、 拡張SIP設定のパラメータで説明されているようにパラメータを設定します |
| 4 |
「すべての変更を送信」をクリックします。 |
拡張SIP設定のパラメーター
次の表は、電話Webインターフェイスの「 > Ext (n)」 タブにあるSIP設定セクションのパラメータの機能と使用方法を定義しています。 また、パラメータを設定するためにXML(cfg.xml)コードを使用して電話設定ファイルに追加される文字列の構文も定義します。
|
パラメーター |
説明 |
|---|---|
|
SIPトランスポート |
SIPメッセージの転送プロトコルを指定します。 AUTOに設定すると、 電話はDNSサーバーのNAPTRレコードに基づいて適切なプロトコルを自動的に選択します。 次のいずれかを実行してください。
許可されている値:UDP | TCP | TLS | オート デフォルト:UDP |
|
SIPポート |
SIPメッセージのリスニングと送信のための電話のポート番号。 ここでポート番号を指定するのは、 UDPをSIPトランスポートプロトコルとして使用している場合だけです。 TCPを使用している場合、システムは [] > [SIP] タブの [ SIP TCPポートの最小値] と [SIP TCPポートの最大値] で指定された範囲内のランダムなポートを使用します。 SIPプロキシサーバーのポートを指定する必要がある場合は、 プロキシフィールドまたはXSIホストサーバーフィールドを使用して指定できます。 次のいずれかを実行してください。
デフォルト:5060 |
|
SIP 100REL を有効にする |
SIP 100REL機能を個別に有効にします。 有効にすると、電話は100REL SIP拡張をサポートし、暫定応答(18x)を確実に送信し、PRACKリクエストを使用します。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
EXT SIP ポート |
外部SIPポート番号。 次のいずれかを実行してください。
許容値: デフォルト:5060 |
|
認証、再同期、再起動 |
Cisco IP Phoneは、 次の要求を含むNOTIFYメッセージを受信すると、送信者を認証します。
次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:はい |
|
SIPプロキシ-必須 |
SIPプロキシは、 ユーザーエージェントからProxy-Requireヘッダーを受信すると、特定の拡張や動作をサポートできます。 このフィールドが設定されていて、 プロキシがそれをサポートしていない場合、プロキシは「サポートされていません」というメッセージで応答します。 次のいずれかを実行してください。
デフォルト:空白 |
|
SIPリモートパーティーID |
Fromヘッダーの代わりに使用するリモートパーティIDヘッダー。 有効にするには「はい」 を選択してください。 デフォルト:はい |
|
紹介者バイディレイ |
コール転送の完了時に、電話がいつBYEを送信して古いコールレッグを終了するかを制御します。 この画面では、複数の遅延設定(リファラー、リファーターゲット、レフリー、 リファーターゲット)が設定されています。 次のいずれかを実行してください。
許可される値:0から65535までの整数 デフォルト:4 |
|
参照先:対象の連絡先 |
参照先を示します。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
レフェリー、バイ・ディレイ |
レフェリーのバイディレイ時間を秒単位で指定します。 次のいずれかを実行してください。
許可される値:0から65535までの整数 デフォルト:0 |
|
ターゲットのバイディレイを紹介 |
ReferTarget Bye遅延時間を秒単位で指定します。 次のいずれかを実行してください。
許可される値:0から65535までの整数 デフォルト:0 |
|
スティッキー 183 |
アウトバウンドINVITEの最初の183 SIP応答を制御します。 この機能を有効にするには、 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
認証と招待 |
SIPプロキシから最初に受信するINVITEリクエストに認証が必要かどうかを制御します。 この機能を有効にするには。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
1xx-to-INVについて紹介しました |
「はい」 に設定した場合、転送先は「イベント:転送先から転送コールレッグで1xxの応答が返された場合は、 転送者に問い合わせてください」 という通知が電話から送信されます。 「いいえ」に設定すると、 電話は最終応答(200以上)にのみNOTIFYを送信します。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:はい |
|
G729アネックスBセット |
G.729アネックスBの設定を行います。 次のいずれかを実行してください。
許容値:なし | いいえ |はい | フォローサイレンスサポート設定 デフォルト:はい |
|
低帯域幅のOPUSを使用してください |
ネットワークの帯域幅を改善するには、 狭帯域OPUSコーデックを使用するように電話を設定できます。 ナローバンドコーデックはワイドバンドコーデックと競合しません。 次のいずれかを実行してください。
許容値:いいえ |はい デフォルト:いいえ |
|
音声品質レポートのアドレス |
電話が通話品質に関する診断レポートを送信する宛先を指定します。 ドメイン名またはIPアドレスのどちらかを入力できます。 このパラメータには、ドメイン名またはIPアドレスと一緒にポート番号を追加することもできます。 ポート番号を入力しない場合、SIP UDPポート (5060)の値がデフォルトで使用されます。 コレクターサーバーのURLパラメーターが空の場合、SIP PUBLISHメッセージは送信されません。 次のいずれかを実行してください。
デフォルト:空です |
|
音声品質レポートの間隔 |
電話機が音声品質レポートを生成して、 設定されたレポートアドレスに送信する頻度を指定します。 間隔は分単位で測定されます。 間隔を短くすると、監視の更新頻度が高くなりますが、レポートトラフィックが増える可能性があります。 一方、間隔を長くすると、オーバーヘッドは減りますが、細分性は低下します。 デフォルトの間隔は0です。つまり、定期的なレポートは送信されません。 次のいずれかを実行してください。
デフォルト:0 |
| 音声品質レポートグループ |
電話から音声品質レポートを送信するときに使用するグループ識別子を定義します。 このパラメータを使用すると、 複数の電話を同じレポートグループにまとめることができるため、 管理者は通話品質データを簡単にソート、フィルタリング、分析できます。 次のいずれかを実行してください。
デフォルト:空です |
|
ユーザー・イコール・フォン |
電話のURLがSIP URLに変換され、 電話番号がURLのユーザー部分で表される場合、SIP URLにはオプションの:user=phoneパラメーター(RFC3261)が含まれます。 例えば: 宛先:sip: + 12325551234@example.com; ユーザー=電話 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
プライバシーヘッダー |
信頼できるネットワークのSIPメッセージにユーザーのプライバシーを設定します。 プライバシーヘッダーのオプションは次のとおりです。
次のいずれかを実行してください。
許可される値:無効 | なし | ヘッダー | セッション | ユーザー | ID デフォルト:無効 |
|
-アーリー・メディア・サポート |
P-Early-Mediaヘッダーを発信通話のSIPメッセージに含めるかどうかを制御します。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
SIPセッション ID サポート |
SIPセッションIDヘッダー(RFC 7989で定義されています)を使用して、 エンドツーエンドの通信セッションを一意に識別できます。 セッションIDは、通話が転送、転送、 または複数のSIP仲介業者を経由した場合でも、 通話レッグ間で同じままです。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:はい |
|
メディアセックのリクエスト |
SIP通話の設定中に、電話がメディアセキュリティ(MediaSEC)の使用を要求するかどうかを指定します。 有効にすると、 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
メディアセックオーバーTLSのみ |
SIPシグナリングがTLSで保護されている場合にのみ、電話がメディアセキュリティ(MediaSEC、RFC 3329)を使用するかどうかを制御します。 有効にすると、電話にはTLSベースのSIPセッションにのみMediaSEC( 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
前提条件サポート |
電話の「Supported」ヘッダーフィールドに前提条件タグ(RFC 3312で定義されている) が含まれているかどうかを判断します。
次のいずれかを実行してください。
許容値:無効 | 有効 デフォルト:無効 |
|
認証サポート RFC8760 |
RFC 8760 — SIPのダイジェスト認証(SHA-256/512) で定義されている認証スキームのサポートを有効にします。 この標準は、古いMD5ベースのダイジェスト (RFC 2617)と比較して、 より強力で安全なハッシュ関数を使用するようにSIP認証を拡張しています。 有効にすると、電話はSIPサーバーから要求されたときにSHA-256/SHA-512ダイジェスト認証をサポートします。 無効にすると、電話は従来のMD5ダイジェスト(RFC 2617)認証のみをサポートします。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
電話でのNATトラバーサル
ネットワークアドレス変換(NAT)を使用すると、 複数のデバイスが単一のルーティング可能なパブリックIPアドレスを共有して、インターネット経由で接続を確立できます。 NATは多くのブロードバンドアクセスデバイスに搭載されており、パブリックIPアドレスとプライベートIPアドレスを変換します。 VoIPとNATを共存させるには、NATトラバーサルが必要です。
すべてのサービスプロバイダーがNATトラバーサルを提供しているわけではありません。 サービスプロバイダーがNATトラバーサルを提供していない場合は、いくつかの選択肢があります。
-
セッション・ボーダー・コントローラーによるNATマッピング: セッション・ボーダー・コントローラーによるNATマッピングをサポートするサービス・プロバイダーを選ぶことをお勧めします。 サービスプロバイダーが提供するNATマッピングでは、 ルーターの選択の選択肢が広がります。
-
SIP-ALGルーターによるNATマッピング:NATマッピングは、SIPアプリケーション層ゲートウェイ(ALG) を備えたルーターを使用することで実現できます。 SIP-ALGルーターを使用すると、 サービスプロバイダーを選択する際の選択肢が増えます。
-
静的IPアドレスによるNATマッピング:サービスプロバイダーとの相互運用性を確保するために、外部(パブリック) 静的IPアドレスとのNATマッピングを実現できます。 ルーターで使用されるNATメカニズムは対称でなければなりません。 詳細については、「NATが対称か非対称かを判断する」を参照してください。
NATマッピングは、 サービスプロバイダーネットワークがセッションボーダーコントローラー機能を提供しない場合にのみ使用してください。 静的IPでNATマッピングを設定する方法の詳細については、「 静的IPアドレスでNATマッピングを設定する」を参照してください。
-
STUNによるNATマッピング: サービスプロバイダーのネットワークがセッションボーダーコントローラー機能を提供しておらず、 他の要件が満たされている場合は、NAT用のセッショントラバーサルユーティリティ(STUN)を使用してNATマッピングを見つけることができます。 STUNでNATマッピングを設定する方法については、「STUNを使ったNATマッピングの設定」を参照してください。
静的IPアドレスでNATマッピングを設定します
サービスプロバイダーとの相互運用性を確保するために、電話機のNATマッピングを設定してください。
始める前に
-
静的な外部(パブリック)IPアドレスが必要です。
-
ルーターで使用されるNATメカニズムは対称でなければなりません。
| 1 |
電話管理ウェブページにアクセスしてください。 |
| 2 |
。 |
| 3 |
NATサポートパラメータセクションで、 静的IPアドレスのNATマッピングのパラメータで説明されているようにパラメータを設定します。 |
| 4 |
に移動します。n拡張子のインデックスはどこですか。 |
| 5 |
NAT設定セクションで、 拡張機能のNATマッピングのパラメータで説明されているようにパラメータを設定します。 |
| 6 |
「すべての変更を送信」をクリックします。 |
次にすべきこと
SIPトラフィックを許可するようにルーターのファイアウォール設定を構成してください。
STUNでNATマッピングを設定してください
サービスプロバイダーネットワークにセッションボーダーコントローラー(SBC)がなく、その他の要件が満たされている場合は、NAT用セッショントラバーサルユーティリティ (STUN)を使用してNATマッピングを検出できます。
STUNを使用すると、NATの背後で動作するアプリケーションは次のことが可能になります。
- 通信経路にNATが存在することを検出します。
- NATがリモートホストへのUDP接続に割り当てるパブリック(マップされた)IPアドレスとポート番号を取得します。
このプロトコルには、NATのパブリック側、 通常はインターネットにあるサードパーティのSTUNサーバーが必要です。 このサーバーとメッセージを交換することで、 クライアントはNATがプライベートIPアドレスとポートをどのように変換するかを学びます。
STUNはフォールバックメカニズムと見なされ、 他のNATトラバーサル方法が利用できない場合にのみ使用してください。
始める前に
-
ルーターは非対称 NAT を使用する必要があります。 NATが対称か非対称かを判断するを参照してください。
-
STUNサーバーソフトウェアを実行しているコンピューターが利用可能でなければなりません。 パブリックSTUNサーバーを使用することも、独自のSTUNサーバーをセットアップすることもできます。
| 1 |
電話管理ウェブページにアクセスしてください。 |
| 2 |
。 |
| 3 |
NATサポートパラメータセクションで、 静的IPアドレスとのNATマッピングのパラメータの表に記載されているようにパラメータを設定します。 |
| 4 | |
| 5 |
「内部 (n) 」タブをクリックします。 |
| 6 |
NAT設定セクションで、 拡張のNATマッピングのパラメータの表に記載されているように、特定の拡張のパラメータを設定します。 |
| 7 |
「すべての変更を送信」をクリックします。 |
次にすべきこと
SIPトラフィックを許可するようにルーターのファイアウォール設定を構成してください。
NATが対称か非対称かを決めてください
STUNは対称NATを搭載したルーターでは動作しません。 対称型NATでは、IPアドレスは1つの内部IPアドレスとポートから、 ルーティング可能な1つの外部宛先IPアドレスとポートにマップされます。 同じ送信元IPアドレスとポートから別の宛先に別のパケットが送信される場合は、別のIPアドレスとポート番号の組み合わせが使用されます。 内部ホストが最初にそのポートから外部ホストにパケットを送信した場合にのみ、 外部ホストが内部ホストの特定のポートにパケットを送信できるため、 この方法には制限があります。
この手順は、syslogサーバーが設定され、 Syslogメッセージを受信する準備ができていることを前提としています。
始める前に
お使いのPCでファイアウォールが動作していないことを確認してください。 (Syslogポートをブロックできます。) デフォルトでは、syslogポートは514です。
| 1 |
電話管理ウェブページにアクセスしてください。 |
| 2 |
、 オプションのネットワーク設定セクションに移動します。 |
| 3 |
ポート番号がデフォルトの514以外の場合は、SyslogサーバーのIPアドレスを入力してください。 デフォルトのポートを使用する場合は、 ポート番号を含める必要はありません。 アドレスとポート番号は、Cisco IP電話からアクセスできる必要があります。 ポート番号は出力ログファイル名に表示されます。 ポート番号が指定されていない場合、
デフォルトの出力ファイル名はです |
| 4 |
デバッグレベルを [エラー]、[ 通知]、または [デバッグ] に設定します。 |
| 5 |
SIPシグナリングメッセージをキャプチャするには、「Ext (n)」タブをクリックして「SIP設定」 に移動します。 SIPデバッグオプションをフルに設定してください。 |
| 6 |
ルーターが使用しているNATの種類に関する情報を収集するには、、NATサポートパラメータに移動します。 |
| 7 |
STUNテストの有効化を 「はい」 に設定してください。 |
| 8 |
ログファイルのデバッグメッセージを見て、NATの種類を判断してください。 デバイスが対称NATを使用していることがメッセージに表示されている場合は、STUNを使用できません。 |
| 9 |
「すべての変更を送信」をクリックします。 |
NATマッピングのパラメータ
静的IPアドレスによるNATマッピングのパラメータ
次の表は、電話機のWebインターフェイスの「」>「SIP」タブの「NATサポートパラメータ」セクションにある静的IPパラメータによるNATマッピングの機能と使用方法を定義しています。 また、パラメータを設定するためにXML(cfg.xml)コードを使用して電話設定ファイルに追加される文字列の構文も定義します。
| パラメーター | 説明 |
|---|---|
|
受信した状態で処理してください |
VIAヘッダーで受信したパラメータを電話機で処理することを有効または無効にします。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
レポート経由で処理 |
次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
受信したビアを挿入 |
受信元IPと送信元のVIAのIP値が異なる場合に、 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
レポート経由で挿入 |
受信元IPと送信元のVIAのIP値が異なる場合、 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
代用ビアアドレス |
ユーザーがVIAヘッダーでNATマップされたIP: Port値を使用できるようにします。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
応答をSRCポートに送ってください |
VIAの送信ポートではなく、リクエストの送信元ポートに応答を送信できます 。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
EXT IP |
すべての発信SIPメッセージで電話の実際のIPアドレスの代わりとなる外部IPアドレス。 0.0.0.0が指定されている場合、IPアドレスの置換は実行されません。 このパラメータが指定されている場合、 電話はSIPメッセージとSDPを生成するときにこのIPアドレスを引き継ぎます(その回線でNATマッピングが有効になっている場合)。 次のいずれかを実行してください。
デフォルト:空です |
|
EXT RTPポートマイン |
電話機がRTPトラフィックに使用する外部NATマッピングの開始(最小)ポート番号。 次のいずれかを実行してください。
デフォルト:0 |
|
NATキープアライブインターナショナル |
NATマッピングのキープアライブメッセージの間隔。 次のいずれかを実行してください。
許容値:0から65535までの数値範囲 デフォルト:15 |
|
キープアライブをリダイレクト |
問題が発生したときに接続を維持するために、 リダイレクトされたサーバーにキープアライブメッセージを送信する電話を有効または無効にしてください。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
エクステンションのNATマッピングのパラメータ
次の表は、電話機のWebインターフェイスの「Voice」>「Ext」タブの「NATサポートパラメータ 」セクションにある静的IPパラメータによるNATマッピングの機能と使用方法を定義しています。 また、パラメータを設定するためにXML(cfg.xml)コードを使用して電話設定ファイルに追加される文字列の構文も定義します。
| パラメーター | 説明 |
|---|---|
|
NATマッピングを有効にする |
SIPメッセージでの外部にマッピングされたIPアドレスとSIP/RTPポートの使用を制御します。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
|
NATキープアライブイネーブル (オプション) |
NATを介した電話のSIP接続を維持するために、 電話がNATキープアライブメッセージを定期的に送信することを有効または無効にします。 次のいずれかを実行してください。
許容値:はい | いいえ デフォルト:いいえ |
STUNによるNATマッピングのパラメータ
次の表は、電話機のWebインターフェイスの「」>「SIP」タブの「NATサポートパラメータ」セクションにある、STUNパラメータによるNATマッピングの機能と使用方法を定義しています。 また、パラメータを設定するためにXML(cfg.xml)コードを使用して電話設定ファイルに追加される文字列の構文も定義します。
|
パラメーター |
説明 |
|---|---|
|
スタンイネーブル |
STUNを使ってNATマッピングを発見できるようにします。 次のいずれかを実行してください。
許可される値:はいといいえ。 デフォルト:いいえ |
|
スタンサーバー |
NATマッピング検出の連絡先となるSTUNサーバーのIPアドレスまたは完全修飾ドメイン名。 パブリックSTUNサーバーを使用することも、 独自のSTUNサーバーをセットアップすることもできます。 次のいずれかを実行してください。
デフォルト:空です |
デュアルモードでのSIPとRTPの動作
電話がデュアルモードの場合、SIP IPプリファレンスとSDP IPプリファレンスのフィールドでSIPとRTPのパラメータを制御できます。
SIP IP Preferenceパラメータは、 デュアルモードのときに電話が最初に試すIPアドレスを定義します。
|
IPモード |
SIP IPプリファレンス |
DNSからのアドレスリスト、優先度、結果 P1-最優先アドレス P2-2番目に優先されるアドレス |
フェイルオーバーシーケンス |
|---|---|---|---|
|
デュアルモード |
IPv4 |
P1- 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 結果:電話は最初に1.1.1.1にSIPメッセージを送信します。 |
1.1.1.1 ->2009:1:1:1:1 -> 2.2.2.2 -> 2009:2:2:2:2 |
|
デュアルモード |
IPv6 |
P1- 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 結果:電話は最初にSIPメッセージを 2009:1:1:1:: 1 に送信します。 |
2009:1:1:1:1 -> 1.1.1.1 -> 2009:2:2:2:2 -> 2.2.2.2 |
|
デュアルモード |
IPv4 |
P1- 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 結果:電話は最初にSIPメッセージを 2009:1:1:1:: 1 に送信します。 |
2009:1:1:1:1 -> 2.2.2.2 -> 2009:2:2:2:2 |
|
デュアルモード |
IPv6 |
P1- 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 結果:電話は最初に1.1.1.1にSIPメッセージを送信します。 |
2009:1:1:1:1 -> 2009:2:2:2:2 ->2.2.2.2 |
|
IPv4だけです |
IPv4 または IPv6 |
P1 - 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 結果:電話は最初に1.1.1.1にSIPメッセージを送信します。 |
1.1.1.1 -> 2.2.2.2 |
|
IPv6のみ |
IPv4 または IPv6 |
P1 - 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 結果:電話は最初にSIPメッセージを 2009:1:1:1:: 1 に送信します。 |
2009:1:1:1:1 -> 2009:2:2:2::2 |
メディアの信頼性と品質の設定を行います
メディア関連リソース情報(MARI)は、 SIPおよびRTPベースのネットワークでよく使用される信号および報告メカニズムです。これにより、電話と通話制御サーバーは、 通話に関するメディア品質情報をリアルタイムで、または通話終了後に交換できます。 通話品質指標を監視または記録したい場合は、MARIを有効にしてください。 有効にすると、電話はジッター、パケットロス、遅延、MOS(平均オピニオンスコア) などのメディアストリームに関する統計情報を監視システムに送り返します
転送エラー訂正(FEC)は、 失われたRTPパケットを再送信せずにリアルタイムで回復するために使用される方法です。 メディアストリームに冗長データを追加することで機能するので、 パケットが失われた場合、受信者は冗長情報からパケットを再構築できます。 FECは、 損失の多いネットワークや不安定なネットワークでの通話品質を向上させます。 有効にすると、 電話はパケットロスを防ぐために冗長なRTPデータを送受信します。
| 1 |
電話管理ウェブページにアクセスしてください。 |
| 2 |
を選択します。 |
| 3 |
MARI設定セクションで、 MARI有効とFEC有効を 「はい」 に設定して機能を有効にします。 デフォルトでは、これらの機能は無効になっています。 XML(cfg.xml)の電話設定ファイルを使用して、 次の形式で文字列を入力して設定することもできます。
|
| 4 |
「すべての変更を送信」をクリックします。 |