- בית
- /
- מאמר
תצורת SIP נכונה מאפשרת לטלפונים שלך להירשם לשרת SIP כדי לבצע ולקבל שיחות. ההגדרות מיועדות לטלפון באופן כללי ולתוספים. מאמר עזרה זה מיועד לסדרת הטלפון השולחני של סיסקו 9800 ולטלפון וידאו 8875 של סיסקו הרשומים בסיסקו ברודוורקס.
הגדר הגדרות SIP עבור הטלפון
| 1 |
גש לדף האינטרנט של ניהול הטלפון. |
| 2 |
בחר . |
| 3 |
הגדר את הפרמטרים כמתואר בפר מטרים להגדרות SIP בטלפון |
| 4 |
לחץ על שלח את כל השינויים. |
פרמטרים להגדרות SIP בטלפון
הפרמטרים הבאים זמינים בכרטיסייה בדף האינטרנט של ניהול הטלפון. עיין בטבלאות הבאות לפרמטרים המתאימים:
פרמטרים כלליים
הטבלה הבאה מתארת את הפרמטרים של SIP הזמינים בס עיף פרמטרים SIP.
|
פרמטר |
תיאור |
|---|---|
|
מקסימום פורוורד |
מציין ערך מקסימום העברה של SIP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 1 עד 255 ברירת מחדל: 70 |
|
ניתוב מחדש מקסימלי |
מציין את מספר הפעמים שניתן להפנות הזמנה כדי למנוע לולאה אינסופית. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 5 |
|
מקסימום אימות |
מציין את המספר המרבי של הפעמים (בין 0 ל 255) שניתן לערער על בקשה. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 0 עד 255 ברירת מחדל: 2 |
|
שם סוכן משתמש SIP |
משמש בבקשות יוצאות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: $VERSION אם ריק, הכותרת אינה כלולה. הרחבת מאקרו של $ A ל- $ D המתאימה למותר GPP_A GPP_D |
|
שם שרת SIP |
כותרת שרת המשמשת בתגובות לתגובות נכנסות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: $VERSION |
|
שם סוכן משתמש SIP Reg |
שם סוכן משתמש שישמש בבקשת REGISTER. אם זה לא צוין, שם סוכן משתמש SIP משמש גם לבק שת REGISTER. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
|
שפת קבלת SIP |
קבל-שפה את הכותרת המשמשת. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
אין ברירת מחדל. אם ריק, הכותרת אינה כלולה. |
|
סוג MIME ממסר DTMF |
סוג MIME המשמש בהודעת SIP INFO כדי לאותת על אירוע DTMF. שדה זה חייב להתאים לשדה של ספק השירות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: יישומ/ממסר dtmf |
|
סוג MIME פלאש הוק |
סוג MIME המשמש בהודעת SIPINFO כדי לאותת על אירוע הבזק וו. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: יישומ/וקר-פלאש |
|
הסר את הרישום האחרון |
מאפשר לך להסיר את הרישום האחרון לפני רישום חדש אם הערך שונה. הגדר את Yes כדי להסיר את הרישום האחרון. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
השתמש בכותרת קומפקטית |
אם מוגדר כ-כן, הטלפון משתמש בכותרות SIP קומפקטיות בהודעות SIP יוצאות. אם בקשות SIP נכנסות מכילות כותרות רגילות, הטלפון מחליף כותרות נכנסות בכותרות קומפקטיות. אם מוגדר כלא, הטלפונים משתמשים בכות רות SIP רגילות. אם בקשות SIP נכנסות מכילות כותרות קומפקטיות, הטלפונים עושים שימוש חוזר באותן כותרות קומפקטיות בעת יצירת התגובה, ללא קשר להגדרה זו. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
שם תצוגה בריחה |
מאפשר לך לשמור על שם התצוגה פרטי. הגדר את הערך Yes אם ברצונך שטלפון ה- IP יכלול את המחרוזת (המוגדרת בשם התצוגה) בזוג מרכאות כפולות להודעות SIP יוצאות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
חבילת שיחה |
מאפשר תמיכה בחבילת BroadSoft Talk המאפשרת ל משתמשים לענות או לחדש שיחה על ידי לחיצה על כפתור ביישום חיצוני. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
החזק את החבילה |
מאפשר תמיכה בחבילת BroadSoft Hold, המאפשרת ל משתמשים לבצע שיחה בהמתנה על ידי לחיצה על כפתור ביישום חיצוני. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
חבילת כנסים |
מאפשר תמיכה בחבילת הוועידה של BroadSoft המאפשרת למשתמשים להתחיל שיחת ועידה על ידי לחיצה על כפתור ביי שום חיצוני. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
RFC 2543 החזקת שיחה |
אם מוגדר כ-כן, יחידה כוללת תחביר c=0.0.0.0 ב- SDP בעת שליחת הזמנה מחדש של SIP לעמית כדי להחזיק את השיחה. אם מוגדר כלא, היחידה לא תכ לול את התחביר c=0.0.0.0 ב- SDP. היחידה תמיד תכלול תח ביר a=sendonly ב- SDP בשני המקרים. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: כן |
|
REG CID אקראי באתחול מחדש |
אם מוגדר כ-כן, הטלפון משתמש במזהה שיחה אקראי אחר לרישום לאחר אתחול התוכנה הבא. אם מוגדר כלא, טלפון ה- IP של Cisco מנסה להשתמש באותו מזהה שיחה לרישום לאחר אתחול התוכנה הבא. טלפון ה- IP של סיסקו משתמש תמיד במזהה שיחה אקראי חדש לרישום לאחר מחזור הפעלה, ללא קשר להגדרה זו. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
יציאת SIP TCP מינימלית |
מציין את מספר יציאת TCP הנמוך ביותר שניתן להשתמש בו עבור הפע לות SIP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 5060 |
|
יציאת SIP TCP מקסימלית |
מציין את מספר יציאת TCP הגבוה ביותר שניתן להשתמש בו עבור הפעלות SIP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 5080 |
|
כותרת מזהה המתקשר |
מספק את האפשרות לקחת את מזהה המתקשר מהכותרת PAYID-RPID-FROM, PAID-FROM, RPID-PAID-FROM, RPID-FROM או FROM. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: בתשלום RPID-מ | סיוע מ/י | RPID-בתשלום מ| RPID-מ | מ ברירת מחדל: בתשלום RPID-מ |
|
החזק את היעד לפני הפניה |
שולט אם להחזיק את רגל השיחה עם יעד ההעברה לפני שליחת REF ER למועבר בעת הפעלת העברת שיחה בהשתתפות מלאה (כאשר י עד ההעברה ענה). כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
הפעלת תיבת דו-שיח SDP |
כאשר מופעל וגוף ההודעה של Notify גדול מדי וגורם לפיצול, תיבת הדו -שיח XML של הודעת הודעה מפושטת; פרוטוקול תיאור הפעלה (SDP) אינו נ כלל בתוכן xml של תיבת הדו-שיח. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
שמור על שופט כאשר ההפניה נכשלה |
אם מוגדר ככן, הוא מגדיר את הטלפון לטפל מייד בהודעות NOTIFY sipfrag . כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
הצג מידע על הסחה |
הצג את פרטי ההסחה הכלולים בהודעת SIP ב- LCD או לא. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
הצג אנונימי מהכותרת |
הצג את מזהה המתקשר מהכותרת של הודעת SIP INVITE "מאת" כאשר מוגדר כYes, גם אם השיחה היא שיחה אנונימית. כאשר הפרמטר מוגדר כלא, הטלפון מציג את "מתקשר אנונימי" כמזהה המתקשר. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
קידוד אישור Sip |
תומך בתכונת gzip לקידוד התוכן. אם נבחר gzip, כותרת ההודעה SIP מכילה את המחרוזת "קבל-קידוד: gzip", והטלפון מסוגל לעבד את גוף ההודעה SIP, המקודד בפורמט gzip. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: none ו- gzip ברירת מחדל: אין |
|
העדפת IP של SIP |
מגדיר אם הטלפון משתמש ב- IPv4 או ב- IPv6. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: IPv4 | IPv6 ברירת מחדל: IPv4 |
|
השבת שם מקומי לכותרת |
שולט בשם התצוגה ב"ספרייה ", "היסטוריית שיחות" ובכותרת "אל" במהלך שיחה יוצאת. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
טיימר OffHook המועדף על המשתמש |
זמן (בשניות) שהטלפון ממתין לאחר הפסקת החיבור לפני תחילת החיוג.
כאשר מוגדרת תצורה, הגדרה זו תקדימית על כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 0-30 ברירת מחדל: ריק |
| סוג חבילת אירוע של קו שיתוף |
מאפשר את הקו המשותף המבוסס על דיאלוג, כך שהטלפונים בקו המשותף יוכלו להיר שם לחבילת אירועי הדו-שיח. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: פרטי שיחה | דיאלוג ברירת מחדל: פרטי שיחה |
| אישור הודעת SIP מורחב |
מאפשר אימות משופר עבור בקשות SIP NOTIFY מחוץ לדיאלוג המתקבלות באמצעות UDP כאשר Block NonProxy SIP מושבת.
כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
ערכי טיימר SIP
הטבלה הבאה מתארת את פרמטרי ה- SIP הזמינים בסעיף ערכי טיימר SIP.
|
פרמטר |
תיאור |
|---|---|
|
SIP T1 |
ערך RFC 3261 T1 (אומדן RTT) שיכול לנוע בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 0.5 שניות |
|
SIP T2 |
ערך RFC 3261 T2 (מרווח שידור חוזר מרבי לבקשות ש אינן INVITATE ותגובות INVITE) שיכול לנוע בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 4 שניות |
|
SIP T4 |
ערך RFC 3261 T4 (משך זמן מקסימלי של הודעה ברשת), שיכול ל נוע בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 5 שניות. |
|
טיימר SIP ב |
ערך פסק זמן של INVITE, שיכול לנוע בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 16 שניות. |
|
טיימר SIP F |
ערך פסק זמן ללא הזמנה, שיכול לנוע בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 16 שניות. |
|
טיימר SIP H |
תשובה סופית של INVITE, ערך פסק זמן, שיכול להיות בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 16 שניות. |
|
טיימר SIP ד |
זמן ההמתנה של ACK, שיכול לנוע בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 16 שניות. |
|
טיימר SIP J |
זמן התגובה ללא הזמנה, שיכול לנוע בין 0 ל -64 שניות. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 16 שניות. |
|
תוקף ההזמנה פג |
פג תוקף ערך הכותרת של בקשת INVITE. אם אתה מזן 0, ה כותרת Expigs אינה כלולה בבקשה. נע בין 0 ל 2000000. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 240 שניות |
|
פג תוקף של ReInvite |
ערך הכותרת של בקשת ReInvite פג תוקף. אם אתה מזן 0, ה כותרת Expigs אינה כלולה בבקשה. נע בין 0 ל 2000000. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 30 |
|
פג תוקף הרישום |
זמן תפוגת רישום מינימלי המותר מהפרוקסי בכותרת Expi ges או כפרמטר כותרת איש קשר. אם ה- proxy מחזיר ערך הנמוך מ הגדרה זו, נעשה שימוש בערך המינימלי. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 1 |
|
פג תוקף של רג מקס |
זמן תפוגת ההרשמה המרבי המותר מהפרוקסי בכותרת Min-Expires. אם הערך גדול מהגדרה זו, נעשה שימוש בערך המרבי. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 7200 |
|
Reg נסה שוב ב- Intv |
מרווח המתנה לפני שטלפון ה- IP של סיסקו ינסה להי רשם מחדש לאחר כישלון במהלך ההרשמה האחרונה. הטווח הוא בין 1 ל 2147483647 כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 30 עיין ב הע רה למטה לפרטים נוספים. |
|
ניסיון חוזר של Reg Intvl |
כאשר ההרשמה נכשלת עם קוד תגובה SIP שאינו תואם<Retry Reg RSC>, טלפון ה- IP של Cisco ממתין למשך הזמן שצוין לפני ניסיון חוזר. אם מרווח זה הוא 0, הטלפון מפסיק לנסות. ערך זה צריך להיות גדול בהרבה מערך Reg Retry Intvl, שלא אמור להיות 0. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 1200 עיין ב הע רה למטה לפרטים נוספים. |
|
עיכוב אקראי לניסיון חוזר של Reg |
טווח עיכוב אקראי (בשניות) להוסיף ל- <Register Retry Intvl> בעת ניסיון חוזר ב- REGISTER לאחר כישלון. עיכוב אקראי מינימלי ומקסימלי שיתווסף לטיימר הקצר. הטווח הוא בין 0 ל 2147483647. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 0 |
|
Reg נסה שוב עיכוב אקראי ארוך |
טווח עיכוב אקראי (בשניות) כדי להוסיף לפרמטר Register Retry Long Intvl בעת ניסיון חוזר של REGISTER לאחר כישל ון. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 0 |
|
כובע קבלת ניסיון חוזר של Reg |
הערך המרבי של העיכוב האקספוננציאלי. הערך המרבי כדי לכסות את עיכוב הניסיון החוזר האקספוננציאלי (המתחיל ב- Register Retry Intvl ומכפיל כל ניסיון חוזר). ברירת המחדל היא 0, מה שמשבית את החזרה האקספוננצי אלית (כלומר, מרווח הניסיון מחדש של השגיאה נמצא תמיד ב- Register Retry Intvl). כאשר תכונה זו מופעלת, ה- Reg Reg Retry Random Delay מתווסף לערך עיכוב החזרה האקספוננציאלי. הטווח הוא בין 0 ל 2147483647. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 0 |
|
פג תוקף תת מינימום |
מגדיר את הגבול התחתון של ערך פג תוקף REGISTER שהוחזר מש רת ה- Proxy. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 10 |
|
פג תוקף תת-מקסימום |
מגדיר את הגבול העליון של הערך REGISTER minשהוחזר מש רת ה- Proxy בכותרת Min-Expires. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 7200 |
|
תת-ניסיון חוזר |
ערך זה (בשניות) קובע את מרווח הניסיון החוזר כאשר בקשת ההרשמה האחרונה נכ שלת. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: 10 |
הטלפון יכול להשתמש בערך RETRY-AFTER כאשר הוא מתקבל משרת proxy SIP שעסוק מכדי לעבד בקשה (הודעת 503 שירות לא זמין). אם הודעת התגובה כוללת כותרת RETRY-AFTER, הטלפון ממתין למשך הזמן שצ וין לפני רישום שוב. אם כותרת RETRY-AFTER אינה קיימת, הטלפון ממתין לערך שצ וין במרווח ניסיון חוזר של Reg או במרווח הארוך של ניסיון חוזר של Reg.
טיפול בקוד מצב תגובה
הטבלה הבאה מתארת את פרמטרי ה- SIP הזמינים בסעיף טיפול בקוד מצב תגובה.
|
פרמטר |
תיאור |
|---|---|
|
נסה גיבוי RSC |
מציין את קודי מצב תגובת SIP שגורמים לטלפון להיכשל ולנסות להירשם בשרת גיבוי. לדוגמה, ניתן להכניס ערכים מספריים 500 או שילוב של ערכים מספריים
בתוספת תווים פראיים אם קיימים ערכים מרובים. עבור מאוחר יותר, אתה יכול להשתמש
כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
|
נסה שוב את Reg RSC |
מציין את קודי מצב תגובת SIP המפעילים את הטלפון לנסות שוב ניסיונות רישום. לדוגמה, ניתן להכניס ערכים מספריים 500 או שילוב של ערכים מספריים
בתוספת תווים פראיים אם קיימים ערכים מרובים. עבור מאוחר יותר, אתה יכול להשתמש
כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
פרמטרים של RTP
הטבלה הבאה מתארת את פרמטרי ה- SIP הזמינים בסעיף פרמטרים של RTP.
|
פרמטר |
תיאור |
|---|---|
|
מינימום יציאת RTP |
מספר יציאה מינימלי לשידור וקליטה של RTP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 2048 עד 49151 אם טווח הערכים (RTP Port Max - RTP Port Min) נמוך מ- 16 או שאתה מגדיר את הפרמטר באופן שגוי, טווח יציאת RTP (16382 עד 32766) משמש במקום זאת. ברירת מחדל: 16384 |
|
יציאת RTP מקס |
מספר יציאה מרבי לשידור וקליטה של RTP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 2048 עד 49151 אם טווח הערכים (RTP Port Max - RTP Port Min) נמוך מ- 16 או שאתה מגדיר את הפרמטר באופן שגוי, טווח יציאת RTP (16382 עד 32766) משמש במקום זאת. ברירת מחדל: 16482 |
|
גודל מנות RTP |
מציין את מרווח חבילת השמע (בשניות) עבור זרמי קול RTP כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: טווחים בין 0.01 ל 0.13. ערכים תקפים חייבים להיות מכפיל של 0.01 שניות. ברירת מחדל: 0.02 |
|
שגיאת ה- ICMP מקסימלית של RTP |
מספר שגיאות ICMP רצופות המותרות בעת העברת מנות RTP לעמית לפני ש הטלפון מסיים את השיחה. אם הערך מוגדר ל- 0, הטלפון יתעלם מהמגבלה על שגיאות ICMP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 0-10 ברירת מחדל: 0 |
|
מרווח RTCP Tx |
מרווח לשליחת דוחות שולח RTCP בחיבור פעיל. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 0 עד 255 שניות ברירת מחדל: 0 |
|
סטטיסטיקת שיחות |
מציין אם הטלפון שולח נתונים סטטיסטיים של סיום השיחה בתוך הודעות SIP כאשר שיחה מסתיימת או מושבתת. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
העדפות IP של SDP |
בחר את ה- IP המועדף בו הטלפון משתמש ככתובת RTP. אם הטלפון נמצא במצב כפול ויש לו גם כתובות ipv4 וגם ipv6, הוא תמיד יכ לול את שתי הכתובות ב- SDP לפי תכונות "a=altc... אם נבחרה כתובת IPv4, לכתובת ipv4 יש עדיפות גבוהה יותר מכתובת ipv6 ב- SDP ומצי ינת שהטלפון מעדיף להשתמש בכתובת IPv4 RTP. אם לטלפון יש רק כתובת ipv4 או כתובת ipv6, ל- SDP אין תכונות ALTC וכתובת RTP מוגדרת בשורה "c =". לקבלת מידע על ההתנהגות במצב כפול, ראה התנהגויות SIP ו- RTP במצב כפול. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: IPv4 | IPv6 ברירת מחדל: IPv4 |
|
RTP לפני ACK |
מאפשר לך לציין אם הפעלת RTP תתחיל לפני או אחרי קבלת ACK מהצד המתק שר.
כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
איפוס SSRC בהזמנת Rx מחדש |
שולט אם לאפס את מקור הסנכרון (SSRC) עבור הפעלות RTP ו- SRTP היוצאות ב- RE-INVITE נכנסת.
כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
איפוס SSRC בהזמנה מחדש של Tx |
שולט אם לאפס את מקור הסנכרון (SSRC) עבור הפעלות RTP ו- SRTP היוצאות ב- RE-INVITE יוצאות.
כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
סוגי מטען SDP
טלפון ה- IP של סיסקו תומך ב- RFC4733. באפשרותך לבחור מבין שלוש אפשרויות הובלת אודיו-וידאו (AVT) לשליחת פולסי DTMF לשרת.
מטענים דינמיים מוגדרים משמשים לשיחות יוצאות רק כאשר טלפון ה- IP של Cisco מציג הצעה של פרוטוקול תיאור הפעלה (SDP). עבור שיחות נכנסות עם הצ עת SDP, הטלפון עוקב אחר סוג המטען הדינמי שהוקצה למתקשר.
טלפון ה- IP של סיסקו משתמש בשמות ה- codec שהוגדרו ב- SDP יוצא. עבור SDP נכנס עם סוגי מטען סטנדרטיים של 0-95, הטלפון מתעלם משמות ה- codec. עבור סוגי מטען דינמי, הטלפון מזהה את ה- codec לפי שמות ה- codec שהוגדרו. הה שוואה רגישה לאותיות רישיות, לכן עליך להגדיר את השם כראוי.
הטבלה הבאה מתארת את הפרמטרים של SIP הזמינים בס עיף סוגי מטען SDP.
|
פרמטר |
תיאור |
|---|---|
|
שם קודק G711u |
שם קודק G711u המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: PCMU |
|
שם קודק G711a |
שם קודק G711a המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: PCMA |
|
שם קודק G729a |
שם קודק G729a המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: G729a |
|
שם קודק G722 |
שם קודק G722 המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: G722 |
|
שם קודק G722.2 |
שם קודק G722.2 המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: AMR-WB |
|
שם קודק iLBC |
שם קודק iLBC המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: iLBC |
|
שם קודק iSac |
שם קודק iSac המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: iSac |
|
שם קודק OPUS |
שם קודק OPUS המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: OPUS |
|
שם קודק AVT |
שם קודק AVT המשמש ב- SDP. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ברירת מחדל: אירוע טלפוני |
|
G722.2 מטען דינמי |
סוג מטען דינמי G722. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 96 |
|
G722.2 OA מטען דינמי |
G722.2 OA סוג מטען דינמי. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 103 |
|
מטען דינמי של iLBC 20ms |
סוג מטען דינמי של iLBC 20ms. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 97 |
|
מטען דינמי של iLBC 30ms |
סוג מטען דינמי של iLBC 20ms. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 105 |
|
מטען דינמי של iSAC |
סוג מטען דינמי של iSAC. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 98 |
|
עומס דינמי של OPUS |
סוג מטען דינמי OPUS. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 99 |
|
מטען דינמי של RSFEC |
סוג מטען דינמי RSFEC. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 113 |
|
מטען דינמי של AVT |
סוג מטען דינמי של AVT. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 101 |
|
מטען דינמי של AVT 16 קילוהרץ |
סוג מטען דינמי AVT עבור קצב השעון של 16 קילוהרץ. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 101 |
|
מטען דינמי של AVT 48 קילוהרץ |
סוג מטען דינמי AVT עבור קצב השעון של 48 קילוהרץ. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 101 |
|
מטען דינמי של INFOREQ |
סוג מטען דינמי של INFOREQ. כדי להגדיר את ההגדרה, בצע אחת מהפעולות הבאות:
ערכים מותרים: 96-127 ברירת מחדל: 101 |
פרמטרי תמיכה של NAT
לפרמטרים הקשורים לתמיכה ב- NAT, ראה מעבר NAT עם טלפונים.
קביעת תצורה של הגדרות SIP עבור הרחבה
בעזרת הגדרות SIP לכל שורה, באפשרותך להגדיר כיצד הטלפון מטפל באיתות SIP, רישום ומדיה עבור סיומת בודדת.
| 1 |
גש לדף האינטרנט של ניהול הטלפון. |
| 2 |
בחר . |
| 3 |
בקטע הגדרות SIP, הגדר את הפרמטרים כמתו אר בפר מטרים להגדרות SIP של הרחבה |
| 4 |
לחץ על שלח את כל השינויים. |
פרמטרים להגדרות SIP של הרחבה
הטבלה הבאה מגדירה את הפונקציה והשימוש בפרמטרים בקטע הגדרות SIP תחת הכרטיסייה בממשק האינטרנט של הטלפון. זה גם מגדיר את התחביר של המחרוזת שנוספה בקובץ תצורת הטלפון עם קוד XML (cfg.xml) כדי להגדיר פרמטר.
|
פרמטר |
תיאור |
|---|---|
|
תחבורה SIP |
מציין את פרוטוקול ההובלה עבור הודעות SIP. כאשר מוגדר ל- AUTO, הטלפון בוחר את הפרו טוקול המתאים באופן אוטומטי, בהתבסס על רשומות NAPTR בשרת ה- DNS. בצע אחת מהפעולות הבאות:
ערכים מותרים: UDP | TCP | TLS | אוטומטי ברירת מחדל: UDP |
|
יציאת SIP |
מספר היציאה של הטלפון להאזנה והעברה של הודעות SIP. ציין כאן את מספר היציאה רק כאשר אתה משתמש ב- UDP כ פרוטוקול ההובלה SIP. אם אתה משתמש ב- TCP, המערכת משתמשת ביציאה אקראית בטווח שצוין ב- SIP TCP Port Min ו- בכרטיסייה קול > SIP. אם עליך לציין יציאה של שרת proxy SIP, באפשרותך לציין אותה באמצעות שדה Proxy או בשדה שרת מארח XSI. בצע אחת מהפעולות הבאות:
ברירת מחדל: 5060 |
|
הפעלת SIP 100REL |
מאפשר בנפרד את תכונת SIP 100REL. כאשר מופעל, הטלפון תומך בתוסף SIP 100REL להעברה אמינה של תגובות זמניות (18x) ומשתמש בבקשות PR ACK. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
יציאת SIP EXT |
מספר יציאת ה- SIP החיצונית. בצע אחת מהפעולות הבאות:
ערכים מותרים: ברירת מחדל: 5060 |
|
אישור סינכרון מחדש |
טלפון ה- IP של סיסקו מאמת את השולח כאשר הוא מקבל הודעת NOTIFY עם הבקשות הבאות:
בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: כן |
|
דרוש פרוקסי SIP |
ה- proxy של SIP יכול לתמוך בהרחבה או בהתנהגות ספציפית כאשר הוא מקבל את הכותרת Proxy-Request מסוכן המשתמש. אם שדה זה מוגדר ו- proxy אינו תומך בו, הוא מגיב עם ההודעה, לא נתמך. בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
|
מזהה צד מרוחק SIP |
הכותרת של מזהה צד מרוחק לשימוש במקום הכותרת From. בחר כן כדי להפעיל. ברירת מחדל: כן |
|
מפנה ביי דיי דיי |
שולט מתי הטלפון שולח BYE כדי לסיים רגלי שיחה מעופשות עם השלמת העברת השיחות. הגדרות עיכוב מרובות (הפניה, יעד הפניה, השופט וי עד הפניה) מוגדרות במסך זה. בצע אחת מהפעולות הבאות:
ערכים מותרים: מספר שלם מ- 0 עד 65535 ברירת מחדל: 4 |
|
איש קשר הפניה ליעד |
מציין את יעד ההפניה. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
שופט ביי דיי |
מציין את זמן ההשהיה של השופט ביי בשניות. בצע אחת מהפעולות הבאות:
ערכים מותרים: מספר שלם מ- 0 עד 65535 ברירת מחדל: 0 |
|
עיין בעיכוב ביי היעד |
מציין את זמן ההשהיה ביי של יעד הפניה בשניות. בצע אחת מהפעולות הבאות:
ערכים מותרים: מספר שלם מ- 0 עד 65535 ברירת מחדל: 0 |
|
דביק 183 |
שולט בתגובת ה- SIP 183 הראשונה עבור INVITE יוצאת. כדי להפעיל תכונה זו, בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
אישור הזמנה |
שולט אם נדרשת הרשאה לבקשות IN VITE נכנסות ראשוניות מ-SIP proxy. כדי להפעיל תכונה זו. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
עיין ב- Ntfy ב- 1xX ל- INV |
אם מוגדר כ כן, כמקבל העברה, הטלפון ישלח NOTIFY with Event:פ נה למעביר עבור כל תגובה 1xx שהוחזרה על ידי יעד ההעברה, ברגל שיחת ההעברה. אם מוגדר כלא, הטלפון ישלח רק NOTIFY לת גובות סופיות (200 ומעלה). בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: כן |
|
סט G729 נספח |
הגדר את הגדרות G.729 נספח B. בצע אחת מהפעולות הבאות:
ערכים מותרים: אין | לא | כן | עקוב אחר הגדרת תמיכה בשקט ברירת מחדל: כן |
|
השתמש ברוחב פס נמוך OPUS |
כדי לשפר את רוחב הפס ברשת שלך, תוכל להגדיר את הטלפונים שלך לשימוש בקודק OPUS הצר. קודק הפס הצר לא יתנגש עם קודק הפס הרחב. בצע אחת מהפעולות הבאות:
ערכים מותרים: לא | כן ברירת מחדל: לא |
|
כתובת דוח איכות קול |
מציין את היעד שבו הטלפון שולח דוחות אבחון לגבי איכות השיחה. ניתן להכניס שם תחום או כתובת IP. ניתן גם להוסיף מספר יציאה יחד עם שם התחום או כתובת IP עבור פרמטר זה. אם אינך מזן מספר יציאה, הערך של יציאת SIP UDP (5060) משמש כברירת מחדל. אם הפרמטר URL של שרת האספן ריק, הודעת SIP PUBLISH לא נשלחת. בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
|
מרווח דוח איכות קול |
מציין באיזו תדירות הטלפון יוצר ושולח דוחות איכות קול לכתובת הדוח שהו גדרה. המרווח נמדד בדקות. מרווחים קצרים יותר מספקים עדכונים תכופים יותר לניטור אך עשויים להגדיל את תעבורת הדיווח, בעוד מרווחים ארוכים יותר מפחיתים את התקורה אך מספקים פחות פירוט. מרווח ברירת המחדל הוא 0, כלומר לא יישלחו דוחות תקופתיים. בצע אחת מהפעולות הבאות:
ברירת מחדל: 0 |
| קבוצת דוחות איכות קול |
מגדיר את מזהה הקבוצה המשמש בעת שליחת דוחות איכות קול מ הטלפון. פרמטר זה מאפשר לארגן מספר טלפונים תחת אותה קבוצת ד יווח, כך שמנהלי מערכת יוכלו למיין, לסנן ולנתח בקלות נתוני איכות השיחה. בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
|
טלפון שווה למשתמש |
כאשר כתובת URL של טלפון מומרת לכתובת URL של SIP ומ ספר הטלפון מיוצג על ידי חלק המשתמש של כתובת האתר, כתובת ה- SIP כוללת את הפרמטר האופ ציונלי: user=phone (RFC3261). לדוגמה: אל: לגימה: + 12325551234@example.com; משתמש = טלפון בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
כותרת פרטיות |
הגדרת פרטיות המשתמש בהודעת SIP ברשת המהימנה. אפשרויות כותרת הפרטיות הן:
בצע אחת מהפעולות הבאות:
ערכים מותרים: מושבת | אין | כותרת | הפעלה | משתמש | מזהה ברירת מחדל: מושבת |
|
תמיכה במדיה מוקדמת של P-P |
שולט אם כותרת P-Early-Media כלולה בהודעת SIP לשיחה יוצאת. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
תמיכה ב- מזהה הפעלה SIP |
מאפשר שימוש בכותרת מזהה הפעלת SIP (המוגדרת ב- RFC 7989) כדי לזהות באופן ייחודי הפעלת תקשורת מקצה לקצה. מזהה הפגישה נשאר זהה בכל רגלי השיחה, גם אם השיחה מועברת, מועברת או עוברת דרך מתווכים SIP מרובים. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: כן |
|
בקשת מדיה-סאק |
מציין אם הטלפון מבקש להשתמש בא בטחת מדיה (MediaSEC) במהלך הגדרת שי חת SIP. כאשר מופעל, הטלפון כולל בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
MediaSec דרך TLS בלבד |
שולט אם הטלפון משתמש באבטחת מדיה (MediaSec, RFC 3329) רק כאשר איתות ה- SIP מוגן באמצעות TLS. כאשר מופעל, הטלפון כולל MediaSec ( בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
תמיכה בתנאי מוקדם |
קובע אם הטלפון כולל את תג התנאי המוקדם (המוגדר ב- RFC 3312) בשדה כותרת נתמכת.
בצע אחת מהפעולות הבאות:
ערכים מותרים: מושבת | מופעל ברירת מחדל: מושבת |
|
תמיכה באישור RFC8760 |
מאפשר תמיכה עבור ערכת האימות המוגדרת ב- RFC 8760 — אימות תקציר עבור SIP (SHA-256/512). תקן זה מרחיב את אימות ה- SIP לשימוש בפונקציות hash חזקות ומאובטחות יותר בהשוואה לעיכול המבוסס על MD5 הישן יותר (RFC 2617). כאשר מופעל, הטלפון תומך באימות תקציר SHA-256/SHA-512 כאשר מאתגר על ידי שרת SIP. כאשר הוא מושבת, הטלפון תומך רק באימות מדור MD5 מדור קודם (RFC 2617). בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
מעבר NAT עם טלפונים
תרגום כתובות רשת (NAT) מאפשר למכשירים מרובים לשתף כתובת IP אחת, ציבור ית וניתנת לניתוב כדי ליצור חיבורים דרך האינטרנט. NAT קיים במכשירי גישה בפ ס רחב רבים לתרגום כתובות IP ציבוריות ופרטיות. כדי ש- VoIP יתקיים יחד עם NAT, נדרש מעבר NAT.
לא כל ספקי השירות מספקים מעבר NAT. אם ספק השירות שלך אינו מספק מעבר NAT, עומדות בפניך מספר אפשרויות:
-
מיפוי NAT עם בקר גבו ל הפעלה: מומלץ לבחור ספק שירות התומך במיפוי NAT באמצעות בקר גבול הפעלה. עם מיפוי NAT המסופק על ידי ספק השירות, יש לך אפשרויות נוספות בבחירת נתב.
-
מיפוי NAT עם נתב SIP-ALG: ניתן להשיג מיפוי NAT באמצעות נתב שיש לו שער שכבת יישום SIP (ALG). על ידי שימוש בנתב SIP-ALG, יש לך אפשרויות נוספות בבחירת ספק שירות.
-
מיפוי NAT עם כתובת IP סטטית: ניתן להשיג מיפוי NAT עם כתובת IP סטטית חיצונית (ציבורית) כדי להבטיח יכולת פעולה הדדית עם ספק השירות. מנגנון NAT המשמש בנתב חייב להיות סימטרי. לקבלת מידע נוסף, ראה ק ביעת NAT סימטרי או אסימטרי.
השתמש במיפוי NAT רק אם רשת ספק השירות אינה מספקת פונקציונליות של בקר גבול הפעלה. לקבלת מידע נוסף אודות אופן התצורה של מיפוי NAT עם כתובת IP סטטית, ראה קביעת תצורה של מיפוי NAT עם כתובת ה- IP הסטטית.
-
מיפוי NAT עם STUN: אם רשת ספק השירות אינה מספקת פונקציונליות של בקר גבול הפעלה ואם הדרישות האחרות מתקיימות, ניתן להשתמש בכלי עזר מעבר הפעלה עבור NAT (STUN) כדי לגלות את מיפוי NAT. לקבלת מידע על אופן התצורה של מיפוי NAT באמצעות STUN, ראה קביעת תצורה של מיפוי NAT עם ST UN.
הגדר מיפוי NAT עם כתובת ה- IP הסטטית
הגדר את מיפוי NAT בטלפון שלך כדי להבטיח יכולת פעולה הדדית עם ספק השירות.
לפני שתתחיל
-
עליך להיות בעל כתובת IP חיצונית (ציבורית) שהיא סטטית.
-
מנגנון NAT המשמש בנתב חייב להיות סימטרי.
| 1 |
גש לדף האינטרנט של ניהול הטלפון. |
| 2 |
בחר . |
| 3 |
במקטע פרמטרים של תמיכה ב- NAT, הגדר את הפרמטרים כמתואר בפרמטרים למיפוי NAT עבור כתובת IP סטטית. |
| 4 |
עבור אל , היכן nנמצא אינדקס ההרחבה. |
| 5 |
בקטע הגדרות NAT, הגדר את הפרמטרים כ מתואר בפר מטרים למיפוי NAT בתוספים. |
| 6 |
לחץ על שלח את כל השינויים. |
מה לעשות הלאה
הגדר את הגדרות חומת האש בנתב שלך כדי לאפשר תעבורת SIP.
הגדר מיפוי NAT באמצעות STUN
אם רשת ספק השירות אינה מספקת בקר גבול הפעלה (SBC) והדרישות האחרות מתקיימות, ניתן להשתמש בכלי עזר מעבר הפעלה עבור NAT (STUN) כדי לגלות את מיפוי NAT.
STUN מאפשר ליישומים הפועלים מאחורי NAT:
- לזהות את הנוכחות של NAT בנתיב התקשורת.
- השג את כתובת ה- IP הציבורית (ממופה) ואת מספר היציאה ש- NAT מקצה לחיבורי UDP למארחים מרוחקים.
הפרוטוקול דורש שרת STUN של צד שלישי הממוקם בצד הציבורי של ה- NAT, בדרך כלל האינטרנט. על ידי החלפת הודעות עם שרת זה, הלקוח לומד כיצד ה- NAT מתרגם את כתובת ה- IP הפרטית שלו ואת היציאות.
STUN נחשב למנגנון חזרה ויש להשתמש בו רק כאשר שיטות חציית NAT אחרות אינן זמינות.
לפני שתתחיל
-
הנתב חייב להשתמש ב- NAT אסימטרי. ראה ק ביעת NAT סימטרי או אסימטרי.
-
מחשב שמריץ תוכנת שרת STUN חייב להיות זמין. אתה יכול להשתמש בשרת STUN ציבורי או להגדיר שרת STUN משלך.
| 1 |
גש לדף האינטרנט של ניהול הטלפון. |
| 2 |
בחר . |
| 3 |
בסעיף פרמטרי תמיכה של NAT, הגדר את הפרמטרים כמתואר בטבלה של פרמטרים למיפוי NAT עם כתובת IP סטטית. |
| 4 |
הגדר את הפרמטרים כמתואר בטבלה של פרמטרים למיפוי NAT עם STUN. |
| 5 |
לחץ על הכר טיסייה Ext (n). |
| 6 |
בקטע הגדרות NAT, הגדר את הפרמטרים עבור התו סף הספציפי כמתואר בטבלה של פרמטרים למיפוי NAT בתוספים. |
| 7 |
לחץ על שלח את כל השינויים. |
מה לעשות הלאה
הגדר את הגדרות חומת האש בנתב שלך כדי לאפשר תעבורת SIP.
קבע NAT סימטרי או אסימטרי
STUN אינו פועל על נתבים עם NAT סימטרי. עם NAT סימטרי, כתובות IP ממופות מכתובת IP פנימית אחת ויציאה לכתובת IP ויציאה חיצונית וניתנת לניתוב אחת. אם מנה אחרת נשלחת מאותה כתובת IP ויציאה מקור ליעד אחר, נעשה שימוש בשילוב כתובת IP ומספר יציאה שונה. שיטה זו מגבילה מכיוון שמארח חיצוני יכול לשלוח מנה ליציאה מסוימת במארח הפנימי רק אם המארח הפנימי שלח לראשונה מנה מאותה יציאה למארח החיצ וני.
הליך זה מניח כי שרת syslog מוגדר ומוכן לקבל הודעות syslog .
לפני שתתחיל
ודא שחומת האש אינה פועלת במחשב האישי שלך. (זה יכול לחסום את יציאת syslog.) כ ברירת מחדל, יציאת syslog היא 514.
| 1 |
גש לדף האינטרנט של ניהול הטלפון. |
| 2 |
בחר וט למקט ע תצורת רשת אופציונ לית. |
| 3 |
הזן את כתובת ה- IP של שרת Syslog, אם מספר היציאה הוא משהו אחר מאשר ברירת המחדל, 514. אם נעשה שימוש ביציאת ברירת המחדל, אין צורך לכלול את מספר היציאה. הכתובת ומספר היציאה חייבים להיות נגישים מטלפון ה- IP של סיסקו. מספר היציאה
מופיע בשם קובץ יומן הפלט. אם מספר היציאה לא צוין, שם
קובץ הפלט המוגדר כברירת מחדל הוא |
| 4 |
הגדר את רמת ניפוי באגים לשגי אה, הודעה או ניפוי באגים. |
| 5 |
כדי ללכוד הודעות איתות SIP, לחץ על הכרטיסייה Ext (n) ונווט אל הגדרות SIP. הגדר את אפשרות ניפוי באגים של SIP למ לאה. |
| 6 |
כדי לאסוף מידע אודות סוג NAT שבו משתמש הנתב שלך, לחץ על הכרטיסייה וט אל פרמטרי תמיכה ב- NAT. |
| 7 |
הגדר את הפעלת בדיקת STUN ל - כן. |
| 8 |
קבע את סוג NAT על-ידי הצגת הודעות ניפוי באגים בקובץ היומן. אם ה הודעות מציינות שההתקן משתמש ב- NAT סימטרי, אינך יכול להשתמש ב- STUN. |
| 9 |
לחץ על שלח את כל השינויים. |
פרמטרים למיפוי NAT
פרמטרים למיפוי NAT עם כתובת IP סטטית
הטבלה הבאה מגדירה את הפונקציה והשימוש במיפוי NAT עם פרמטרי IP סט טיים בקטע פרמטרי תמיכה של NAT תחת הכרטיסייה בממשק האינטרנט של הטלפון. זה גם מגדיר את התחביר של המחרוזת שנוספה בקובץ תצורת הטלפון עם קוד XML (cfg.xml) כדי להגדיר פרמטר.
| פרמטר | תיאור |
|---|---|
|
טיפול VIA שהתקבל |
מאפשר או משבית את הטלפון כדי לעבד את הפרמטר שהתקבל ב כותרת VIA. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
טפל בנמל VIA |
מאפשר או משבית את הטלפון כדי לעבד את בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
הכנס VIA שהתקבל |
מאפשר או משבית את הטלפון כדי להכניס את בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
הכנס רפורט VIA |
מאפשר או משבית את הטלפון כדי להוסיף את בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
תחליף דרך אדר |
מאפשר למשתמש להשתמש בערכי IP: יציאה במיפוי NAT בכותרת VIA. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
שלח Resp לנמל Src |
מאפשר לשלוח תגובות ליציאת מקור הבקשה במקום ליציאת VIA שנשלחה על ידי . בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
EXT IP |
כתובת IP חיצונית שתחליף את כתובת ה- IP בפועל של הטלפון בכל הודעות ה- SIP ה יוצאות. אם צוין 0.0.0.0, לא תבו צע החלפת כתובת IP. אם פרמטר זה צוין, הטלפון מקבל כתובת IP זו בעת יצירת הודעות SIP ו- SDP (אם מיפוי NAT מופעל עבור קו זה). בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
|
יציאת RTP מינימלית של EXT |
מספר היציאה ההתחלתי (המינימלי) במיפוי NAT החיצוני שהטלפון אמור להשתמש בו לתעבורת RTP. בצע אחת מהפעולות הבאות:
ברירת מחדל: 0 |
|
מידע של NAT שמור בחיים |
מרווח בין מיפוי NAT שומר על הודעות בחיים. בצע אחת מהפעולות הבאות:
ערכים מותרים: טווחים מספריים בין 0 ל 65535 ברירת מחדל: 15 |
|
הפניה מחדש שמור בחיים |
הפעל או השבת את הטלפון כדי לשלוח הודעות Keep-Alive לשרת המנותב כדי לשמור על קישוריות כאשר מתרחשת בעיה. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
פרמטרים למיפוי NAT בתוספים
הטבלה הבאה מגדירה את הפונקציה והשימוש במיפוי NAT עם פרמטרי IP סטטיים בקטע פרמטרי תמיכה של NAT תחת הכרטיסייה Voice> Ext בממשק האינטרנט של הטלפון. זה גם מגדיר את התחביר של המחרוזת שנוספה בקובץ תצורת הטלפון עם קוד XML (cfg.xml) כדי להגדיר פרמטר.
| פרמטר | תיאור |
|---|---|
|
הפעלת מיפוי NAT |
שולט בשימוש בכתובות IP ממופות חיצונית וביציאות SIP/ RTP בהודעות SIP. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
|
הפעלה של NAT שמור בחיים (אופציונלי) |
מאפשר או משבית את הטלפון לשלוח הודעות NAT keep alive מעת לעת כדי לשמור על חיבור ה- SIP של הטלפון חי באמצעות NAT. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן | לא ברירת מחדל: לא |
פרמטרים למיפוי NAT עם STUN
הטבלה הבאה מגדירה את הפונקציה והשימוש במיפוי NAT עם פרמטרי STUN בקט ע פר מטרי תמיכה של NAT תחת הכרטיסייה בממשק האינטרנט של הטלפון. זה גם מגדיר את התחביר של המחרוזת שנוספה בקובץ תצורת הטלפון עם קוד XML (cfg.xml) כדי להגדיר פרמטר.
|
פרמטר |
תיאור |
|---|---|
|
הפעלת STUN |
מאפשר שימוש ב- STUN כדי לגלות מיפוי NAT. בצע אחת מהפעולות הבאות:
ערכים מותרים: כן ולא. ברירת מחדל: לא |
|
שרת STUN |
כתובת IP או שם תחום מוסמך מלא של שרת STUN ליצירת קשר לצורך גילוי מיפוי NAT. אתה יכול להשתמש בשרת STUN ציבורי או להגדיר שרת STUN משלך. בצע אחת מהפעולות הבאות:
ברירת מחדל: ריק |
התנהגויות SIP ו- RTP במצב כפול
באפשרותך לשלוט בפרמטרים של SIP ו- RTP באמצעות שדות העדפת IP SIP ו- SDP IP העדפה כאשר הטלפון נמצא במצב כפול.
פרמטר העדפת IP SIP מגדיר איזו כתובת IP הטלפון מנסה תחילה כאשר הוא במצב כפול.
|
מצב IP |
העדפת IP של SIP |
רשימת כתובות מ- DNS, עדיפות, תוצאה P1 - כתובת בעדיפות ראשונה P2 - כתובת בעדיפות שנייה |
רצף גיבוי לכישלון |
|---|---|---|---|
|
מצב כפול |
IPv4 |
P1- 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 תוצאה: הטלפון ישלח תחילה את הודעות ה- SIP ל- 1.1.1.1. |
1.1.1.1 ->2009:1:1:1:1 -> 2.2.2.2 -> 2009:2:2:2:2 |
|
מצב כפול |
IPv6 |
P1- 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 תוצאה: הטלפון ישלח את הודעות ה- SIP ל- 2009:1:1:1: :1 תחילה. |
2009:1:1:1:1 -> 1.1.1.1 -> 2009:2:2:2:2 -> 2.2.2.2 |
|
מצב כפול |
IPv4 |
P1- 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 תוצאה: הטלפון ישלח את הודעות ה- SIP ל- 2009:1:1:1: :1 תחילה. |
2009:1:1:1:1 -> 2.2.2.2 -> 2009:2:2:2:2 |
|
מצב כפול |
IPv6 |
P1- 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 תוצאה: הטלפון ישלח תחילה את הודעות ה- SIP ל- 1.1.1.1. |
2009:1:1:1:1 -> 2009:2:2:2:2 ->2.2.2.2 |
|
IPv4 בלבד |
IPv4 או IPv6 |
P1 - 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 תוצאה: הטלפון ישלח תחילה את הודעות ה- SIP ל- 1.1.1.1. |
1.1.1.1 -> 2.2.2.2 |
|
IPv6 בלבד |
IPv4 או IPv6 |
P1 - 1.1.1.1, 2009:1:1:1::1 P2 - 2.2.2.2, 2009:2:2:2::2 תוצאה: הטלפון ישלח את הודעות ה- SIP ל- 2009:1:1:1: :1 תחילה. |
2009:1:1:1:1 -> 2009:2:2:2::2 |
הגדר הגדרות אמינות ואיכות מדיה
Media Associated Resource Information (MARI) הוא מנגנון איתות ודיווח - המ שמש לעתים קרובות ברשתות מבוססות SIP ו- RTP - המאפשר לטלפונים ושרתי בקרת שיחות להחליף מידע באיכות מדיה על שיחה בזמן אמת או לאחר סיום השיחה. הפעל את MARI אם ברצונך לפקח או לרשום מדד איכות שיחה. כאשר מופעל, הטלפון שולח נתונים סטטי סטיים על זרם המדיה - כגון ריצוד, אובדן מנות, עיכוב, MOS (ציון חוות דעת ממוצע) וכו' - בחזרה למערכת הניטור
תיקון שגיאות קדימה (FEC) היא שיטה המשמשת לשחזור מנות RTP שאבדו בזמן אמת ללא שידור מחדש. זה עובד על ידי הוספת נתונים מיותרים לזרם המדיה, כך שאם מנה הולכת לאיבוד, המקלט יכול לשחזר אותו מהמידע המיותר. FEC משפר את איכות השיחה ברשתות אובדניות או לא יציבות. כאשר מופעל, הטלפון שולח ומקבל נתוני RTP מיותרים כדי להגן מפני אובדן מנות.
| 1 |
גש לדף האינטרנט של ניהול הטלפון. |
| 2 |
בחר . |
| 3 |
בקטע תצורת MARI, הגדר את MARI מופעל ו - FEC מופעל ל - Yes כדי לאפשר את התכונות. כברירת מחדל, תכונות אלה מושבתות. ניתן גם להגדיר את ההגדרות באמצעות קובץ תצורת הטלפון עם XML (cfg.xml) על ידי הזנת מחרוזות בפור מט זה:
|
| 4 |
לחץ על שלח את כל השינויים. |