Headset model

Minimum firmware version

Jabra headsets supported on Windows:

  • Jabra Link 380
  • Jabra Link 400
  • Jabra Engage 55
  • Jabra Engage 75
  • Jabra Evolve 30 II UC, 40 UC, 75 UC
  • Jabra Evolve2 65 UC
  • Jabra Evolve2 30SE, 40SE
  • Jabra Evolve2 50, 55
  • Jabra Evolve2 65 Flex
  • Jabra Evolve2 75
  • Jabra Evolve2 Buds
  • Jabra Speak2 40, 55, 75

EPOS headsets supported on Windows, Mac, Linux, and VDI (supported thin client operating systems: Windows, Ubuntu, IGEL OS, Unicon eLux, HP ThinPro, Dell ThinOS):


 

To use EPOS headsets with Webex App for Linux, RedHat users must Download the latest webex.rpm version of Webex App. Then, uninstall the previous version and use administrator privileges (sudo command) to reinstall the new version of the app.

  • EPOS ADAPT 130 USB II
  • EPOS ADAPT 130-C USB II
  • EPOS ADAPT 135 USB II
  • EPOS ADAPT 135-C USB II
  • EPOS ADAPT 160 USB II
  • EPOS ADAPT 160-C USB II
  • EPOS ADAPT 165 USB II
  • EPOS ADAPT 165-C USB II

8.41.24.0

  • EPOS ADAPT 230
  • EPOS ADAPT 231
  • EPOS ADAPT 260
  • EPOS ADAPT 261

1.4.4

EPOS ADAPT 660

1.6.2

EPOS Expand 80

4.6.129

EPOS Expand 80 MIC

1.1.255

  • EPOS IMPACT MB Pro 1 UC ML
  • EPOS IMPACT MB Pro 2 UC ML

2.5.9

  • EPOS IMPACT SC 630 USB ML
  • EPOS IMPACT SC 635 USB
  • EPOS IMPACT SC 635 USB-C
  • EPOS IMPACT SC 660 USB ML
  • EPOS IMPACT SC 665 USB
  • EPOS IMPACT SC 665 USB-C

15.05.83.83

Poly headsets supported on Windows:

Poly Blackwire 5210

213

Poly Blackwire 5220

213

Poly Savi 7310

1026

Poly Savi 7320

1026

Poly Savi 8220

3888

Poly Voyager 5200

510

Poly Voyager 8200

700

Poly Voyager Focus

612

Poly Voyager Focus 2

610

Poly BT 600

2120

Poly BT 700

315