Quels sont les codes d'erreur SAML ?
Langage de balisage des assertions de sécurité
Quels sont les codes d'erreur SAML ?
Où puis-je trouver la liste des numéros d'erreur liés à l'authentification unique SAML ?
Liste des codes d'erreur SSO
Solution :
Consultez le tableau ci-dessous pour connaître les erreurs courantes du langage SAML (Security Assertion Markup Language) :
| Code d'erreur | Description du symptôme | Cause possible | Résolution suggérée |
| 1 | Erreur liée au protocole SSO | Il s'agit d'une exception SSO générale, certaines exceptions d'exécution sont associées à ce code d'erreur | Renseignez-vous auprès du support technique de Webex |
| 4 | Aucun certificat X.509 n'a été trouvé dans le système | L'administrateur Webex n'a pas configuré le certificat | Consultez l'outil d'administration Webex pour la « Gestion des certificats de l'organisation » et configurez le certificat |
| 5 | Seule la demande POST est prise en charge | Lorsque le système IdP envoie une assertion à Webex Service, seule la méthode « post » est acceptée | Vérifiez la trace. Si c'est la méthode « get », mettez à jour la configuration de l'IdP |
| 7 | L'organisation n'est pas autorisée à utiliser le SSO | Le service Webex n'est pas activé par le SSO, ou le protocole configuré n'est pas correct | Contactez le support technique de Webex pour vérifier si le SSO est activé et/ou pour vérifier si le protocole est correct dans l'outil d'administration |
| 8 | Certificat X.509 incorrect pour valider l'assertion SAML | L'administrateur du service Webex a configuré le certificat de l'organisation, mais il ne correspond pas à celui du système IdP | Reportez-vous à la section « Configuration du système d'identification client » pour voir le mappage de certification entre le système d'administration de l'organisation et le système IdP |
| 13 | Assertion SAML non valide | Le certificat est correct, mais la vérification des assertions échoue | Vérifiez la chaîne d'assertion, si elle est complète. Effectuez une trace et validez les champs d'assertion |
| 15 | Le certificat X.509 a expiré | Le certificat X.509 a expiré | Consultez l'outil d'administration « Gestion des certificats de l'organisation » et mettez à jour le certificat |
| 19 | L'assertion SAML a expiré | L'assertion SAML est expirée. Normalement, c'est dû à un décalage horaire entre l'IdP et le service Webex | Contacter le support technique de Webex |
| 23 | Signature numérique non valide | La signature numérique de l'assertion n'est pas correcte | Faites une trace et vérifiez l'assertion. La signature numérique est manquante ou non valide |
| 24 | Émetteur non fiable | L'identifiant de l'émetteur ne correspond pas entre le système IdP et le service Webex | Comparez l'identifiant de l'émetteur entre deux systèmes |
| 25 | Le format de l'identifiant du nom est incorrect | Le format de l'identifiant ne correspond pas entre le système IdP et le service Webex | Comparez le format d'identification nominative entre deux systèmes |
| 26 | Impossible de générer AuthnRequest | L'outil d'administration Webex a vérifié l'AuthnRequest, mais n'a pas réussi à le générer | Normalement, c'est un problème de certificat Webex, consultez l'administrateur de l'organisation « Webex Certificate Management » |
| 28 | InResponseTo ne correspond pas au numéro de demande | L'assertion « InResponseTo » ne correspond pas à la demande, normalement pour les raisons suivantes : 1. l'assertion est réutilisée, ou la page a été vidée, l'assertion a été envoyée à nouveau 2. la demande a été envoyée depuis le serveur CAS 1, mais la réponse est renvoyée au serveur CAS 2. et ils ne partagent pas la base de données | 1. L'assertion ne peut pas être réutilisée. 2. Vérifiez le système IdP. Si l' « URL du service client d'assertion » est incorrecte, pointez du doigt le mauvais serveur Webex |
| 29 | Message de réponse non valide | 1. Le tag est absent de l'Assertion 2. Le tag n'est pas le premier enfant de Response ou Assertion 3. L'assertion n'est pas codée en base64 lorsqu'elle est envoyée à Webex. 4. Le nom de la réponse POST n'est pas SamlResponse (les majuscules doivent correspondre). 5. Vérifiez que AuthnContextStyleRef correspond. Vérifiez caractère par caractère. Parfois, un « : » manquant est à l'origine du problème. | Vérifiez l'assertion et confirmez qu'aucune des causes possibles n'existe. Si le problème persiste une fois qu'ils ont été confirmés/corrigés, contactez le support technique de Webex. |
| 31 | La création automatique du compte a échoué | Impossible de trouver l'utilisateur dans Webex Service par son identifiant dans l'assertion | 1. L'utilisateur existe, mais le « nom de famille » indiqué dans l'assertion est incorrect. Impossible de le créer automatiquement à cause d'un conflit d'adresses électroniques. 2. L'utilisateur n'existe pas, mais les attributs obligatoires sont absents : (prénom, nom de famille, e-mail) |
| 32 | La mise à jour automatique du compte a échoué | Tout ce qui cause l'erreur 31 peut également entraîner l'erreur 32 lors de la mise à jour des comptes. L'assertion contient une valeur d'attribut qui n'est pas prise en charge par le site ou qui n'est pas correctement formatée. (Exemple : le type de réunion (MT) envoyé dans l'assertion n'est pas disponible sur le site Webex.) | Passez en revue les attributs envoyés dans l'assertion et comparez-les avec les options disponibles/requises sur le site Webex, corrigez-les si nécessaire. |
Pour plus de codes d'erreur SAML, voir :
Codes d'erreur SSO
Pour obtenir de l'aide concernant le téléchargement d'un certificat X.509, consultez :
Cet article était-il utile ?