webex-logowebex-logoHelp Center
  • Ctrl K
    • Get started
    • Help by product
    • Administration
    • What's new
    • Support

      Join a meeting
      Developer ToolsDeveloper Tools
      Webex AdoptionWebex Adoption
      Contact Support

      learn

      Video resources
      Webex AcademyWebex Academy
      Live Events and WebinarsLive Events and Webinars
      Webex BlogWebex Blog

      programs

      Webex CommunityWebex Community
      Webex InsiderWebex Insider
      App HubApp Hub
      Cisco AI Assistant

      Cisco AI Assistant

      The most advanced generative AI-powered platform for hybrid work and customer experience.

      Learn more →
      webexDownload Webex
      +1-888-469-3239Contact Sales →
    • Ctrl K
      • Dansk
      • Deutsch
      • English language tick
      • Español
      • Français
      • Italiano
      • Nederlands
      • Português
      • Pyccĸий
      • Svenska
      • Tϋrkçe
      • 한국어
      • 日本語
      • 简体中文
      • 繁體中文
      • Română
      • Magyar
      • Polski
      • Čeština
      • Български
      • Norsk
      • Hrvatski
      • Srpski
      • Українська
      • العربية
      • עברית
      • Suomi
      • Slovenščina
      • Slovenský
    • Home
    • /
    • Article
    Was this article helpful?
    close

    Thanks for your feedback.

    June 25, 2024 | 3118 view(s) | 9 people thought this was helpful
    Error: 'URL is Invalid.' when Playing a Recording
    list-menuFeedback?


    ISSUE
    Users may encounter the error message 'The URL is invalid. Please contact the publisher or your Site Administrator.' when trying to play a recording.

    RESOLUTION

    To correct the 'The URL is invalid' error, you should ensure that your computer's date, time, and time zone are set correctly by following these steps:

    Windows 10

    1. Right-click on the time displayed in the lower-right corner of your screen.
    2. Select Adjust date/time to open the Date & Time settings window.
    3. You can opt to have Windows set the time and time zone automatically by toggling Set time and Set time zones automatically.
    4.  Please just turn the automatic options off if you prefer to set these manually.
    5. To manually set the time, click Change under Set the date and time and enter the correct information.
    6. To manually set the time zone, select the correct time zone from the drop-down menu under Time Zone.
    7. Close the settings window once the correct settings are applied.
    After making sure the date, time, and time zone settings are accurate, please try to access the content or perform the action again. The error message should no longer appear. If the issue persists, it may be unrelated to the system's time settings, and further investigation may be necessary, such as checking for network issues or contacting the site administrator for additional support.

    CAUSE
    This error is often triggered when the system's date, time, or time zone settings are inaccurately configured. Many applications and websites validate requests based on the client system's current time settings. If there is a significant discrepancy, it can lead to such URL validation errors.

    Was this article helpful?
    Was this article helpful?
    PricingWebex AppMeetingsCallingMessagingScreen Sharing
    Webex SuiteCallingMeetingsMessagingSlidoWebinarsEventsContact CenterCPaaSSecurityControl Hub
    HeadsetsCamerasDesk SeriesRoom SeriesBoard SeriesPhone SeriesAccessories
    EducationHealthcareGovernmentFinanceSports & EntertainmentFrontlineNonprofitsStartupsHybrid Work
    DownloadsJoin a Test MeetingOnline ClassesIntegrationsAccessibilityInclusivityLive & On-Demand WebinarsWebex CommunityWebex DevelopersNews & Innovations
    CiscoContact SupportContact SalesWebex BlogWebex Thought LeadershipWebex Merch StoreCareers
    • X
    • LinkedIn
    • Facebook
    • Youtube
    • Instagram
    Terms & ConditionsPrivacy StatementCookiesTrademarks
    ©2025 Cisco and/or its affiliates. All rights reserved.
    Terms & ConditionsPrivacy StatementCookiesTrademarks