Review these system requirements to verify that you can use Webex Teams on your computer, mobile device, or web browser.


Keep in mind that we don't support using Webex Teams with pre-release or early release programs, such as the Apple Beta Software, Windows Insider Program, Google Android Beta, or any other similar programs.

The performance of the Webex Teams app may also be influenced by other factors, for example: network connectivity or other applications on your devices.

  • Windows PCs Recommended Minimum System Requirements


    These requirements are continuously reviewed and may be revised.

  • Mac Recommended Minimum System Requirements


    These requirements are continuously reviewed and may be revised.

    • MacOS 10.12 and later on a supported Mac.

    • Intel CPI-based (2GB of RAM minimum recommended).

  • iPhone and iPad—iOS 11.0 and later, and iPadOS 13.1 and later

  • Android Smartphones—Nougat 7.0 and later (2GB of RAM required).

  • Web—Last two major releases of one of these browsers: Google Chrome, Mozilla Firefox, Apple Safari, and Microsoft Edge on computers running Windows, Mac, or Linux.


    You can only use the calling and meetings features from the Webex Teams for Web app using Firefox, Chrome, and Safari.

Review these system requirements to verify that you can use the Webex Calling app on your computer or mobile device.


Keep in mind that we don't support using the app with pre-release or early release programs, such as the Apple Beta Software, Windows Insider Program, Google Android Beta, or any other similar programs.

  • Windows PCs—Windows 7, 8 (classic), 8.1 (classic), and 10 (classic). Make sure your drivers are up-to-date.

  • Mac—MacOS 10.12, 10.13, and 10.14 on a supported Mac

  • iPhone and iPad—iOS 11.0 and later

  • Android Smartphones—Lollipop 5.0 and later

  • Chromebook—ARM-based Chomebooks capable of running Android apps

We recommend that you use the latest desktop version of Google Chrome, Microsoft Edge, or Mozilla Firefox to access Control Hub. Other browsers may produce unexpected results.


Control Hub doesn't support Internet Explorer.


Control Hub supports Microsoft Edge Version 79.0.309.71 (Official build) (64-bit) and later.

Control Hub is not designed for mobile devices.