خيارات DHCP على سلسلة اللوحة والمكتب والغرفة
خيارات DHCP هي المعلمات الإضافية التي يمكن لخادم DHCP توفيرها للعملاء إلى جانب تعيين عنوان IP. تنقل هذه الخيارات تفاصيل تكوين الشبكة المهمة بما يتجاوز عنوان IP فقط، مثل:
- عنوان العبّارة الافتراضية (جهاز التوجيه)
- عناوين خادم DNS
- قناع الشبكة الفرعية
- اسم النطاق
- خادم الوقت
- اسم ملف التمهيد لتشغيل الشبكة
- معايير التكوين الأخرى الخاصة بالبائع أو المخصصة
تتيح خيارات DHCP تكوين شبكة أكثر مرونة وشمولية للأجهزة العميلة، مما يسمح لها بتلقي جميع الإعدادات الضرورية تلقائيًا من خادم DHCP لتعمل بشكل صحيح على الشبكة.
راجع دليل DHCP للحصول على معلومات تفصيلية حول خيارات DHCP وتفاصيل التحقق من صحة الحقول.
تنسيق اسم المضيف الافتراضي لـ RoomOS:
SEP <MAC>- حيث <MAC>يمثل عنوان MAC الخاص بالجهاز.
معرف فئة خيار DHCP 60 الخاص بـ RoomOS:
سيسكو: الترميز: 1.0
قائمة طلبات المعلمات للخيار 55 لنظام التشغيل RoomOS DHCP
خيارات IPv4
| القيمة | الاسم | وصف |
|---|---|---|
| 1 | قناع الشبكة الفرعية | قناع الشبكة الفرعية للعميل. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 3 | الموجهات | يحدد قائمة عناوين IP لأجهزة التوجيه على الشبكة الفرعية للعميل. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 6 | خوادم أسماء النطاقات | يحدد قائمة DNS المتاحة للعميل. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 12 | اسم المضيف | اسم العميل. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 15 | اسم النطاق | اسم المجال الذي يجب أن يستخدمه العميل لتحليل اسم مضيف DNS. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 18 | مسار الامتدادات | يحدد سلسلة تحدد الملف المتاح للاسترجاع عبر TFTP. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 28 | عنوان البث | عنوان البث المستخدم على الشبكة الفرعية للعميل لتسليم حزم البث. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 42 | خوادم بروتوكول ntp | يحدد قائمة عناوين IP لخوادم بروتوكول وقت الشبكة (NTP) المتاحة للعميل لمزامنة الوقت. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 43 | خيارات مغلفة للبائع | خيارات البائع. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 66 | اسم خادم ttp | عنوان خادم TFTP عند استخدام حقل «sname» في رأس DHCP لنقل خيارات DHCP. يقوم هذا الخيار بتعريف خادم TFTP للعميل للاتصال به. راجع RFC 2132 للحصول على معلومات مفصلة. |
| 119 | البحث عن نطاق | يحدد خيار قائمة بحث المجال الذي يستخدمه العملاء لحل أسماء المضيفين عبر DNS. يسمح هذا الخيار للعميل بالبحث في نطاقات متعددة عند حل الأسماء. راجع RFC 3397 للحصول على معلومات مفصلة. |
| 120 | خوادم SIP المحلية | يحدد خيار DHCP المستخدم لتوفير عنوان خادم بروتوكول بدء الجلسة (SIP) للعملاء. يتيح هذا الخيار للأجهزة اكتشاف خوادم SIP ديناميكيًا عبر DHCP. راجع RFC 3361 للحصول على معلومات مفصلة. |
| 150 | سيسكو-tftp | يحدد خيار DHCP المستخدم لتوفير مصفوفة من عناوين خادم بروتوكول نقل الملفات المبسط (TFTP) للعملاء. يسمح هذا الخيار للأجهزة باكتشاف خوادم TFTP المتعددة ديناميكيًا عبر DHCP. راجع RFC 5859 للحصول على معلومات مفصلة . |
| 242 | خادم tms المحلي | يحدد عنوان IP المحلي لخادم Telepresence Management Suite (TMS)، مما يمكّن العملاء من تحديد موقع TMS والتواصل معه لأغراض الإدارة والتزويد. |
| 252 | wpad | موقع خادم Web Proxy Auto-Discovery (WPAD) الذي يستضيف ملف التكوين التلقائي للوكيل (PAC)، مما يتيح للعملاء اكتشاف إعدادات الوكيل وتكوينها تلقائيًا للوصول إلى الشبكة. |
خيارات IPv6
| القيمة | الاسم | وصف |
|---|---|---|
| 16 | dhcp6. فئة البائع | يستخدم العملاء هذا الخيار لتحديد المورد الذي قام بتصنيع الأجهزة التي يعملون عليها، مما يمكّن خدمات الشبكة من تخصيص التكوينات أو السياسات استنادًا إلى بائع الجهاز. راجع RFC 8415 للحصول على معلومات مفصلة . |
| 17 | dhcp6. خيارات المورد |
يستخدم العملاء والخوادم هذا الخيار لتبادل المعلومات الخاصة بالمورد، مما يسمح بالاتصال والتكوين المخصصين استنادًا إلى البيانات المحددة من قبل البائع . راجع RFC 8415 للحصول على معلومات مفصلة . |
| 21 | أسماء خوادم dhcp6.sip | يحدد أسماء النطاقات لخوادم بروكسي SIP الصادرة التي يستخدمها العميل لتوجيه حركة مرور إشارات SIP. راجع RFC 3319 للحصول على معلومات مفصلة. |
| 22 | عناوين خوادم dhcp6.sip | يحدد عناوين IPv6 لخوادم بروكسي SIP الصادرة التي يستخدمها العميل لتوجيه حركة مرور إشارات SIP. راجع RFC 3319 للحصول على معلومات مفصلة. |
| 23 | خوادم أسماء dhcp6 | يحدد عناوين IPv6 لخوادم أسماء DNS المتكررة التي يستخدمها العملاء لحل أسماء النطاقات إلى عناوين IP. راجع RFC 3646 للحصول على معلومات مفصلة . |
| 24 | dhcp6. البحث عن نطاق | يحدد أسماء النطاقات المضمنة في قائمة بحث المجال التي يستخدمها العملاء لحل أسماء المضيفين بدون أسماء نطاقات مؤهلة بالكامل. راجع RFC 3646 للحصول على معلومات مفصلة . |
| 31 | خوادم dhcp6.sntp | يحدد قائمة بخوادم بروتوكول وقت الشبكة البسيط (SNTP) المتاحة للعميل لأغراض مزامنة الوقت. راجع RFC 4075 للحصول على معلومات مفصلة . |