DHCP-opciók a fedélzeti, asztali és szobaszában
A DHCP-beállítások olyan további paraméterek, amelyeket a DHCP-kiszolgáló az IP-címek hozzárendelésével együtt biztosí that az ügyfeleknek. Ezek az opciók az IP-címen túl fontos hálózati konfigurációs részleteket közvetítenek, például:
- Alapértelmezett átjáró (router) cím
- DNS-kiszolgáló címei
- Alhálózati maszk
- Domain név
- Időkiszolgáló
- Indító fájl neve hálózati indításhoz
- Egyéb gyártó-specifikus vagy egyedi konfigurációs paraméterek
A DHCP-opciók rugalmasabb és átfogóbb hálózati konfigurációt tesznek lehetővé az ügyfél eszközök számára, lehetővé téve számukra, hogy automatikusan megkapják az összes szükséges beállítást a DHCP-kiszolgálóról a hálózaton való helyes működéshez.
RooMOS alapértelmezett gazdanév formátuma:
SEP <MAC>— ahol <MAC>az eszköz MAC-címét jelöli.
RooMOS DHCP opció 60 osztályazonosító:
Cisco: Codec:1.0
RooMOS DHCP opció 55 paraméterkérelmek listája
IPv4 beállítások
| Érték | Név | Leírás |
|---|---|---|
| 1 | alhálózati maszk | Az ügyfél alhálózati maszkja. Részletes információkért lásd az RFC 2132 címet. |
| 3 | útválasztók | Megadja az ügyfél alhálózatán található útválasztók IP-címeinek listáját. Részletes információkért lásd az RFC 2132 címet. |
| 6 | tartománynév-kiszolgálók | Megadja az ügyfél számára elérhető DNS-listát. Részletes információkért lásd az RFC 2132 címet. |
| 12 | gazdnév | Az ügyfél neve. Részletes információkért lásd az RFC 2132 címet. |
| 15 | tartománynév | Az a tartománynév, amelyet az ügyfélnek használnia kell a DNS-hostnév felbontásához. Részletes információkért lásd az RFC 2132 címet. |
| 18 | kiterjesztés-útvonal | Olyan karakterláncot ad meg, amely azonosítja a TFTP-n keresztül letölthető fájlt. Részletes információkért lásd az RFC 2132 címet. |
| 28 | műsorszórási cím | Az ügyfél alhálózatán használt sugárzási cím, amelyet sugárzási csomagok szállításához használnak. Részletes információkért lásd az RFC 2132 címet. |
| 42 | ntp-szerverek | Meghatározza az ügyfél számára az időszinkronizáláshoz rendelkezésre álló hálózati időprotokoll (NTP) kiszolgálók IP-címeinek listáját. Részletes információkért lásd az RFC 2132 címet. |
| 43 | szállítói kapszulázott opciók | Szállítói lehetőségek. Részletes információkért lásd az RFC 2132 címet. |
| 66 | tftp-kiszolgáló neve | A TFTP-kiszolgáló címe, amikor a DHCP-fejléc „sname” mezője a DHCP-beállítások átvitelére szolgál . Ez az opció azonosítja azt a TFTP-kiszolgálót, amellyel az ügyfél kapcsolatba léphet. Részletes információkért lásd az RFC 2132 címet. |
| 119 | tartománykeresés | Meghatározza azt a tartománykeresőlista opciót, amelyet az ügyfelek használnak a hostnevek DNS-en keresztü li megoldásához. Ez az opció lehetővé teszi az ügyfél számára, hogy több tartományban keressen a ne vek megoldásakor. Részletes információkért lásd az RFC 3397 címet. |
| 120 | helyi sip-szerverek | Megadja a munkamenet-iniciációs protokoll (SIP) kiszolgáló címének az ügyfelek számára történő megadásához használt DHCP-opciót. Ez az opció lehetővé teszi az eszközök számára, hogy a DHCP-n keresztül dinamikusan felfedezzék a SIP szervere Részletes információkért lásd az RFC 3361-et. |
| 150 | cisco-tftp | Meghatározza azt a DHCP-opciót, amely a Trivial File Transfer Protocol (TFTP) kiszolgálócímek tömbének megadására szolgál az ügyfelek számára. Ez az opció lehetővé teszi az eszközök számára, hogy dinamikusan több TFTP-kiszolgálót fedezjenek fel DHCP-n keresztül. Részletes információkért lásd az RFC 5859 oldalt. |
| 242 | helyi-tms-szerver | Megadja a Telepresentation Management Suite (TMS) kiszolgáló helyi IP-címét, amely lehetővé teszi az ügyfelek számára, hogy felügyeleti és biztosítási célokból megtalálják és kommunikáljanak a TMS-sel. |
| 252 | Wpad | A Proxy automatikus konfigurációs (PAC) fájlt tároló Web Proxy Auto-Discovery (WPAD) kiszolgáló helye, amely lehetővé teszi az ügyfelek számára, hogy automatikusan felfedezzék és konfigur álják a hálózati hozzáféréshez szükséges proxy beállításokat. |
IPv6 beállítások
| Érték | Név | Leírás |
|---|---|---|
| 16 | dhcp6.gyártó-osztály | Az ügyfelek ezzel a beállítással határozzák meg azt a szállítót, amely gyártotta a hard vert, amelyen futnak, lehetővé téve a hálózati szolgáltatások számára, hogy az eszközgyártó alapján testre szab ják a konfigurációkat vagy házirendeket. Részletes információkért lásd az RFC 8415 címet. |
| 17 | dhcp6. Vendor-Opts |
Az ügyfelek és kiszolgálók ezt az opciót a szállító-specifikus információk cseréjére használják, lehetővé téve a személyre szabott kommunikációt és konfigurációt a szállító által meghatározott adatok alapján. Részletes információkért lásd az RFC 8415 címet. |
| 21 | dhcp6.sip-szerverek-nevek | Meghatározza azon SIP-kimenő proxykiszolgálók tartománynevét, amelyeket az ügyfél a SIP jelátviteli forgalom irányításához használ. Részletes információkért lásd az RFC 3319 oldalt. |
| 22 | dhcp6.sip-szerver-címek | Meghatározza azon SIP-kimenő proxy kiszolgálók IPv6-címét, amelyeket az ügyfél a SIP jelátviteli forgalom irányításához használ. Részletes információkért lásd az RFC 3319 oldalt. |
| 23 | dhcp6.névkiszolgálók | Meghatározza azon DNS-rekurzív névkiszolgálók IPv6-címeit, amelyeket az ügyfelek a tartománynevek IP-cí mekké történő feloldására használnak. Részletes információkért lásd az RFC 3646 oldalt. |
| 24 | dhcp6.domain-search | Meghatározza azokat a tartománykeresési listában szereplő tartományneveket, amelyeket az ügyfelek a teljes minősített tartománynevek nélküli hostnevek megoldására használnak. Részletes információkért lásd az RFC 3646 oldalt. |
| 31 | dhcp6.sntp-szerverek | Meghatározza az ügyfél számára időszinkronizálási célokra rendelkezésre álló egyszerű hálózati időprotokoll (SNTP) kiszolgálók listáját. Részletes információkért lásd az RFC 4075 oldalt. |