אפשרויות DHCP בסדרות לוח, שולחן עבודה וחדרים
DHCP (Dynamic Host Configuration Protocol) הוא פרוטוקול ניהול רשת המשמש להקצאה אוטומטית של כתובות IP ופרמטרים אחרים של תצורת רשת להתקנים ברשת. זה מאפשר למכשירים לתקשר ברשת IP מבלי לדרוש תצורה ידנית של כתובות IP. DHCP מפשט את ניהול הרשת על ידי הקצאה דינמית של כתובות IP מטווח מוגדר ומתן מידע חיוני כגון מסיכת רשת משנה, שער ברירת מחדל ושרתי DNS למכשירי לקוח.
אפשרויות DHCP הן פרמטרים נוספים ששרת DHCP יכול לספק ללקוחות יחד עם הקצאת כתובת ה- IP. אפשרויות אלה מעבירות פרטי תצורת רשת חשובים מעבר לכתובת ה- IP בלבד, כגון:
- כתובת ברירת מחדל של שער (נתב)
- כתובות שרת DNS
- מסיכת רשת משנה
- שם תחום
- שרת זמן
- שם קובץ אתחול לאתחול ברשת
- פרמטרי תצורה אחרים ספציפיים לספק או מותאמים אישית
אפשרויות DHCP מאפשרות תצורת רשת גמישה ומקיפה יותר עבור התקני לקוח, ומאפשרות להם לקבל את כל ההגדרות הדרושות באופן אוטומטי משרת DHCP כדי לפעול כראוי ברשת.
עיין במד ריך DHCP לקבלת מידע מפורט אודות אפשרויות DHCP ופרטי אימות עבור השדות.
פורמט שם מארח ברירת מחדל של RoomOS:
SEP <MAC>- איפה <MAC>מייצג את כתובת ה- MAC של המכשיר.
RoomOS DHCP אפשרות 60 מזהה מחלקה:
סיסקו: קודק: 1.0
RoomOS DHCP אפשרות 55 רשימת בקשות פרמטרים
אפשרויות IPv4
| ערך | שם | תיאור |
|---|---|---|
| 1 | מסיכת רשת משנה | מסיכת רשת המשנה של הלקוח. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 3 | נתבים | מציין רשימה של כתובות IP לנתבים ברשת המשנה של הלקוח. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 6 | שרתי שמות דומיין | מציין רשימה של DNS הזמינה ללקוח. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 12 | שם מארח | שם הלקוח. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 15 | שם דומיין | שם הדומיין שהלקוח צריך להשתמש בו לצורך רזולוציית שם מארח DNS. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 18 | נתיב הרחבות | מציין מחרוזת המזהה קובץ הזמין לאחזור באמצעות TFTP. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 28 | כתובת שידור | כתובת השידור המשמשת ברשת המשנה של הלקוח למסירת מנות שידור . עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 42 | שרתי ntp | מציין רשימה של כתובות IP עבור שרתי פרוטוקול זמן רשת (NTP) הזמינים ללקוח לצורך סנכרון זמן. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 43 | אפשרויות מרופדות ספק | אפשרויות ספק. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 66 | שם שרת tftp | כתובת שרת ה- TFTP כאשר השדה 'sname' בכותרת DHCP משמש לשאת אפשרויות DHCP. אפשרות זו מזהה את שרת ה- TFTP שהלקוח יפ נה אליו. עיין ב- RFC 2132 לקבלת מידע מפורט. |
| 119 | חיפוש דומיין | מציין את האפשרות רשימת חיפוש תחומים המשמשת לקוחות לפתרון שמות מארחים באמצעות DNS. אפשרות זו מאפשרת ללקוח לחפש תחומים מרובים בעת פתרון שמות. עיין ב- RFC 3397 למידע מפורט. |
| 120 | שרתי SIP מקומיים | מציין את האפשרות DHCP המשמשת כדי לספק את כתובת הש רת פרוטוקול התחלת הפעלה (SIP) ללקוחות. אפשרות זו מאפשרת למכשירים לגלות שרתי SIP באופן דינמי באמצעות DHCP. עיין ב- RFC 3361 למידע מפורט. |
| 150 | סיסקו-tftp | מציין את האפשרות DHCP המשמשת לספק מערך של כתובות שרת של פרוטוקול העברת קבצים טריוויאלי (TFTP) ללקוחות. אפשרות זו מאפשרת למכשירים לגלות שרתי TFTP מרובים באופן דינמי באמצעות DHCP. עיין ב- RFC 5859 למידע מפורט . |
| 242 | שרת tms מקומי | מציין את כתובת ה- IP המקומית של שרת TelePresence Management Suite (TMS), המאפשרת ללקוחות לאתר את ה- TMS ולתקשר איתו למטרות ניהול והק צאה. |
| 252 | wpad | המיקום של שרת ה- WPAD (Web Proxy Auto-Discovery) המארח את קובץ הת צורה האוטומטית של פרוקסי (PAC), המאפשר ללקוחות לגלות ולהגדיר באופן אוטומטי הגדרות proxy לגישה לרשת. |
אפשרויות IPv6
| ערך | שם | תיאור |
|---|---|---|
| 16 | dhcp6. מחלקת ספק | לקוחות משתמשים באפשרות זו כדי לציין את הספק שייצר את החומרה עליה הם פועלים, מה שמאפשר לשירותי רשת להתאים תצורות או מדיניות בהתבסס על ספק ההתקן. עיין ב- RFC 8415 למידע מפורט . |
| 17 | dhcp6. אפשרויות ספק |
לקוחות ושרתים משתמשים באפשרות זו כדי להחליף מידע ספציפי לספק, המאפשרים תקשורת ותצורה מותאמים אישית המבוססים על נתונים המוגדרים על ידי ספק. עיין ב- RFC 8415 למידע מפורט . |
| 21 | dhcp6.sip-שמות שרתים | מציין את שמות התחום של שרתי ה- proxy היוצאים של SIP המשמשים את הלקוח לנתב תעבורת איתות SIP. עיין ב- RFC 3319 למידע מפורט. |
| 22 | dhcp6.sip-כתובות שרתים | מציין את כתובות ה- IPv6 של שרתי ה- proxy היוצאים של SIP המשמשים את הלקוח לנתב תעבורת איתות SIP. עיין ב- RFC 3319 למידע מפורט. |
| 23 | dhcp6. שרתי שמות | מציין את כתובות ה- IPv6 של שרתי שמות רקורסיביים של DNS שבהם משתמשים הלקוחות כדי לפתור שמות תחום לכתובות IP. עיין ב- RFC 3646 למידע מפורט . |
| 24 | dhcp6. חיפוש דומיין | מציין את שמות התחומים הכלולים ברשימת חיפוש התחומים שבהם משתמשים הלקוחות כדי לפתור שמות מארחים ללא שמות תחום מוסמכים במלואם. עיין ב- RFC 3646 למידע מפורט . |
| 31 | שרתי dhcp6.sntp | מציין רשימה של שרתי פרוטוקול זמן רשת פשוט (SNTP) הזמינים ללקו ח למטרות סנכרון זמן. עיין ב- RFC 4075 למידע מפורט . |
האם המאמר הועיל לך?