Možnosti DHCP v sérii palubných, pracovných stolov a miestností
Možnosti DHCP sú ďalšie parametre, ktoré môže DHCP server poskytnúť klientom spolu s priradením adres y IP. Tieto možnosti prenášajú dôležité podrobnosti o konfigurácii siete nad rámec IP adresy, ako napríklad:
- Predvolená adresa brány (smerovača)
- Adresy servera DNS
- Maska podsiete
- Názov domény
- Časový server
- Názov zavádzacieho súboru pre spustenie siete
- Ostatné parametre konfigurácie špecifické pre dodávateľa alebo vlastné konfiguračné parametre
Možnosti DHCP umožňujú flexibilnejšiu a komplexnejšiu konfiguráciu siete pre klientske zariadenia, čo im umožňuje automaticky prijímať všetky potrebné nastavenia zo servera DHCP, aby mohli správne fungovať v sieti.
Podrobné informácie o mož nostiach DHCP a podrobnosti o overení polí nájdete v Príručke DHCP.
Predvolený formát názvu hostiteľa RooMOS:
SEP <MAC>— kde <MAC>predstavuje MAC adresu zariadenia.
RoomOS DHCP Option 60 Identifikátor triedy:
Cisco:Codec:1.0
RooMOS DHCP Option 55 Zoznam požiadaviek parametrov
Možnosti IPv4
| Hodnota | Názov | Popis |
|---|---|---|
| 1 | podsieťová maska | Maska podsiete klienta. Podrobné informácie nájdete v RFC 2132. |
| 3 | smerovače | Určuje zoznam adries IP smerovačov v podsieti klienta. Podrobné informácie nájdete v RFC 2132. |
| 6 | servery s názvom domény | Určuje zoznam DNS dostupných pre klienta. Podrobné informácie nájdete v RFC 2132. |
| 12 | názov hostiteľa | Meno klienta. Podrobné informácie nájdete v RFC 2132. |
| 15 | názov domény | Názov domény, ktorý by mal klient použiť na rozlíšenie názvu hostiteľa DNS. Podrobné informácie nájdete v RFC 2132. |
| 18 | rozšírenia-cesta | Určuje reťazec, ktorý identifikuje súbor dostupný na načítanie cez TFTP. Podrobné informácie nájdete v RFC 2132. |
| 28 | adresa vysielania | Vysielacia adresa používaná v podsieti klienta na doručovanie vysielacích paketov. Podrobné informácie nájdete v RFC 2132. |
| 42 | ntp-servery | Určuje zoznam adries IP pre servery Network Time Protocol (NTP) dostupných pre klienta na synchronizáciu času. Podrobné informácie nájdete v RFC 2132. |
| 43 | možnosti zapuzdrené od dodávateľa | Možnosti dodávateľa. Podrobné informácie nájdete v RFC 2132. |
| 66 | Názov servera tftp | Adresa servera TFTP, keď sa pole „sname“ v hlavičke DHCP používa na prenášanie možností DHCP. Táto možnosť identifikuje server TFTP, s ktorým sa má klient kontaktovať. Podrobné informácie nájdete v RFC 2132. |
| 119 | vyhľadávanie domény | Určuje možnosť zoznamu vyhľadávania domén používanú klientmi na riešenie názvov hostiteľov prostredníctvom DNS. Táto možnosť umožňuje klientovi vyhľadávať vo viacerých doménach pri rieš ení mien. Podrobné informácie nájdete v RFC 3397. |
| 120 | lokálne sip-servery | Určuje možnosť DHCP použitú na poskytnutie adresy servera protokolu iniciácie relácie (SIP) klientom. Táto možnosť umožňuje zariadeniam dynamicky objavovať SIP servery prostredníctvom DHCP. Podrobné informácie nájdete v RFC 3361. |
| 150 | cisco-tftp | Určuje možnosť DHCP používanú na poskytovanie poľa adries servera Trivial File Transfer Protocol (TFTP) klientom. Táto možnosť umožňuje zariadeniam dynamicky objavovať viacero serverov TFTP prostredníctvom DHCP. Podrobné informácie nájdete v RFC 5859. |
| 242 | lokálny-tms-server | Určuje lokálnu IP adresu servera Telepresentation Management Suite (TMS), ktorá umožňuje klientom lokalizovať a komunikovať s TMS na účely správy a poskytovania služieb. |
| 252 | Wpad | Umiestnenie servera Web Proxy Auto-Discovery (WPAD), ktorý hosťuje súbor Proxy Auto-Configuration (PAC), ktorý umožňuje klientom automaticky zisťovať a konfigurovať nastavenia proxy pre prístup k sieti. |
Možnosti IPv6
| Hodnota | Názov | Popis |
|---|---|---|
| 16 | dhcp6.dodávateľská trieda | Klienti používajú túto možnosť na určenie dodávateľa, ktorý vyrobil hardvér, na ktorom sú spustení, čo umožňuje sieťovým službám prispôsobiť konfigurácie alebo politiky na základe dodávateľa zariadenia. Podrobné informácie nájdete v RFC 8415. |
| 17 | dhcp6.dodávateľský výber |
Klienti a servery využívajú túto možnosť na výmenu informácií špecifických pre dodávateľa, čo umožňuje prispôsobenú komunikáciu a konfiguráciu na základe údajov definovaných dodávateľom. Podrobné informácie nájdete v RFC 8415. |
| 21 | dhcp6.sip-názvy serverov | Určuje názvy domén odchádzajúcich proxy serverov SIP, ktoré klient používa na smerovanie signálnej prevádzky SIP. Podrobné informácie nájdete v RFC 3319. |
| 22 | adresy serverov dhcp6.sip- | Určuje adresy IPv6 odchádzajúcich proxy serverov SIP, ktoré klient používa na smerovanie signálnej prevádzky SIP. Podrobné informácie nájdete v RFC 3319. |
| 23 | dhcp6.name-servery | Určuje adresy IPv6 rekurzívnych menových serverov DNS, ktoré klienti používajú na riešenie náz vov domén na adresy IP. Podrobné informácie nájdete v RFC 3646. |
| 24 | dhcp6.vyhľadávanie domény | Určuje názvy domén zahrnuté v zozname vyhľadávania domén, ktoré klienti používajú na riešenie názvov hostiteľov bez plne kvalifikovaných názvov domén. Podrobné informácie nájdete v RFC 3646. |
| 31 | dhcp6.sntp-servery | Určuje zoznam serverov Simple Network Time Protocol (SNTP) dostupných pre klienta na účely synchronizácie času. Podrobné informácie nájdete v RFC 4075. |