DHCP-indstillinger i Board-, Desk- og Room-serien
DHCP-indstillinger er yderligere parametre, som en DHCP-server kan levere til klienter sammen med IP-adres setildelingen. Disse indstillinger formidler vigtige netværkskon figurationsdetaljer ud over blot IP-adressen, såsom:
- Standardgateway-adresse (router)
- DNS-serveradresser
- Subnetmaske
- Domænenavn
- Tidsserver
- Boot-filnavn til netværksopstart
- Andre leverandørspecifikke eller brugerdefinerede konfigurationsparametre
DHCP-indstillinger muliggør mere fleksibel og omfattende netværkskonfiguration for klient enheder, så de automatisk kan modtage alle nødvendige indstillinger fra DHCP-serveren for at fungere korrekt på netværket.
Se DHCP-vejledningen for detaljerede oplysninger om DHCP- indstillinger og valideringsoplysninger for felterne.
RoomOS Standard værtsnavnformat:
SEP <MAC>- hvor <MAC>repræsenterer enhedens MAC-adresse.
RoomOS DHCP Option 60 Klasse-identifikator:
Cisco: Codec: 1.0
RoomOS DHCP Option 55 Liste over parameteranmodninger
IPv4-indstillinger
| Værdi | Navn | Beskrivelse |
|---|---|---|
| 1 | undernetværksmaske | Klientens subnetmaske. Se RFC 2132 for detaljerede oplysninger. |
| 3 | routere | Angiver en liste over IP-adresser for routere på klientens undernet. Se RFC 2132 for detaljerede oplysninger. |
| 6 | domænenavneservere | Angiver en liste over DNS, der er tilgængelige for klienten. Se RFC 2132 for detaljerede oplysninger. |
| 12 | værtsnavn | Navnet på klienten. Se RFC 2132 for detaljerede oplysninger. |
| 15 | domænenavn | Det domænenavn, som klienten skal bruge til løsning af DNS-værtsnavn. Se RFC 2132 for detaljerede oplysninger. |
| 18 | udvidelser-sti | Angiver en streng, der identificerer en fil, der er tilgængelig til hentning via TFTP. Se RFC 2132 for detaljerede oplysninger. |
| 28 | Broadcast-adresse | Broadcast-adressen, der bruges på klientens undernet til levering af udsendelses pakker. Se RFC 2132 for detaljerede oplysninger. |
| 42 | ntp-servere | Angiver en liste over IP-adresser for NTP-servere (Network Time Protocol), der er tilgængelige for klienten til tidssynkronisering. Se RFC 2132 for detaljerede oplysninger. |
| 43 | leverandørindkapslede muligheder | Leverandørindstillinger. Se RFC 2132 for detaljerede oplysninger. |
| 66 | tftp-servernavn | TFTP-serverens adresse, når feltet 'sname' i DHCP-overskriften bruges til at bære DHCP-indstillinger. Denne indstilling identificerer den TFTP-server, som klienten skal kontakte. Se RFC 2132 for detaljerede oplysninger. |
| 119 | domænesøgning | Angiver den domænesøgningsliste, som klienter bruger til at løse værtsnavne via DNS. Denne indstilling giver klienten mulighed for at søge i flere domæner, når der løses navne. Se RFC 3397 for detaljerede oplysninger. |
| 120 | lokale-sip-servere | Angiver den DHCP-indstilling, der bruges til at angive SIP- serveradressen (Session Initiation Protocol) til klienter. Denne indstilling gør det muligt for enheder at opdage SIP-servere dynamisk via DHCP. Se RFC 3361 for detaljerede oplysninger. |
| 150 | cisco-tftp | Angiver den DHCP-indstilling, der bruges til at levere en række TFTP-serveradresser (Trivial File Transfer Protocol) til klienter. Denne indstilling gør det muligt for enheder at opdage flere TFTP-servere dynamisk via DHCP. Se RFC 5859 for detaljerede oplysninger. |
| 242 | lokal-tms-server | Angiver den lokale IP-adresse på TelePresence Management Suite (TMS) - serveren, så klienter kan lokalisere og kommunikere med TMS med henblik på administration og klargøring. |
| 252 | wpad | Placeringen af den WPAD-server (Web Proxy Auto-Discovery), der er vært for filen Proxy Auto-Configuration (PAC), så klienter automatisk kan finde og konfigurere proxyindstillinger for netværksadgang. |
IPv6-indstillinger
| Værdi | Navn | Beskrivelse |
|---|---|---|
| 16 | dhcp6.vendor-klasse | Klienter bruger denne indstilling til at angive den leverandør, der fremstillede den hardware, de kører på, hvilket gør det muligt for netværkstjenester at skræddersy konfigurationer eller politikker baseret på enhedsleverandøren. Se RFC 8415 for detaljerede oplysninger. |
| 17 | dhcp6.leverandørvalg |
Klienter og servere bruger denne mulighed til at udveksle leverandørspecifikke oplysninger, hvilket muliggør tilpasset kommunikation og konfiguration baseret på leverandørdefinerede data. Se RFC 8415 for detaljerede oplysninger. |
| 21 | dhcp6.sip-servernavne | Angiver domænenavne på de udgående SIP-proxyservere, som klienten bruger til at dirig ere SIP-signaleringstrafik. Se RFC 3319 for detaljerede oplysninger. |
| 22 | dhcp6.sip-server-adresser | Angiver IPv6-adresserne på de udgående SIP-proxyservere, som klienten bruger til at dirigere SIP-signaleringstrafik. Se RFC 3319 for detaljerede oplysninger. |
| 23 | dhcp6.navneservere | Angiver IPv6-adresserne for DNS-rekursive navneservere, som klienter bruger til at omdanne dom ænenavne til IP-adresser. Se RFC 3646 for detaljerede oplysninger. |
| 24 | dhcp6.domæne-søgning | Angiver de domænenavne, der er inkluderet på listen over domænesøgninger, som klienter bruger til at løse værtsnavne uden fuldt kvalificerede domænenavne. Se RFC 3646 for detaljerede oplysninger. |
| 31 | dhcp6.sntp-servere | Angiver en liste over SNTP-servere (Simple Network Time Protocol), der er tilgængelige for klienten til tidssynkroniseringsformål. Se RFC 4075 for detaljerede oplysninger. |