Opzioni DHCP sulle serie Board, Desk e Room

list-menuFeedback?
DHCP (Dynamic Host Configuration Protocol) è un protocollo di gestione della rete utilizzato per assegnare automaticamente indirizzi IP e altri parametri di configurazione di rete ai dispositivi su una rete. Ciò consente ai dispositivi di comunicare su una rete IP senza richiedere la configurazione manuale degli indirizzi IP. Il DHCP semplifica l'amministrazione della rete allocando dinamicamente gli indirizzi IP da un intervallo definito e fornendo informazioni essenziali come subnet mask, gateway predefinito e server DNS ai dispositivi client.

Le opzioni DHCP sono parametri aggiuntivi che un server DHCP può fornire ai client insieme all'assegnazione dell'indirizzo IP. Queste opzioni forniscono importanti dettagli di configurazione della rete oltre al semplice indirizzo IP, come:

  • Indirizzo gateway (router) predefinito
  • Indirizzi dei server DNS
  • Subnet mask
  • Nome di dominio
  • Time server
  • Nome del file di avvio per l'avvio dalla rete
  • Altri parametri di configurazione personalizzati o specifici del fornitore

Le opzioni DHCP consentono una configurazione di rete più flessibile e completa per i dispositivi client, consentendo loro di ricevere automaticamente tutte le impostazioni necessarie dal server DHCP per funzionare correttamente sulla rete.

Consulti la Guida DHCP per informazioni dettagliate sulle opzioni DHCP e sui dettagli di convalida per i campi.

Formato predefinito del nome host di RoomOS:

SEP <MAC>— dove <MAC>rappresenta l'indirizzo MAC del dispositivo.

Identificatore di classe RoomOS DHCP Option 60:

Cisco: Codec:1.0

Elenco di richieste di parametri RoomOS DHCP Option 55

Opzioni IPv4

ValoreNomeDescrizione
1subnet mask La subnet mask del cliente. Fare riferimento alla RFC 2132 per informazioni dettagliate.
3router Specifica un elenco di indirizzi IP per i router sulla sottorete del client. Fare riferimento alla RFC 2132 per informazioni dettagliate.
6server di nomi di dominio Specifica un elenco di DNS disponibili per il cliente. Fare riferimento alla RFC 2132 per informazioni dettagliate.
12nome host Il nome del cliente. Fare riferimento alla RFC 2132 per informazioni dettagliate.
15nome di dominio Il nome di dominio che il cliente deve utilizzare per la risoluzione dei nomi host DNS. Fare riferimento alla RFC 2132 per informazioni dettagliate.
18estensioni-percorso Specifica una stringa che identifica un file disponibile per il recupero tramite TFTP. Fare riferimento alla RFC 2132 per informazioni dettagliate.
28indirizzo di trasmissione L'indirizzo di trasmissione utilizzato nella sottorete del cliente per la consegna dei pacchetti di trasmissione. Fare riferimento alla RFC 2132 per informazioni dettagliate.
42server ntp Specifica un elenco di indirizzi IP per i server Network Time Protocol (NTP) disponibili per il client per la sincronizzazione dell'ora. Fare riferimento alla RFC 2132 per informazioni dettagliate.
43opzioni incapsulate dal fornitore Opzioni per i fornitori. Fare riferimento alla RFC 2132 per informazioni dettagliate.
66nome-server tftp L'indirizzo del server TFTP quando il campo «sname» nell'intestazione DHCP viene utilizzato per contenere le opzioni DHCP. Questa opzione identifica il server TFTP che il cliente deve contattare. Fare riferimento alla RFC 2132 per informazioni dettagliate.
119ricerca nel dominio Specifica l'opzione dell'elenco di ricerca dei domini utilizzata dai client per risolvere i nomi host tramite DNS. Questa opzione consente al cliente di cercare più domini durante la risoluzione dei nomi . Fare riferimento alla RFC 3397 per informazioni dettagliate.
120server SIP locali Specifica l'opzione DHCP utilizzata per fornire l'indirizzo del server SIP (Session Initiation Protocol) ai client. Questa opzione consente ai dispositivi di rilevare i server SIP in modo dinamico tramite DHCP. Fare riferimento alla RFC 3361 per informazioni dettagliate.
150cisco-tftp Specifica l'opzione DHCP utilizzata per fornire una serie di indirizzi di server TFTP (Trivial File Transfer Protocol) ai client. Questa opzione consente ai dispositivi di rilevare più server TFTP in modo dinamico tramite DHCP. Fare riferimento alla RFC 5859 per informazioni dettagliate .
242server tms locale Specifica l'indirizzo IP locale del server Telepresence Management Suite (TMS), consentendo ai client di localizzare e comunicare con il TMS per scopi di gestione e provisioning.
252wpad La posizione del server Web Proxy Auto-Discovery (WPAD) che ospita il file Proxy Auto-Configuration (PAC), che consente ai client di scoprire e configurare automaticamente le impostazioni proxy per l'accesso alla rete.

Opzioni IPv6

ValoreNomeDescrizione
16dhcp6.vendor-class I clienti utilizzano questa opzione per specificare il fornitore che ha prodotto l'hardware su cui sono in esecuzione, consentendo ai servizi di rete di personalizzare le configurazioni o le politiche in base al fornitore del dispositivo. Fare riferimento alla RFC 8415 per informazioni dettagliate .
17dhcp6.vendor-opts

I clienti e i server utilizzano questa opzione per scambiare informazioni specifiche del fornitore, consentendo comunicazioni e configurazioni personalizzate sulla base di dati definiti dal fornitore . Fare riferimento alla RFC 8415 per informazioni dettagliate .

21nomi-server dhcp6.sip Specifica i nomi di dominio dei server proxy SIP in uscita utilizzati dal client per instradare il traffico di segnalazione SIP. Fare riferimento alla RFC 3319 per informazioni dettagliate.
22indirizzi-server dhcp6.sip Specifica gli indirizzi IPv6 dei server proxy SIP in uscita utilizzati dal client per instradare il traffico di segnalazione SIP. Fare riferimento alla RFC 3319 per informazioni dettagliate.
23dhcp6.name-server Specifica gli indirizzi IPv6 dei server di nomi ricorsivi DNS utilizzati dai client per risolvere i nomi di dominio in indirizzi IP. Fare riferimento alla RFC 3646 per informazioni dettagliate .
24dhcp6.domain-search Specifica i nomi di dominio inclusi nell'elenco di ricerca dei domini che i client utilizzano per risolvere i nomi host senza nomi di dominio completi. Fare riferimento alla RFC 3646 per informazioni dettagliate .
31server dhcp6.sntp Specifica un elenco di server SNTP (Simple Network Time Protocol) disponibili per il client per scopi di sincronizzazione dell'ora. Fare riferimento alla RFC 4075 per informazioni dettagliate .
Questo articolo è stato utile?
Questo articolo è stato utile?