DHCP-opties aan boord, op het bureau en in de kamerserie

list-menuFeedback?
DHCP (Dynamic Host Configuration Protocol) is een netwerkbeheerprotocol dat wordt gebruikt om automatisch IP-adressen en andere netwerkconfiguratieparameters toe te wijzen aan apparaten in een netwerk. Hierdoor kunnen apparaten communiceren op een IP-netwerk zonder dat de IP-adressen handmatig hoeven te worden geconfigureerd. DHCP vereenvoudigt het netwerkbeheer door dynamisch IP-adressen uit een bepaald bereik toe te wijzen en essentiële informatie te verstrekken, zoals een subnetmasker, standaardgateway en DNS-servers, aan clientapparaten.

DHCP-opties zijn aanvullende parameters die een DHCP-server aan klanten kan verstrekken, samen met de toewijzing van het IP-adres. Deze opties bevatten belangrijke netwerkconfiguratiegegevens die verder gaan dan alleen het IP-adres, zoals:

  • Standaardgateway-adres (router)
  • Adressen van de DNS-server
  • Subnetmasker
  • Domeinnaam
  • Tijdserver
  • Naam van het opstartbestand voor het opstarten van het netwerk
  • Andere leverancierspecifieke of aangepaste configuratieparameters

DHCP-opties maken een flexibelere en uitgebreidere netwerkconfiguratie mogelijk voor client-apparaten, waardoor ze automatisch alle noodzakelijke instellingen van de DHCP-server kunnen ontvangen om correct te kunnen functioneren op het netwerk.

Raadpleeg de DHCP-handleiding voor gedetailleerde informatie over DHCP-opties en validatiegegevens voor de velden.

RoomOS standaard hostnaamformaat:

SEP <MAC>— waar <MAC>staat voor het MAC-adres van het apparaat.

Klasse-ID voor RoomOS DHCP Option 60:

Cisco: Codec:1.0

RoomOS DHCP Optie 55 Parameteraanvraaglijst

IPv4-opties

WaardeNaamBeschrijving
1subnetmasker Het subnetmasker van de klant. Raadpleeg RFC 2132 voor gedetailleerde informatie.
3routers Specificeert een lijst met IP-adressen voor routers op het subnet van de klant. Raadpleeg RFC 2132 voor gedetailleerde informatie.
6domeinnaamservers Specificeert een lijst van DNS die beschikbaar is voor de client. Raadpleeg RFC 2132 voor gedetailleerde informatie.
12hostnaam De naam van de klant. Raadpleeg RFC 2132 voor gedetailleerde informatie.
15domeinnaam De domeinnaam die de client moet gebruiken voor de resolutie van de DNS-hostnaam. Raadpleeg RFC 2132 voor gedetailleerde informatie.
18pad met extensies Specificeert een tekenreeks die een bestand identificeert dat via TFTP kan worden opgehaald. Raadpleeg RFC 2132 voor gedetailleerde informatie.
28omroepadres Het uitzendadres dat op het subnet van de klant wordt gebruikt voor de levering van uitzendpakketten. Raadpleeg RFC 2132 voor gedetailleerde informatie.
42ntp-servers Specificeert een lijst met IP-adressen voor NTP-servers (Network Time Protocol) die beschikbaar zijn voor de client voor tijdsynchronisatie. Raadpleeg RFC 2132 voor gedetailleerde informatie.
43opties die zijn ingekapseld door de leverancier Opties voor leveranciers. Raadpleeg RFC 2132 voor gedetailleerde informatie.
66tftp-servernaam Het adres van de TFTP-server wanneer het veld 'naam' in de DHCP-header wordt gebruikt om DHCP-opties over te dragen. Deze optie identificeert de TFTP-server waarmee de client contact kan opnemen. Raadpleeg RFC 2132 voor gedetailleerde informatie.
119zoeken naar een domein Specificeert de optie voor de zoeklijst voor domeinen die door klanten wordt gebruikt om hostnamen via DNS op te lossen. Met deze optie kan de klant meerdere domeinen doorzoeken bij het omzetten van namen. Raadpleeg RFC 3397 voor gedetailleerde informatie.
120lokale SIP-servers Specificeert de DHCP-optie die wordt gebruikt om het serveradres van het Session Initiation Protocol (SIP) aan klanten te verstrekken. Met deze optie kunnen apparaten SIP-servers dynamisch ontdekken via DHCP. Raadpleeg RFC 3361 voor gedetailleerde informatie.
150cisco-tftp Specificeert de DHCP-optie die wordt gebruikt om een reeks Trivial File Transfer Protocol (TFTP) -serveradressen aan klanten te verstrekken. Met deze optie kunnen apparaten meerdere TFTP-servers dynamisch ontdekken via DHCP. Raadpleeg RFC 5859 voor gedetailleerde informatie .
242lokale tms-server Specificeert het lokale IP-adres van de Telepresence Management Suite (TMS) -server, zodat klanten het TMS kunnen lokaliseren en ermee kunnen communiceren voor beheer- en inrichtingsdoeleinden.
252wpad De locatie van de Web Proxy Auto-Discovery (WPAD-server) waarop het PAC-bestand (Proxy Auto-Configuration) wordt gehost, zodat clients automatisch de proxy-instellingen voor netwerktoegang kunnen ontdekken en configureren.

IPv6-opties

WaardeNaamBeschrijving
16dhcp6.leveranciersklasse Klanten gebruiken deze optie om de leverancier aan te geven die de hardware heeft vervaardigd waarop ze draaien, zodat netwerkdiensten configuraties of beleidsregels kunnen aanpassen op basis van de leverancier van het apparaat. Raadpleeg RFC 8415 voor gedetailleerde informatie .
17dhcp6.vendor-opts

Clients en servers gebruiken deze optie om leverancierspecifieke informatie uit te wisselen, waardoor communicatie en configuratie op maat mogelijk is op basis van door de leverancier gedefinieerde gegevens. Raadpleeg RFC 8415 voor gedetailleerde informatie .

21dhcp6.sip-servernamen Specificeert de domeinnamen van de uitgaande SIP-proxyservers die door de client worden gebruikt om SIP-signaleringsverkeer te routeren. Raadpleeg RFC 3319 voor gedetailleerde informatie.
22dhcp6.sip-servers-adressen Specificeert de IPv6-adressen van de uitgaande SIP-proxyservers die door de client worden gebruikt om SIP-signaleringsverkeer te routeren. Raadpleeg RFC 3319 voor gedetailleerde informatie.
23dhcp6.name-servers Specificeert de IPv6-adressen van recursieve DNS-naamservers die clients gebruiken om domeinnamen om te zetten in IP-adressen. Raadpleeg RFC 3646 voor gedetailleerde informatie .
24dhcp6.domein zoeken Specificeert de domeinnamen die zijn opgenomen in de zoeklijst voor domeinen die klanten gebruiken om hostnamen op te lossen zonder volledig gekwalificeerde domeinnamen. Raadpleeg RFC 3646 voor gedetailleerde informatie .
31dhcp6.sntp-servers Specificeert een lijst van Simple Network Time Protocol-servers (SNTP) die beschikbaar zijn voor de client voor tijdsynchronisatie. Raadpleeg RFC 4075 voor gedetailleerde informatie .
Vond u dit artikel nuttig?
Vond u dit artikel nuttig?