Опции DHCP в сериях «Плата», «Рабочий стол» и «Комната»
Опции DHCP — это дополнительные параметры, которые DHCP-сервер может предоставлять клиентам вместе с назначением IP-адреса. Эти опции содержат не только IP-адрес, но и важные сведения о конфигурации сети, такие как:
- Адрес шлюза (маршрутизатора) по умолчанию
- Адреса DNS-серверов
- Маска подсети
- Доменное имя
- Сервер времени
- Имя загрузочного файла для сетевой загрузки
- Другие специфичные для производителя или настраиваемые параметры конфигурации
Опции DHCP обеспечивают более гибкую и комплексную настройку сети для клиентских устройств, позволяя им автоматически получать все необходимые настройки с DHCP-сервера для корректной работы в сети.
Подробные сведения о параметрах DHCP и сведения о проверке полей см. в руководстве по DHCP.
Формат имени хоста RoomOS по умолчанию:
SEP <MAC>— где <MAC>обозначает MAC-адрес устройства.
Идентификатор класса RoomOS DHCP Option 60:
Cisco: кодек: 1.0
Список запросов параметров RoomOS DHCP, опция 55
Опции IPv4
| Значение | Имя | Описание |
|---|---|---|
| 1 | маска подсети | Маска подсети клиента. Дополнительные сведения см. в документе RFC 2132. |
| 3 | маршрутизаторы | Указывает список IP-адресов для маршрутизаторов в подсети клиента. Дополнительные сведения см. в документе RFC 2132. |
| 6 | серверы доменных имен | Указывает список DNS, доступных клиенту. Дополнительные сведения см. в документе RFC 2132. |
| 12 | имя хоста | Имя клиента. Дополнительные сведения см. в документе RFC 2132. |
| 15 | доменное имя | Доменное имя, которое клиент должен использовать для разрешения имен хостов DNS. Дополнительные сведения см. в документе RFC 2132. |
| 18 | путь к расширениям | Указывает строку, идентифицирующую файл, доступный для получения по протоколу TFTP. Дополнительные сведения см. в документе RFC 2132. |
| 28 | адрес вещания | широковещательный адрес, используемый в подсети клиента для доставки широковещательных пакетов. Дополнительные сведения см. в документе RFC 2132. |
| 42 | ntp-серверы | Указывает список IP-адресов серверов NTP, доступных клиенту для синхронизации времени. Дополнительные сведения см. в документе RFC 2132. |
| 43 | Опции, инкапсулированные поставщиком | Опции поставщиков. Дополнительные сведения см. в документе RFC 2132. |
| 66 | tftp-имя сервера | Адрес сервера TFTP, когда поле «sname» в заголовке DHCP используется для хранения опций DHCP. Эта опция определяет сервер TFTP, с которым клиент должен связаться. Дополнительные сведения см. в документе RFC 2132. |
| 119 | поиск по доменам | Указывает вариант списка поиска доменов, используемый клиентами для разрешения имен хостов с помощью DNS. Эта опция позволяет клиенту искать несколько доменов при разрешении имен. Дополнительные сведения см. в документе RFC 3397. |
| 120 | локальные sip-серверы | Указывает опцию DHCP, используемую для предоставления клиентам адреса сервера протокола инициации сеанса (SIP). Эта опция позволяет устройствам динамически обнаруживать серверы SIP через DHCP. Дополнительные сведения см. в документе RFC 3361. |
| 150 | cisco-tftp | Указывает опцию DHCP, используемую для предоставления клиентам массива адресов серверов TFTP . Эта опция позволяет устройствам динамически обнаруживать несколько серверов TFTP через DHCP. Дополнительные сведения см. в документе RFC 5859. |
| 242 | локальный tms-сервер | Указывает локальный IP-адрес сервера Telepresence Management Suite (TMS), позволяющий клиентам находить TMS и взаимодействовать с ней в целях управления и выделения ресурсов. |
| 252 | wpad | Местоположение сервера автоматического обнаружения веб-прокси (WPAD), на котором размещен файл автоматической конфигурации прокси-сервера (PAC), позволяющий клиентам автоматически обнаруживать и настраивать параметры прокси-сервера для доступа к сети. |
Варианты IPv6
| Значение | Имя | Описание |
|---|---|---|
| 16 | класс поставщика dhcp6. | Клиенты используют эту опцию, чтобы указать поставщика, изготовившего оборудование, на котором они работают, что позволяет сетевым службам адаптировать конфигурации или политики в зависимости от поставщика устройства. Дополнительные сведения см. в документе RFC 8415. |
| 17 | Выбор поставщика dhcp6. |
Клиенты и серверы используют эту опцию для обмена информацией о конкретном поставщике, что позволяет настраивать связь и конфигурацию на основе данных, определенных поставщиком. Дополнительные сведения см. в документе RFC 8415. |
| 21 | dhcp6.sip-имена серверов | Указывает доменные имена исходящих прокси-серверов SIP, используемых клиентом для маршрутизации сигнального трафика SIP. Дополнительные сведения см. в документе RFC 3319. |
| 22 | dhcp6.sip-адреса серверов | Указывает IPv6-адреса исходящих прокси-серверов SIP, используемых клиентом для маршрутизации сигнального трафика SIP. Дополнительные сведения см. в документе RFC 3319. |
| 23 | Серверы dhcp6.name | Указывает IPv6-адреса рекурсивных DNS-серверов имен, которые клиенты используют для преобразования доменных имен в IP-адреса. Дополнительные сведения см. в документе RFC 3646. |
| 24 | dhcp6. Поиск по домену | Указывает доменные имена, включенные в список поиска доменов, которые клиенты используют для определения имен хостов без полных доменных имен. Дополнительные сведения см. в документе RFC 3646. |
| 31 | dhcp6.sntp-серверы | Указывает список серверов SNTP, доступных клиенту для синхронизации времени. Дополнительные сведения см. в документе RFC 4075. |