Opções de DHCP nas séries Board, Desk e Room
As opções de DHCP são parâmetros adicionais que um servidor DHCP pode fornecer aos clientes junto com a atribuição de endereço IP. Essas opções transmitem detalhes importantes da configuração da rede além do endereço IP, como:
- Endereço de gateway (roteador) padrão
- Endereços de servidores DNS
- Máscara de sub-rede
- Nome de domínio
- Servidor de horário
- Nome do arquivo de inicialização para inicialização de rede
- Outros parâmetros de configuração personalizados ou específicos do fornecedor
As opções de DHCP permitem uma configuração de rede mais flexível e abrangente para dispositivos clientes, permitindo que eles recebam automaticamente todas as configurações necessárias do servidor DHCP para operar corretamente na rede.
Consulte o Guia do DHCP para obter informações detalhadas sobre as opções de DHCP e os detalhes de validação dos campos.
Formato de nome de host padrão do RoomOS:
SEP <MAC>— onde <MAC>representa o endereço MAC do dispositivo.
Identificador de classe RoomOS DHCP Opção 60:
Cisco: Codec: 1.0
Lista de solicitações de parâmetros da opção 55 do RoomOS DHCP
Opções de IPv4
| Valor | Nome | Descrição |
|---|---|---|
| 1 | máscara de sub-rede | A máscara de sub-rede do cliente. Consulte a RFC 2132 para obter informações detalhadas. |
| 3 | roteadores | Especifica uma lista de endereços IP para roteadores na sub-rede do cliente. Consulte a RFC 2132 para obter informações detalhadas. |
| 6 | servidores de nomes de domínio | Especifica uma lista de DNS disponíveis para o cliente. Consulte a RFC 2132 para obter informações detalhadas. |
| 12 | nome do host | O nome do cliente. Consulte a RFC 2132 para obter informações detalhadas. |
| 15 | nome de domínio | O nome de domínio que o cliente deve usar para a resolução do nome de host DNS. Consulte a RFC 2132 para obter informações detalhadas. |
| 18 | caminho de extensões | Especifica uma string que identifica um arquivo disponível para recuperação via TFTP. Consulte a RFC 2132 para obter informações detalhadas. |
| 28 | endereço de transmissão | O endereço de transmissão usado na sub-rede do cliente para entregar pacotes de transmissão. Consulte a RFC 2132 para obter informações detalhadas. |
| 42 | servidores ntp | Especifica uma lista de endereços IP para servidores NTP (Network Time Protocol) disponíveis para o cliente para sincronização de horário. Consulte a RFC 2132 para obter informações detalhadas. |
| 43 | opções encapsuladas pelo fornecedor | Opções do fornecedor. Consulte a RFC 2132 para obter informações detalhadas. |
| 66 | nome do servidor tftp | O endereço do servidor TFTP quando o campo 'sname' no cabeçalho DHCP é usado para transportar as opções de DHCP. Essa opção identifica o servidor TFTP para o cliente contatar. Consulte a RFC 2132 para obter informações detalhadas. |
| 119 | pesquisa de domínio | Especifica a opção de lista de pesquisa de domínio usada pelos clientes para resolver nomes de host via DNS. Essa opção permite que o cliente pesquise vários domínios ao resolver nomes. Consulte a RFC 3397 para obter informações detalhadas. |
| 120 | servidores SIP locais | Especifica a opção DHCP usada para fornecer o endereço do servidor SIP (Session Initiation Protocol) aos clientes. Essa opção permite que os dispositivos descubram servidores SIP dinamicamente via DHCP. Consulte a RFC 3361 para obter informações detalhadas. |
| 150 | cisco-tftp | Especifica a opção DHCP usada para fornecer uma matriz de endereços de servidor TFTP (Trivial File Transfer Protocol) aos clientes. Essa opção permite que os dispositivos descubram vários servidores TFTP dinamicamente via DHCP. Consulte a RFC 5859 para obter informações detalhadas . |
| 242 | servidor tms local | Especifica o endereço IP local do servidor Telepresence Management Suite (TMS), permitindo que os clientes localizem e se comuniquem com o TMS para fins de gerenciamento e provisionamento. |
| 252 | almofada | A localização do servidor Web Proxy Auto-Discovery (WPAD) que hospeda o arquivo PAC (Proxy Auto-Configuration), permitindo que os clientes descubram e definam automaticamente as configurações de proxy para acesso à rede. |
Opções de IPv6
| Valor | Nome | Descrição |
|---|---|---|
| 16 | dhcp6.classe de fornecedor | Os clientes usam essa opção para especificar o fornecedor que fabricou o hardware no qual estão sendo executados, permitindo que os serviços de rede personalizem configurações ou políticas com base no fornecedor do dispositivo. Consulte a RFC 8415 para obter informações detalhadas . |
| 17 | dhcp6.opções do fornecedor |
Clientes e servidores usam essa opção para trocar informações específicas do fornecedor, permitindo comunicação e configuração personalizadas com base nos dados definidos pelo fornecedor . Consulte a RFC 8415 para obter informações detalhadas . |
| 21 | nomes de servidores dhcp6.sip | Especifica os nomes de domínio dos servidores proxy de saída SIP usados pelo cliente para rotear o tráfego de sinalização SIP. Consulte o RFC 3319 para obter informações detalhadas. |
| 22 | endereços de servidores dhcp6.sip | Especifica os endereços IPv6 dos servidores proxy de saída SIP usados pelo cliente para rotear o tráfego de sinalização SIP. Consulte o RFC 3319 para obter informações detalhadas. |
| 23 | servidores de nomes dhcp6. | Especifica os endereços IPv6 dos servidores de nomes recursivos DNS que os clientes usam para transformar nomes de domínio em endereços IP. Consulte o RFC 3646 para obter informações detalhadas . |
| 24 | dhcp6. pesquisa de domínio | Especifica os nomes de domínio incluídos na lista de pesquisa de domínio que os clientes usam para resolver nomes de host sem nomes de domínio totalmente qualificados. Consulte o RFC 3646 para obter informações detalhadas . |
| 31 | servidores dhcp6.sntp | Especifica uma lista de servidores SNTP (Simple Network Time Protocol) disponíveis para o cliente para fins de sincronização de horário. Consulte a RFC 4075 para obter informações detalhadas . |