機板、桌面和房間系列的 DHCP 選項
DHCP(動態主機組態通訊協定)是一種網路管理通訊協定,用於自動將 IP 位址和其他網路組態參數指派給網路上的裝置。這允許設備在 IP 網絡上通信,而不需要手動配置 IP 位址。DHCP 透過從定義範圍動態分配 IP 位址,並將子網路遮罩、預設閘道和 DNS 伺服器等重要資訊提供給用戶端裝置,簡化網路管理。
DHCP 選項是 DHCP 伺服器可以向用戶端提供的附加參數以及 IP 位址分配。 這些選項傳達了除 IP 位址之外的重要網路配置詳細資訊,例如:
- 預設閘道 (路由器) 位址
- DNS 伺服器位址
- 子網路遮罩
- 網域名稱
- 時間伺服器
- 用於網路引導的引導檔案名稱
- 其他供應商特定或自訂設定參數
DHCP 選項為用戶端設備提供更靈活、更全面的網络配置,允許它們從 DHCP 伺服器自動接收所有必要的設置,以便在網络上正常運行。
有關欄位的 DHCP 選項和驗證詳細資訊的詳細資訊,請參閱 DHCP 指南 。
RoomOS 預設主機名稱格式:
SEP<MAC>—其中 <MAC> 表示裝置的 MAC 位址。
RoomOS DHCP 選項 60 類標識符:
Cisco:編解碼器:1.0
RoomOS DHCP 選項 55 參數請求清單
IPv4 選項
| 值 | 名稱 | 說明 |
|---|---|---|
| 1 | 子網路遮罩 | 用戶端的子網掩碼。 有關詳細資訊,請參閱 RFC 2132。 |
| 3 | 路由器 | 指定用戶端子網上路由器的 IP 位址清單。 有關詳細資訊,請參閱 RFC 2132。 |
| 6 | 網域名稱伺服器 | 指定用戶端可用的 DNS 清單。 有關詳細資訊,請參閱 RFC 2132。 |
| 12 | 主機名稱 | 用戶端的名稱。 有關詳細資訊,請參閱 RFC 2132。 |
| 15 | 網域名稱 | 用戶端應用於 DNS 主機名解析的功能變數名稱。 有關詳細資訊,請參閱 RFC 2132。 |
| 18 | 延伸路徑 | 指定一個字串,該字串標識可通過 TFTP 檢索的檔。 有關詳細資訊,請參閱 RFC 2132。 |
| 28 | 廣播位址 | 用戶端子網上用於傳送廣播數據包的廣播位址。 有關詳細資訊,請參閱 RFC 2132。 |
| 42 | NTP 伺服器 | 指定網路時間協定 (NTP) 伺服器的 IP 位址清單,該伺服器可供客戶端進行時間同步。 有關詳細資訊,請參閱 RFC 2132。 |
| 43 | 供應商封裝選項 | 供應商選項。 有關詳細資訊,請參閱 RFC 2132。 |
| 66 | TFTP 伺服器名稱 | TFTP 伺服器的位址,當 DHCP 標頭中的“sname”字段用於攜帶 DHCP 選項時。 此選項標識用戶端要聯繫的 TFTP 伺服器。 有關詳細資訊,請參閱 RFC 2132。 |
| 119 | 網域搜尋 | 指定客戶端用於通過 DNS 解析主機名的域搜索清單選項。 此選項允許客戶端在解析名稱時搜索多個域。 有關詳細資訊,請參閱 RFC 3397。 |
| 120 | 本地 SIP 伺服器 | 指定用於向用戶端提供 Session Initiation Protocol (SIP) 伺服器位址的 DHCP 選項。 此選項使設備能夠通過 DHCP 動態發現 SIP 伺服器。 有關詳細資訊,請參閱 RFC 3361。 |
| 150 | 思科 -TFTP | 指定用於向用戶端提供簡單檔案傳輸協定 (TFTP) 伺服器位址陣列的 DHCP 選項。 此選項允許設備通過 DHCP 動態發現多個 TFTP 伺服器。 有關詳細資訊,請參閱 RFC 5859。 |
| 242 | 本地 TMS- 伺服器 | 指定 TelePresence 管理套件 (TMS) 伺服器的本地 IP 位址,使客戶端能夠查找 TMS 並與之通信以進行管理和預配。 |
| 252 | WPAD | 承載代理自動配置 (PAC) 檔案的 Web 代理自動發現 (WPAD) 伺服器的位置,使客戶端能夠自動發現和配置網路訪問的代理設置。 |
IPv6 選項
| 值 | 名稱 | 說明 |
|---|---|---|
| 16 | DHCP6.vendor-class | 用戶端使用此選項指定製造運行它們的硬體的供應商,使網路服務能夠根據設備供應商定製配置或策略。 有關詳細資訊,請參閱 RFC 8415。 |
| 17 | DHCP6.vendor-opts |
用戶端和伺服器使用此選項交換特定於供應商的資訊,從而允許基於供應商定義的數據進行自定義通信和配置。 有關詳細資訊,請參閱 RFC 8415。 |
| 21 | dhcp6.sip-servers-names | 指定用戶端用於路由 SIP 信號流量的 SIP 出站代理伺服器的功能變數名稱。 有關詳細資訊,請參閱 RFC 3319。 |
| 22 | dhcp6.sip-servers-address | 指定用戶端用於路由 SIP 信號流量的 SIP 出站代理伺服器的 IPv6 位址。 有關詳細資訊,請參閱 RFC 3319。 |
| 23 | dhcp6.name 伺服器 | 指定用戶端用於將功能變數名稱解析為 IP 位址的 IPv6 遞歸名稱伺服器的 DNS 位址。 有關詳細資訊,請參閱 RFC 3646。 |
| 24 | dhcp6.域搜尋 | 指定域搜索清單中包括的功能變數名稱,用戶端使用該功能變數名稱解析沒有完全限定功能變數名稱的主機名。 有關詳細資訊,請參閱 RFC 3646。 |
| 31 | dhcp6.sntp-servers | 指定用戶端可用於時間同步的簡單網路時間協定 (SNTP) 伺服器的清單。 有關詳細資訊,請參閱 RFC 4075。 |
本文是否有幫助?