Možnosti DHCP v seriji plošče, mize in sobe
Možnosti DHCP so dodatni parametri, ki jih strežnik DHCP lahko zagotovi odjemalcem skupaj z dodelitvijo naslova IP. Te možnosti posredujejo pomembne podrobnosti o konfiguraciji omrež ja, ki presegajo samo naslov IP, kot so:
- Privzeti naslov prehoda (usmerjevalnik)
- Naslovi strežnika DNS
- Maska podomrežja
- Ime domene
- Časovni strežnik
- Ime zagonske datoteke za zagon omrežja
- Drugi konfiguracijski parametri, specifični za prodajalca ali po meri
Možnosti DHCP omogočajo bolj prilagodljivo in celovito konfiguracijo omrežja za odjemalske naprave, kar jim omogoča samodejno prejemanje vseh potrebnih nastavitev s strežnika DHCP za pravilno delovanje v omrežju.
Za podrobne informacije o možnosti h DHCP in podrobnosti o preverjanju veljavnosti polj glejte Vodnik DHCP.
Privzeta oblika imena gostitelja RooMOS:
SEP <MAC>- kjer <MAC>predstavlja MAC naslov naprave.
RooMOS DHCP Option 60 Identifikator razreda:
Cisco:Codec:1.0
RooMOS DHCP Option 55 Seznam zahtev parametrov
Možnosti IPv4
| Vrednost | Ime | Opis |
|---|---|---|
| 1 | podomrežna maska | Maska podomrežja stranke. Za podrobne informacije glejte RFC 2132. |
| 3 | usmerjevalniki | Določa seznam naslovov IP za usmerjevalnike v odjemalčevim podomrežju. Za podrobne informacije glejte RFC 2132. |
| 6 | strežniki domenskih imen | Določa seznam DNS, ki je na voljo odjemalcu. Za podrobne informacije glejte RFC 2132. |
| 12 | ime gostitelja | Ime stranke. Za podrobne informacije glejte RFC 2132. |
| 15 | ime domene | Ime domene, ki ga mora odjemalec uporabiti za ločljivost imena gostitelja DNS. Za podrobne informacije glejte RFC 2132. |
| 18 | razširitvenje-pot | Določa niz, ki identificira datoteko, ki je na voljo za iskanje prek TFTP. Za podrobne informacije glejte RFC 2132. |
| 28 | naslov oddajanja | Naslov oddajanja, ki se uporablja v odjemalčevem podomrežju za dostavo oddajnih paketov. Za podrobne informacije glejte RFC 2132. |
| 42 | ntp-strežniki | Določa seznam naslovov IP za strežnike Network Time Protocol (NTP), ki so na voljo odjemalcu za časovno sinhronizacijo. Za podrobne informacije glejte RFC 2132. |
| 43 | Inkapsulirane možnosti prodajalca | Možnosti prodajalca. Za podrobne informacije glejte RFC 2132. |
| 66 | ime strežnika tftp | Naslov strežnika TFTP, ko se polje« sname »v glavi DHCP uporablja za prenos možnosti DHCP . Ta možnost identificira strežnik TFTP, s katerim se odjemalec lahko obrne. Za podrobne informacije glejte RFC 2132. |
| 119 | iskanje domene | Določa možnost seznama iskanja po domeni, ki jo odjemalci uporabljajo za reševanje imen gostitel jev prek DNS. Ta možnost omogoča odjemalcu, da pri reševanju imen išče več domen. Za podrobne informacije glejte RFC 3397. |
| 120 | lokalni sip-strežniki | Določa možnost DHCP, ki se uporablja za zagotavljanje naslova strežnika protokola za začetek seje (SIP) odjemalcem. Ta možnost omogoča napravam dinamično odkrivanje strežnikov SIP prek DHCP. Za podrobne informacije glejte RFC 3361. |
| 150 | cisco-tftp | Določa možnost DHCP, ki se uporablja za zagotavljanje niza naslovov strežnika Trivial File Transfer Protocol (TFTP) odjemalcem. Ta možnost omogoča napravam, da prek DHCP dinamično odkrijejo več strežnikov TFTP. Za podrob ne informacije glejte RFC 5859. |
| 242 | lokalni strežnik tms- | Določa lokalni naslov IP strežnika Telepresentation Management Suite (TMS), ki strankam omogoča iskanje in komunikacijo s sistemom TMS za namene upravljanja in zagotavljanja. |
| 252 | Wpad | Lokacija strežnika Web Proxy Auto-Discovery (WPAD), ki gosti datoteko Proxy Auto-Configuration (PAC), ki omogoča odjemalcem samodejno odkrivanje in konfiguriranje nastavitev proxy za dostop do omrežja. |
Možnosti IPv6
| Vrednost | Ime | Opis |
|---|---|---|
| 16 | dhcp6.prodajni razred | Odjemalci s to možnostjo določijo prodajalca, ki je izdelal strojno opremo, na kateri se izvajajo, in omrežnim storitvam omogoča prilagajanje konfiguracij ali pravilnikov glede na prodajalca naprave. Za podrob ne informacije glejte RFC 8415. |
| 17 | dhcp6.prodajalec se odloči |
Odjemalci in strežniki uporabljajo to možnost za izmenjavo informacij, specifičnih za prodajalca, kar omogoča prilagojeno komunikacijo in konfiguracijo na podlagi podatkov, ki jih določi prodajalec . Za podrob ne informacije glejte RFC 8415. |
| 21 | dhcp6.sip-imena strežnikov | Določa imena domen izhodnih proxy strežnikov SIP, ki jih odjemalec uporablja za usmer janje signalnega prometa SIP. Za podrobne informacije glejte RFC 3319. |
| 22 | dhcp6.sip-naslovi strežnikov | Določa naslove IPv6 izhodnih proxy strežnikov SIP, ki jih odjemalec uporablja za usmer janje signalnega prometa SIP. Za podrobne informacije glejte RFC 3319. |
| 23 | dhcp6.imenski strežniki | Določa naslove IPv6 rekurzivnih imenskih strežnikov DNS, ki jih odjemalci uporabljajo za raz reševanje imen domen v naslove IP. Za podrob ne informacije glejte RFC 3646. |
| 24 | dhcp6.iskanje domene | Določa imena domen, vključena v seznam iskanja po domeni, ki jih odjemalci uporabljajo za reš evanje imen gostiteljev brez popolnoma kvalificiranih domenskih imen. Za podrob ne informacije glejte RFC 3646. |
| 31 | dhcp6.sntp-strežniki | Določa seznam strežnikov Simple Network Time Protocol (SNTP), ki so na voljo odjemal cu za namene sinhronizacije časa. Za podrob ne informacije glejte RFC 4075. |