Options DHCP pour les séries Board, Desk et Room
Les options DHCP sont des paramètres supplémentaires qu'un serveur DHCP peut fournir aux clients en plus de l'attribution des adresses IP. Ces options fournissent des informations importantes sur la configuration du réseau, au-delà de l'adresse IP, telles que :
- Adresse de passerelle (routeur) par défaut
- Adresses des serveurs DNS
- Masque de sous-réseau
- nom de domaine
- Serveur de temps
- Nom du fichier de démarrage pour le démarrage sur le réseau
- Autres paramètres de configuration personnalisés ou spécifiques au fournisseur
Les options DHCP permettent une configuration réseau plus flexible et plus complète pour les appareils clients, en leur permettant de recevoir automatiquement tous les paramètres nécessaires de la part du serveur DHCP pour fonctionner correctement sur le réseau.
Consultez le guide DHCP pour obtenir des informations détaillées sur les options DHCP et les détails de validation des champs.
Format de nom d'hôte par défaut de RoomOS :
SEP <MAC>— où <MAC>représente l'adresse MAC de l'appareil.
Identifiant de classe RoomOS DHCP Option 60 :
Cisco : Codec:1.0
Liste des demandes de paramètres RoomOS DHCP Option 55
options IPv4
| Valeur | Nom | Description |
|---|---|---|
| 1 | masque de sous-réseau | Le masque de sous-réseau du client. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 3 | routeurs | Spécifie une liste d'adresses IP pour les routeurs du sous-réseau du client. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 6 | serveurs de noms de domaine | Spécifie la liste des DNS disponibles pour le client. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 12 | nom d'hôte | Le nom du client. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 15 | nom de domaine | Le nom de domaine que le client doit utiliser pour la résolution des noms d'hôte DNS. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 18 | chemin des extensions | Spécifie une chaîne qui identifie un fichier pouvant être récupéré via TFTP. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 28 | adresse de diffusion | L'adresse de diffusion utilisée sur le sous-réseau du client pour transmettre les paquets de diffusion. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 42 | serveurs NTP | Spécifie la liste des adresses IP des serveurs NTP (Network Time Protocol) mis à la disposition du client pour la synchronisation de l'heure. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 43 | options encapsulées par le fournisseur | Options des fournisseurs. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 66 | nom du serveur FTP | L'adresse du serveur TFTP lorsque le champ « sname » de l'en-tête DHCP est utilisé pour transmettre les options DHCP. Cette option identifie le serveur TFTP que le client doit contacter. Reportez-vous à la RFC 2132 pour plus d'informations. |
| 119 | recherche de domaine | Spécifie l'option de liste de recherche de domaines utilisée par les clients pour résoudre les noms d'hôte via le DNS. Cette option permet au client de rechercher plusieurs domaines lors de la résolution de noms. Reportez-vous à la RFC 3397 pour plus d'informations. |
| 120 | serveurs SIP locaux | Spécifie l'option DHCP utilisée pour fournir l'adresse du serveur SIP (Session Initiation Protocol) aux clients. Cette option permet aux appareils de découvrir les serveurs SIP de manière dynamique via DHCP. Reportez-vous à la RFC 3361 pour plus d'informations. |
| 150 | cisco-TFTP | Spécifie l'option DHCP utilisée pour fournir un tableau d'adresses de serveurs TFTP (Trivial File Transfer Protocol) aux clients. Cette option permet aux appareils de découvrir plusieurs serveurs TFTP de manière dynamique via DHCP. Reportez-vous à la RFC 5859 pour plus d'informations. |
| 242 | serveur tms local | Spécifie l'adresse IP locale du serveur Telepresence Management Suite (TMS), permettant aux clients de localiser le TMS et de communiquer avec lui à des fins de gestion et de provisionnement. |
| 252 | wpad | L'emplacement du serveur Web Proxy Auto-Discovery (WPAD) qui héberge le fichier de configuration automatique du proxy (PAC), qui permet aux clients de découvrir et de configurer automatiquement les paramètres du proxy pour l'accès au réseau. |
options IPv6
| Valeur | Nom | Description |
|---|---|---|
| 16 | dhcp6.vendor-class | Les clients utilisent cette option pour spécifier le fournisseur qui a fabriqué le matériel sur lequel ils fonctionnent, ce qui permet aux services réseau d'adapter les configurations ou les politiques en fonction du fournisseur de l'appareil. Reportez-vous à la RFC 8415 pour plus d'informations. |
| 17 | dhcp6.vendor-opts |
Les clients et les serveurs utilisent cette option pour échanger des informations spécifiques aux fournisseurs, ce qui permet une communication et une configuration personnalisées en fonction des données définies par le fournisseur . Reportez-vous à la RFC 8415 pour plus d'informations. |
| 21 | noms de serveurs dhcp6.sip | Spécifie les noms de domaine des serveurs proxy sortants SIP utilisés par le client pour acheminer le trafic de signalisation SIP. Reportez-vous à la RFC 3319 pour plus d'informations. |
| 22 | adresses de serveurs DHCP 6. SIP | Spécifie les adresses IPv6 des serveurs proxy sortants SIP utilisés par le client pour acheminer le trafic de signalisation SIP. Reportez-vous à la RFC 3319 pour plus d'informations. |
| 23 | serveurs de noms dhcp6 | Spécifie les adresses IPv6 des serveurs DNS récursifs que les clients utilisent pour convertir les noms de domaine en adresses IP. Reportez-vous à la RFC 3646 pour plus d'informations. |
| 24 | dhcp6. Domain-search | Spécifie les noms de domaine inclus dans la liste de recherche de domaines que les clients utilisent pour résoudre les noms d'hôte qui ne sont pas des noms de domaine complets. Reportez-vous à la RFC 3646 pour plus d'informations. |
| 31 | serveurs DHCP6. SNTP | Spécifie la liste des serveurs SNTP (Simple Network Time Protocol) mis à la disposition du client à des fins de synchronisation de l'heure. Reportez-vous à la RFC 4075 pour plus d'informations. |