Water Mark
Mar 16, 2020 | view(s) | people thought this was helpful

Error: 'Can't connect securely to this page' While Accessing Webex Sites

Error: 'Can't connect securely to this page' while accessing Webex sites.

Unable to access Webex website, getting error: 'Can't connect securely to this page'.

To continue using Webex, please upgrade your browser to IE11 or higher, or use Google Chrome or Firefox browsers.

 

Since August 03, 2018, Cisco only allows connections using Transport Layer Security (TLS 1.2). Users connecting from operating systems and browsers that do not support or are not configured to use TLS 1.2 will not be able to start or join meetings.

If TLS 1.2 is disabled in your browser, the connection between Webex web servers and your browser will not be established. Any code changes in the Webex client will not take effect on your computer. Users will receive the following error, while accessing the Webex site:

User-added image

Cisco Webex Business Suite 33.6 and above
If the site is enabled with Modern View, users connecting from operating systems and browsers that do not support, or are not configured to use, TLS 1.2, will receive the following error:
User-added image

For help enabling TLS 1.2 and more info about the changes, see: TLS 1.2 Required in Cisco Webex Meetings

Was this article helpful?

Related Articles

Recently Viewed

×