Como faço para usar o Fiddler para capturar o tráfego da Web?
Se precisar capturar registros HTTPS para solucionar problemas, você pode baixar, instalar e usar a ferramenta Fiddler.
Como faço para usar o Fiddler para capturar tráfego na web?
Como faço para usar o Fiddler?
Como configuro o Fiddler para descriptografar o tráfego HTTPS?
Solução:
O Fiddler é usado para realizar capturas HTTPS para produtos como Cisco Jabber o aplicativo Webex Desktop e outras integrações similares. Os dados capturados pelo Fiddler devem ser adicionados a um tíquete da web ou encaminhados para o suporte técnico da Webex para agilizar a resolução de problemas.
Para usar o Fiddler para capturar tráfego HTTPS:
- Baixe e instale o Fiddler em https://www.telerik.com/download/fiddler.
- Clique no botão Iniciar para abrir o menu Iniciar.
- Selecione Fiddler 4 (ou sua versão atual do Fiddler).
O aplicativo Fiddler é exibido.
- Vá para o menu Ferramentas > Opções...
A janela “Opções” é exibida.
- Vá até a guia HTTPS.
- Marque as caixas Capturar conexões HTTPS e descriptografar tráfego HTTPS e clique no botão OK.
- Sobre o certificado “Trust the Fiddler Root certificate?” No aviso de segurança exibido, clique no botão Sim.
- Na caixa de diálogo “Aviso de segurança”, clique no botão Sim. Siga as instruções para adicionar o certificado.
- Nota: O Mozilla Firefox não usa as configurações de proxy e certificado do sistema por padrão e requer algumas configurações adicionais. Para obter ajuda, consulte: WBX9000030844 - Configurando o Mozilla Firefox para Fiddler para capturar tráfego HTTPS
- Feche e reinicie o programa para o qual você deseja coletar registros.
- Reproduza o problema para que o erro ou problema relatado ocorra.
- Volte para a janela do Fiddler e vá para Arquivo > Salvar > Todas as sessões... .
Forneça os registros do Fiddler ao agente de suporte técnico junto com um resumo das etapas para replicar o problema.
Para remover o certificado do Fiddler:
- Vá para o menu Iniciar > Todos os programas > Fiddler 4 (ou sua versão atual do Fiddler).
- Vá para o menu Ferramentas > Opções... .
A janela “Opções” é exibida.
- Vá para a guia HTTPs.
- Clique em Ações e selecione Remover certificados de interceptação no menu suspenso.
- Na caixa de diálogo exibida, clique no botão Sim.
- Clique no botão OK.
Este artigo foi útil?