Как использовать Fiddler для захвата веб-трафика?
Если вам необходимо записывать журналы HTTPS для устранения неполадок, вы можете загрузить, установить и использовать инструмент Fiddler.
Как использовать Fiddler для захвата веб-трафика?
Как использовать Fiddler?
Как настроить Fiddler для расшифровки HTTPS-трафика?
Решение:
Fiddler используется для захвата HTTPS для таких продуктов, как приложение Webex Desktop Cisco Jabber App и другие аналогичные интеграции. Данные, собранные Fiddler, следует добавить в веб-заявку или передать в службу технической поддержки Webex, чтобы ускорить решение проблем.
Чтобы использовать Fiddler для сбора HTTPS-трафика, выполните следующие действия:
- Скачайте и установите Fiddler с сайта https://www.telerik.com/download/fiddler.
- Нажмите кнопку «Пуск», чтобы открыть меню «Пуск».
- Выберите Fiddler 4 (или текущую версию Fiddler).
Появится приложение Fiddler.
- Перейдите в меню «Инструменты» > «Параметры»...
Появится окно «Опции».
- Перейдите на вкладку HTTPS.
- Отметьте флажки Захват HTTPS-подключений и Расшифровка HTTPS-трафика, затем нажмите кнопку ОК.
- В разделе «Доверяете корневому сертификату Fiddler?» В появившемся окне безопасности нажмите кнопку «Да».
- В диалоговом окне «Предупреждение безопасности» нажмите кнопку «Да». Следуйте инструкциям, чтобы добавить сертификат.
- Примечание. Mozilla Firefox по умолчанию не использует системные настройки прокси-сервера и сертификата и требует дополнительной настройки. Справку см. в разделе: WBX9000030844 — Настройка Mozilla Firefox для Fiddler для захвата HTTPS-трафика
- Закройте и перезапустите программу, для которой вы хотите собрать журналы.
- Воспроизведите проблему, чтобы возникла ошибка или проблема, о которой было сообщено.
- Вернитесь в окно Fiddler, затем выберите «Файл» > «Сохранить» > «Все сеансы»... .
Предоставьте агенту технической поддержки журналы Fiddler вместе с кратким описанием шагов по устранению проблемы.
Чтобы удалить сертификат Fiddler, выполните следующие действия:
- Перейдите в меню «Пуск» > «Все программы» > «Fiddler 4» (или текущую версию Fiddler).
- Перейдите в меню «Инструменты» > «Параметры»... .
Появится окно «Опции».
- Перейдите на вкладку HTTPS.
- Нажмите «Действия», затем выберите «Удалить сертификаты перехвата» в раскрывающемся списке.
- В появившемся диалоговом окне нажмите кнопку Да.
- Нажмите кнопку «ОК».
Была ли статья полезной?