What Security Certificates Do I need to Trust for Cisco Jabber?

What security certificates do I need to trust for Cisco Jabber?

What Root Certificate Authorities (RCA) are used with Cisco Jabber?

What will happen if I don't trust certificates during logging into Cisco Jabber?

Error: 'Cannot communicate with the server' when trying to log in to Cisco Jabber.

I'm not able to log in to Cisco Jabber due to certificate problems.


Note:

You may need help from your local computer support or IT department to do the steps in this article.


Cause:

If Cisco Jabber is unable to authenticate due to invalid or untrusted security certificates, you may see the following error:

 

Solution:

To establish a proper trust relationship between the Jabber client and the Webex Messenger Cloud you need to have the following certificates in your Trusted Root CA Store:

Root CAs

  1. QuoVadis Root CA2

Intermediate CAs

  1. HydrantID SSL ICA G2
 

Why do older versions of Jabber work without these certificates?

Starting in Jabber 9.6 Cisco introduced mandatory certificate checking requirements. These certificate checks are being rolled out incrementally in different versions of jabber. Depending on your version of Jabber you may need to trust one or all of the Root Certificate Authorities.

What will happen if I don't trust these certificates?

Jabber will reject the connection to whichever server you are trying to connect to. This can cause various problems including, but not limited to, inability to login, send or receive screenshots, start desktop share or see presence status.

To get the certificates:

  1. Close completely out of Cisco Jabber.
  2. Use the links above to download and save the files to your local computer.
  3. Once the certificate files are downloaded, import them to your certificate store.
  4. After the files are imported, relaunch the Cisco Jabber client.

For help with importing the certificates see the following:

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