Error: 'Auto account creation failed 31'
For site admins to troubleshoot Auto account creation failed errors.
ISSUE
Users may encounter an error message stating Auto account creation failed 31 when creating a new Single Sign-On (SSO) account on a Webex site. The error message may appear as Error: 'Auto account creation failed 31.'
RESOLUTION
To resolve the "Auto Account Creation Failed 31" error:
- If your SAML assertion includes the 'Member Status' attribute, remove it from your assertion.
- Log in to your Control Hub.
- Navigate to the Users section to make sure host accounts are available.
- Check for the pending account approvals.
- Confirm all required fields are included when using APIs to create user accounts:
- Log in to your Control Hub.
- Navigate to Users > Manage Users > Add User.
- Ensure all fields marked with asterisks (*) are provided during account creation.
- Log in to your Control Hub.
- Navigate to Users > Manage Users > Add User.
- Uncheck the Show active accounts only box.
- Search for the host using the User name or Email field.
- If the account is inactive, you can activate it by checking the box in the Active column and clicking Submit.
Note: Attributes such as 'uid' and 'updatetimestamp' are not required for auto account creation.
CAUSE
The error can occur due to several reasons:
- The site lacks a partner ID.
- An existing account for the host is either deactivated or pending approval.
- Mandatory fields are missing in the SAML response during the account creation process. The required fields include:
- User Name
- First Name
- Last Name
- There are no available host licenses on the Webex site.
- The Member Status attribute is included in the SAML response, which is not necessary.
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