Error: 'Auto account creation failed 31'
For site admins to troubleshoot Auto account creation failed errors.
Error: 'Auto account creation failed 31'
Null Error number - 31
Error code 31 when creating a new SSO account
Error: 'Reason: Auto Account Creation failed (31).'
Cause:
This error may be caused for the following reasons:
- The site doesn't have a partner ID.
- An account already exists for the host that is attempting to login but it is deactivated, or pending approval.
- Required fields are not being passed to the Webex site during the account creation process.
- The following fields are always required, and must be present in the SAML response:
- User Name
- First Name
- Last Name
- The following fields are always required, and must be present in the SAML response:
- There are no free host licenses left.
- The Member Status attribute is present in the SAML response.
Solution:
Note: If your SAML assertion contains the 'Member Status' attribute, remove this entry from your assertion before performing the steps below. The Member Status attribute is not required in a SAML assertion.
Site Administrators only
See the bullet points below to troubleshoot the issue:
Account has never worked
- Verify your Webex site has free host account seats:
- Log in to your Webex Site Administration page. (Example: https://SITENAME.webex.com/admin.php)
- In the Site Information section, verify there are free host accounts.
- Check to see if the account is pending approval
- If using API's to create user accounts, verify all required fields are being passed to the Webex site.
- To verify the required fields:
- Log in to your Webex Site Administration page. (Example: https://SITENAME.Webex.com/admin.php)
- Click on User Management > Add User link on the left side of the page.
- All fields with asterisks (*) are required and must be passed during the account creation. Scroll down the page and scan all available fields to check for required info.
- To verify the required fields:
Account has previously worked
- Verify the host account is active on the Webex site:
- Log in to your Webex Site Administration page. (Example: https://SITENAME.webex.com/admin.php)
- Click on User Management > Edit User link on the left side of the page.
- Uncheck the Show active accounts only box.
- In the User name: or Email: field, enter search criteria for the host, then click the Search button.
- If the account displays, but is not showing as active, check the box in the Active column, then click the Submit button.
If the issue persists, contact Technical Support.
Note: The uid and updatetimestamp attributes are not mandatory for auto account creation.
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