In this article
Configure a customer support upload URL
Remote problem report creation with XSI
Set up Problem Report Tool (PRT)
list-menuIn this article
list-menuFeedback?

This Help article is for Cisco Wireless Phone 9821 registered to Cisco Unified Communications Manager (Unified CM).

Users submit problem reports to you with the Problem Report Tool.

The Problem Report Tool logs are required by Cisco TAC when troubleshooting problems. The logs are cleared if you restart the phone. Collect the logs before you restart the phones.

To issue a problem report, users access the Problem Report Tool and provide the date and time that the problem occurred, and a description of the problem.

If the PRT upload fails, you can access the PRT file for the phone from the URL http://<phone-ip-address>/FS/<prt-file-name>. This URL is displayed on the phone in the following cases:

  • If the phone is in the factory default state. The URL is active for 1 hour. After 1 hour, the user should try to submit the phone logs again.
  • If the phone has downloaded a configuration file and the call control system allows web access to the phone.
  • The Customer Support Upload URL field isn't configured correctly.

    You must add a server address to the Customer Support Upload URL field on Cisco Unified Communications Manager.

  • The phone isn't assigned with an IP address.

If you are deploying devices with Mobile and Remote Access (MRA) through Expressway, you must also add the PRT server address to the HTTP Server Allow list on the Expressway server.

Configure a customer support upload URL

You must use a server with an upload script to receive PRT files. The PRT uses an HTTP POST mechanism, with the following parameters included in the upload (utilizing multipart MIME encoding):

  • devicename (example: SEP001122334455)

  • serialno (example: FVH295131MU)

  • username (the username configured in Cisco Unified CM, the device owner)

  • prt_file (example: prt-log.tar.gz)

A sample script is shown below. This script is provided for reference only. Cisco does not provide support for the upload script installed on a customer's server.

<?php

// NOTE: you may need to edit your php.ini file to allow larger
// size file uploads to work.
// Modify the setting for upload_max_filesize
// I used:  upload_max_filesize = 20M

// Retrieve the name of the uploaded file 
$filename = basename($_FILES['prt_file']['name']);

// Get rid of quotes around the device name, serial number and username if they exist
$devicename = $_POST['devicename'];
$devicename = trim($devicename, "'\"");

$serialno = $_POST['serialno'];
$serialno = trim($serialno, "'\"");

$username = $_POST['username'];
$username = trim($username, "'\"");

// where to put the file
$fullfilename = "/var/prtuploads/".$filename;

// If the file upload is unsuccessful, return a 500 error and
// inform the user to try again

if(!move_uploaded_file($_FILES['prt_file']['tmp_name'], $fullfilename)) {
        header("HTTP/1.0 500 Internal Server Error");
        die("Error: You must select a file to upload.");
}

?>

The phones only support HTTP URLs.

1

Set up a server that can run your PRT upload script.

2

Write a script that can handle the parameters listed above, or edit the provided sample script to suit your needs.

3

Upload your script to your server.

4

In Cisco Unified CM, go to the Product Specific Configuration Layout area of the individual device configuration window, Common Phone Profile window, or Enterprise Phone Configuration window.

5

Check Customer support upload URL and enter your upload server URL.

http://example.com/prtscript.php
6

Save your changes.

Was this article helpful?
Was this article helpful?